"Looking for your Roon Core" - but it hides..... Come out, come out wherever you are [Solved - Subnet Issue]

I have spent a lot of hours looking at “Looking for your Roon Core” on my iPhone, Kindle Fire and Microsoft Surface. I have found my core with both my iPhone and Fire, but not at the same time. I can view it from only one machine at a time and that is not useful.
Help advises me to ensure that Roon is configured to accept remote connections. https://kb.roonlabs.com/Why_can’t_Roon_Remote_Connect%3F
Trouble is that when I navigate to “Settings” in Roon, there is no option to “Accept connections from Remotes”, despite what the help clearly says. Why have advice in a help file that is wrong? Careless and not impressive for software that costs so much.
My Roon is part of my Grimm Mu1. It works just fine - but I need to be able to control it from more than one place. Anyone know how?

  • Details on your Core machine (OS, Hardware specs, Roon build)
    Core Machine is an integral part of the Grimm Mu1. Version 1.7 build 571

  • Details on your Remote(s) (OS, Hardware specs, Roon build)
    Originally set up on a Kindle Fire. Now running nicely on a iPhone XS. Cannot now link to the Fire - or a Microsoft Surface running Windows 10.

  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
    Network is cabled and wireless. Grimm is wired. All connection devices are wireless (Eero). All running on the same network. All have different IP addresses.

  • Audio devices in use
    Dutch 8cs

  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)
    No storage. All music streamed with QoBuz

I’d post to the support forum. Sounds like a network issue.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicat

I moved this thread to Support.

Hi @Peter_Bevis,

When you are unable to find the Core, what do you see? Do you have one remote connected to one access point while the other connected to a different one? Is the behavior the same when they’re connected to the same access point?

This is the “Looking for Roon” Screen. The Grimm MU1 and therefore the core, are hard wired into a TP-Link switch which is in turn connected to the router. Three EERO wireless units create the wireless network. They are also all connected to the TP-Link switch. I do not have a wired remote option to try. All three (MS Surface, iPhone and Kindle Fire) are connected wirelessly to the EERO network, which is connected to the same switch that runs the Grimm MU1 and thus the core.

Click on help and see what that brings you to.

You can enter the IP address of the core there.

And lo… It did connect. Gosh. Thank you.

1 Like

And the Kindle fire has connected. I feel sure I tried that a few days ago, but whatever. Telling it the IP address worked, so thank you very much for your help.

1 Like

Clicking on the help button to get to the IP address isn’t exactly intuitive!!! So I can see why you never got there.
You will hopefully find that once you have done it once 8t will work OK in future.


And… It has gone again. And entering the IP address does not find it again. This is very frustrating. Fortunately it is working fine on my iPhone, but I would like other remotes - remotes that don’t just disappear an hour later.

Hi @Peter_Bevis,

Can you try to input into the IP address field and see if that helps?

That’s a multicast broadcast IP, if that works it is possible that your router is having issues with multicast packet routing.

Mesh network…again

No, that ( into the IP address field) did not work…

Oh… Now Roon has died on my iPhone and cannot reconnect. It is now working only on my Kindle Fire. My children make more reliable software than this. To have invested so much in a Grimm Mu1, that needs Roon, and then to find that Roon is so flaky. It is worrying. Every other item of software on all these machines works perfectly. Never had any sort of networking problem. The common enemy is Roon, which appears to be at best temperamental and at worst a pile of poo.
Damned shame, because when it works, I love it. When it dies, I hate it.

Please can I return to my first question. The Roon Help says there is a switch to toggle “accept connection from remotes” / “do not accept connection from remotes”. I cannot find this switch. Should I look harder?
Does it exist? Is it a feature now removed and the help is wrong? Do I have a version of Roon that can only accept one connection - no remotes? Is Roon just a pile of poo? (Seems unlikely - someone would have noticed)


Hi @Peter_Bevis,

No, this option shouldn’t appear on devices running RoonServer, just on Cores that can run Roon UI + Core capabilities.

Have you tried to remove the Grimm MU1 from the equation completely? I would try to use the Windows PC as a Core to see if you can reproduce these issues, as if the issues occur only with the Grimm, we should also loop in Grimm support.

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Is your wireless Eero network getting DHCP from the wired router or is it acting as its own DHCP server? It might be creating a double NAT and a seperate subnet on yout network which Roon cannot cross over. Can you post your ip address for the deivce the core is on and what the remotes are?

1 Like

I’ve happily been using Roon with my Eero network, wirelessly, without issues. So know Roon can work well on a wireless-mesh network.

Really? The Grimm Mu is a £10,000 streamer built on Roon. You think maybe it is a pile of poo too? It does seem unlikely. Mind you Roon is not inexpensive as software goes and it is frankly the most irritating and flakey bit of software I have ever had the misfortune to buy. I have a lifetime license for something that works today and does not work tomorrow. I am not a network technician. I bought a record player and it is frankly disappointing that it does not work. Every other App on my phone works. All software on the network works. The Roon hub is running on the network at and sometimes I can connect to it and sometimes I cannot. When I can connect Roon is a wonder. When I cannot I curse it. At this price I think it should work. I should not have to learn how a network works. I am simply a customer and it should work

And breath… bloody thing still does not connect, but strangely simple feel better.

And ten minutes after posting this my iPhone connects. Sheesh. I should moan more often. But of course now the Kindle Fire won’t connect.

1 Like