Looking for your Roon Core”

Roon Core Machine

Nucleus

Networking Gear & Setup Details

Xfinity router - connected via Ethernet

Connected Audio Devices

Chord Qutest DAC

Number of Tracks in Library

20000

Description of Issue

Installed new SSD that you sent. Everything booted up and started working for a while. Then started getting the “Uh, Ohh something’s not right” message and then connection is lost. Now I just get a constant “Looking for your Roon Core” message on both ipad and iPhone.
I’m pretty close to just giving up - I love the software and appreciate that everyone’s set up is different but Im so sick of this not working. Please contact me via email because last time a Moderator merged my thread with someone else’s and then I got blamed for doing it by a poster trying to help!!

1 Like

Hey @Anthony_Shefferd,

Thanks for your patience while we continue to work through each thread. I’m so sorry to hear you’ve hit more issues with your Nucleus. Not having basic access to your music can be immensely frustrating!

I was able to see your previous exchange with @Wes and that we sent you a new SSD with ROCK preinstalled, and from there we got you back up on the proper Nucleus OS.

From your description, I can’t yet fully determine the issue to be tied to the Nucleus itself. If you pull up the webUI of the Nucleus, what do you see?

I see that your iPad and iPhone have both been online recently, are you still running into issues?

Unfortunately, I can’t access the WebUI. When I click on the IP address all I get is “Safari cannot open the page because it could not connect to the server”
Is there another way of getting to it other than via the “ Configure Roon OS devices on your network” link?

Hey @Anthony_Shefferd,

The Web Interface can also be accessed by:

  1. Typing in the IP Address of the RoonOS Device in a Web Browser

  2. Typing the hostname, for example http://rock , http://nucleus , or http://nucleusplus

  3. Typing the .local suffix for the device, for example http://rock.local , http://nucleus.local , or http://nucleusplus.local

Let me know if you’re able to access the webUI from any of the above. If not, could you please plug a monitor into the Nucleus and reboot the device? Let me know what you see on the screen.

I couldn’t connect so I plugged a tv and usb keyboard into the Nucleus. I typed “reset network” and then I was able to bring up the WebUI screen. I reinstalled the operating system and firmware and then I was able to resume playing music - for about 30 minutes. Several times during this session I was getting a message where it was “Waiting for your Roon Core” with the blue wheel countdown and the interface came back several times. However, now I’m back with the “Uh, oh something’s not right” message and I’m back to square one now and cannot connect again. If I click on Select a different core, it finds the Nucleus and shows it with a green dot so I hit the Ready icon, but it just goes back to the “Waiting for your Roon Core” message again.

Hey @Anthony_Shefferd,

Thanks for the update! You did jump ahead a bit on the reinstall and firmware, but good things to test nonetheless. Do you have a recent backup saved?

If yes, I would suggest resetting the database via webUI, and then testing things on a fresh database (not yet restoring from a backup) to test for database corruption.

Let me know if you’re able to give this a go! We’ll continue to investigate diagnostics on your nucleus as well.

I managed to reconnect to the WebUI but only after switching the Nucleus off and back on - that seems to make it detectable again. I did (only) a Database restore and it has rebuilt successfully. I have been done this before and it works for a while and then fails.

Do you believe that my Nucleus is functioning correctly and it’s more of a connectivity problem, or does this look more like some sort of intermittent hardware issue?

Please keep this thread open as I’m not confident this is a permanent solution.

Thanks for your help.

1 Like

Hey @Anthony_Shefferd,

Good to know!

This pattern of errors can point to SSD failure, if the same thing happens again within a similar timeline we would want to enable diagnostics again on your Nulcues to further investigate the system for such a failure. I will certainly keep this thread open so we can continue to monitor things for now. :+1:

As suspected, that didn’t last long and I was unable to progress far enough to play any music.
Now I have the “Waiting for your Roon Core” followed by the “Uh, oh something’s not right message” again. If I click on “Select a different core” I see the Choose your Roon Core screen with my Nucleus with a green Ready icon. If I try and connect it just follows the same series of error messages.
I was shipped a replacement SSD a few weeks ago and successfully installed it, but that doesn’t seem to have resolved the issue.

A bit more info and another question; I had the WebUI still on my iPad so I tried a reboot via the red power icon. After about a minute I got the “Device could not be rebooted. Please check your network connection.” How can there be a connection problem when the Nucleus is hard wired via Ethernet? My router shows that it is - so I assume it’s not a defective cable?

Hey @Anthony_Shefferd,

Thanks for the updated info.

Even with a hardwire connection, there could be some restrictions being hit from the handshake between your router and core device.

What is the specific router model of your Xfinity router? Can you confirm that both Roon.exe and RAATServer.exe are added as exceptions on your router firewall?

I would also pull up your router settings and review anything within your multicast settings. If you can, I would test disabling any multicast settings to see how things run.

Let me know, and I’ll be awaiting your reply. :pray:

Thanks for the update. It’s Model X5001 but I have no knowledge of how to check for what you’re asking. Over the weekend I decided to disconnect the Nucleus from the Xfinity router and take the “Forget this Device” from the Xfinity app. I then rebooted the router, reconnected the Ethernet cable and “discovered” the Nucleus again after rebooting the Nucleus again. Things are much better at the moment - no more “Uh, oh something’s gone wrong” messages. When I open Roon Remote it does not find the Nucleus, but if I take the “Configure…….” link it does find it. So I am up and running again!
The artwork is missing on the iPad so I reinstalled Roon Remote and that fixed it for a moment, but it’s gone again. When using Roon Remote on my iPhone the artwork is there.
So overall, disconnecting (forgetting the device) then “reinitializing” the Nucleus on the router may have resolved this?!

Hey @Anthony_Shefferd,

That could certainly be the case! I’ll keep this thread open for now while you continue to test.

Is this all artwork? Or, just artwork on local files? If you could share a time stamp of when you pull up an LP that doesn’t load, that would be helpful. :pray:

So I’m now experiencing the same issues as before - “Waiting for your Roon Core” followed by “Uh oh, something’s not right”.
Sometimes if I switch the Nucleus off and then back on it will work temporarily.
Where do we go from here?

Hey @Anthony_Shefferd,

Ah, I’m sorry to hear you’ve run into some more trouble! I’m not able to grab diagnostics from your Nucleus. Would you be able to send over a set of manual logs? You use the directions found here and send over a set of logs to our File Uploader.

Are you able to pull up the webUI again? Sharing a screenshot of this would be helpful. Has anything changed within your network setup?

This topic was automatically closed after 45 days. New replies are no longer allowed.