Looking for your Roon Core

Core Machine (Operating system/System info/Roon build number)

Laptop using Windows 10, install latest Roon.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Laptop connect to wifi, my ipad connect to the same wifi network.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

CH Precision I1

Description Of Issue

My Ipad/iphone are stucked at Choose your roon core - Looking for your roon core screen.
I checked Roon and RAATServer both allowed for public and private on my windows firewall.
My laptop says: CH Precision I1 is UNCERTIFIED!, but on the system it is Roon Ready! How come?

Hi @Kiet_Vuong,

Welcome to the forum.

Do you actually see the Core listed there and you’re failing to connect or does it not show up at all?

Have you made sure that your network is set to “private” and not “public” on the PC? You can use these instructions to verify this aspect. Do you have any other Antivirus Firewalls in place?

Can you provide some more information regarding the model/manufacturer of your router and any switches/range extenders/powerline adapters, access points? Is your Core and iPad on the same subnet as the Core?

In our device catalog, I see that this device started the certification process but did not yet complete it, let me double check with the hardware team to make sure that this is info is correct.

Hello @Kiet_Vuong,

The CH-Precision I1 is currently undergoing Roon Ready certification.

Once the device has completed the certification process, your Roon Core will automatically update itself with the correct certification status for the device in the background.


Hi Noris,

  1. After running the Roon app on Ipad, it keeps looking for Roon Core and nothing happens.

  2. My Laptop Roon Core is connected on Private. I am using NOD32 Antivirus, so only Windows Firewall is activated.

  3. My IPS modem goes to Draytek Vigor2925 Series Modem.
    then goes to Extreme Networks Patch Panel (I think this is the model: NBD AHR 16569)
    then my access point wifi Extreme Networks (AP-7622-68B30-1-WR)

How do I check my ipad is on the same subnet as the Core (my laptop)?

  1. Waiting for CH I1 certified to get rid of the red warning!

PS: I can only reply to this forum, not via my email right? As I already reply on the email you replied to my, but not receiving anything after 7 days!


Hi @Kiet_Vuong,

Thanks for the info, to address a few of your questions and provide some suggestions:

Have you added Roon as an application exception into NOD32? I have seen some reports that NOD32 firewall blocks Roon as well, so I would check this by temporarily disabling the NOD32 firewall to see if it triggers a change in behavior.

Do you know how to access the Access Point/router settings? I would double check to make sure that “Multicast” is enabled after you have checked the NOD32 firewall.

You can us a network scanning app such as FING. If the IP of the Core and iPad have all the same digits except for the last 3, they are on the same subnet.

Yes, this is correct. The only way to respond to us at this time would be via the Community website, here is a direct link to your thread (Looking for your Roon Core).

Hi again,

I did the below steps but still not able to connect my Ipad to Core!

  1. I added Roon.exe and RAATServer.exe as app exception in NOD32 (in Performance Exclusions and Detection Exclusions).

  2. I found in the settings on my router as in this picture, which one should I tick? Or is there other Multicast?

  3. My ipad IP is:, and my Laptop (core) is They should be on the same subnet.

Hi @Kiet_Vuong,

Is there any change in behavior if you temporarily disable the NOD32 firewall completely?

In the past, both IGMP Proxy and IGMP Snooping has helped with similar behavior, I would try both settings one at a time.

Hi Noris,

Enabled IGMP Proxy and Snooping and with Windows Firewall and NOD32 disabled, it did not help, I still could not connect to the Core.

But, when I checked IGMP Proxy, and IGMP Snooping, I tried to play song on my Core, it connected very slow and the song stooped playing after few seconds. If I disabled IGMP Proxy, and only enabled IGMP Snooping, songs played faster without stopping. If I disabled both, then songs play fastest and no stopping.

Looking for more resolutions.

Hi @Kiet_Vuong,

Thanks for checking the IGMP Snooping/Proxying settings.

I wonder if the WiFi is playing a part in this issue, can you try temporarily connecting the laptop via Ethernet to the router/access point? I suspect that there is something going wrong with the multicast routing on your setup here.

I have the same problem. I try Ethernet everything, no problem for 2 weeks. Call Tech guy run Ethernet cable anywhere I want ( BJ cable Cat 6 in wall ) Over 6 month never have any trouble.

When I connect my laptop to LAN then my iPad can see Roon Core on the laptop!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.