Losing connection, audifile loading slow, etc

I’m having major problems with Roon at my endpoint on a laptop (Windows 10, i7 (sandybridge), 16GB, 250GB SSD) in the livingroom. The Rooncore is situated in my bedroom on an Nuc7i5BNH with Windows 10. All connected at router with cable. Storage is on a Synology NAS D116.
Roon is losing connection, audiofile loading slow or it can’t find the DAC at all! This happens very sudden, in the middle of musicplaying. My core has as a dac a Chord Mojo, my livingroomlaptop has a NuForce-dac. I have tried the Chord Mojo at the laptop, but then I also lose the connection or getting hardware error. So it’s DAC-independent. I checked all the cables (also the usb-cables), I replaced ROCK at the NuC for Windows 10, but nothing seems to help.
I disabled Upnp in my router, disabled flowcontrol in my networkadaptor in Windows. Nothing helps. It happens with Flac files, dts etc.

Can it be the Sandybridge i7, although this is not the core?
So I need some help from you. Hope we can figure out what’s happening.


Hi @PhiloMelos ---- Thank you for the report and sharing these observations you have made with us. The insight is appreciated!

Moving forward, to help us better understand what could be causing this behavior, may I very kindly ask you to please provide me with the following information:

  • If you are to play directly out of the internal speakers of the laptop, thus bypassing the DAC mounted to the device, do you still encounter these errors?

  • During your troubleshooting have you tried (temporarily) attaching the the Win10 laptop directly to your router to see how the endpoint holds up with a wired connection as opposed to WiFi?

  • Please provide the details of your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing.


I’ll try bypassing the dac tomorrow.
The laptop is allready connected to the router with a cable directly. No Wifi here.
1 router with 4 1Gbps ports. Core, laptop, Library on Synology 116 4TB drive, 3 TB music, + 1 tv connected to the router with cat6 cables.

However, the problem started after i put an accesspoint at the router. The first 3 weeks no problems whatsoever.
I got rid of the accespoint, so now it is just the router. Could that have messed things up? I reïnstalled Windows on both machines after that, resetted the router and more.

I had the problems also on the core, but they dissappeared after I installed Win 10, instead of ROCK.

Let me know if there’s anything more you need to know.


Hi @Eric
Okay, I tested Roon playing music through the headphone output of the laptop (thus bypassing the DAC) and there are also dropouts, music stops playing at random. It just stopted playing showing Music device was not found!

In short Rooncore at Nuc7i5, 8GB ram, WD Black PCIe SSD 256GB, Windows 10 64bit, latest build 1709
It has a cabled connection to the Technicolour 7210 Router. A Chord Mojo is connected as a dac.

Roon endpoint with NuForce udac2 at my laptop HP Elite 8560p, i7, 16GB ram, Samsung 250GB ssd, Windows 10 64, latest fall update (1709) (but problems excisted also before the update) I reïnstallled (wiped whole disk) Windows last week, but problems stayed.

The problem excisted also on my RoonCore, till I switched from ROCK to Windows 10. Now the core is playing fine without troubles.

Music (100000 files) is stored on Synology DS116, latest update dsm 6.1.3 WD Red 4TB HDD

Doesn’t matter what kind of musicfile I play, flac, dfs etc.

All network connections are cabled with Cat6 cables.

All firmwares are up to date.

In Roon DSP engine is off


On the laptop, do you have REALtek drivers installed? If so, try uninstalling them and using the basic MS HD Audio drivers. The Realtek drivers have always had issues.

No, i don’t use the realtekdrivers. I only use the nuforce dac for sound. Laptopsoundcard is normally disabled in the bios, so no drivers at all for the soundchip on board.

I thought you mentioned that you had bypassed the NuForce and plugged straight into the headphone out of the laptop. At that point, some driver had to have been loaded.

Which NuForce are you using, I didn’t see the model?

Yes, that was just a test Eric had asked me to do. So I enabled sound in the bios, etc…
Nuforce is 1 of the first models. But, I experience exact the same problems when I connect the Mojo to the laptop. And experienced the exact same problems with the RoonCore using ROCK as os.

Hi @PhiloMelos — Thank you for touching base with me and providing the results of the proposed test. The insight is appreciated!

These issues you are experiencing feel like they are related to some kind of bottle neck occurring in your network configuration. You had mentioned the following in one of your previous posts:

Can you please provide some further information in to the above comment?

Furthermore, while this may seem elementary, have you tried rebooting ALL of your devices since the mentioned reconfiguration (i.e removing the access point)?


Hi @Eric , thnx for looking into my problems.
I noticed the morning after I installed the accespoint, problems when playing music. That was the first time since I used Roon (I think about 4 weeks). I connected the Core directly to the Router.
Don’t recall if the problems went away that moment. I have reïnstalled and resetted all components severall times since, and moved from ROCK to Win 10. Since then no more problems with the Core, only with the laptop. Maybe it’s just coïncidence (the accespoint) and is the new Synology the problem. First 3 weeks I had attached an external usb3 disk at the Core and everything was fine.

Hi @Eric,

Cause the situation got worse I decided to do a clean install of my whole setup. 2 fresh window installs on Core and endpoint, and a clean install of the storage ds116. Till 10 minutes ago all went good. When I checked a minute ago, the endpoint had stopped playing. Sight… But. then I saw the laptop ran out of juice. I had accidently pulled out the plug! So it’s now fingers crossed. Hope to report tomorrow all is still running fine.

For now it’s case closed. Roon has running on the laptop endpoint for over 16 hours without a single problem. I’ll be sure to make good system backup off all the components, so when a problem reoccurs i can easily go back. When I replace the laptop as endpoint for a Nuc I will try Rock again.
Thnx for the help. I now can enjoy again the amazing Roon!

1 Like