Losing connection to the core

Core Machine (Operating system/System info/Roon build number)
Windows 10 home version 1909.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Router - LAN cable - Cisco unmanged switch - LAN cable - Windows PC (Jcat PCIE network card)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Samsung tab A tablet
Goggle pixel3A phone

Description Of Issue
Losing connection to the core. (For all remote devices)

After a few minutes, when the remote is untouched, the connection to the core is lost.
There is also no connection possible when the core is already active for a few minutes and then starting up the remote-app.

Recovering the connection is only possible ;

  • restart the core, or
  • pull out the LAN cable out off the Windows PC and plug it in again.

All IP addresses are in same range and fixed.

Any suggestions?

Can you try another cable? They do go bad.

The fact that it works, for awhile, when you unplug/replug is suspicious.

Could be the Ethernet port.

You can try a USB to Ethernet converter to test that theory.

1 Like

Thnx. But i dont think its a hardware problem.

I’m with Slim.

Hi @Hans_vandenbarg,

Do you have any non-Android remote devices? Do they exhibit the same thing?

Are you able to continue controlling Roon okay during this time on the Windows machine directly?

Hi Dylan,
No other devices.
And yes, roon core keeps running and you can control directly by mouse all the time

Hello @Hans_vandenbarg, do you still have this issue if you use the new cable directly from the router to the core?

you mean; bypassing the switch? I have not tried …
I will en I let you know

1 Like

Yes, I have tried. Same problem. No connection.

Hi @Hans_vandenbarg,

The next time this occurs would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link. Please also let us know the time that the disconnect occurs.


Thanks, @Hans_vandenbarg! Just wanted to let you know that we are continuing to look into this and @nuwriy will follow up with you soon on this.

Hello @Hans_vandenbarg, I have a meeting scheduled with the team to discuss your thread and would like to provide diagnostics from your remotes as well. Could you please open Roon on those remotes for a few moments so their diagnostic reports could upload? Thanks!

Ok. Core and remote is now active .

Hello @Hans_vandenbarg, I wanted to confirm that you’ve tried a different Ethernet cable to the core and that you have reinstalled the app on one of your devices to see if that helps? Let me know!

Yes. I did. And nothing helpes.
At this moment I made the ‘Time-out’ on my samsung tablet inactive. So the tablet keeps continually ‘on’ to maintain the connection. But now the battery is quickly running low.
So I need a solution… please help …

Hello @Hans_vandenbarg, could you tell me what model router you’re using? Also, if you manually enter the core’s IP once the tablet disconnects, are you able to establish a connection? I’d also recommend entering as the core’s IP on the tablet next time the issue occurs to see if that works.

Hi Nuwriy,
router is stock T-mobile Huawei HG659.
If tablet disconnects, I can’t connect again. I only can re-connect if I shut down the core on the server and start-up the core again (by mouse, I dont have to restart the windows pc).
On my router I cant use . I only can pick pre-defined ip addresses in pick-list.
The way I make static ip-address on router : Home network / Lan interface / DHCP reservation /
Kind regards, Hans

Hello @Hans_vandenbarg, my apologies for the confusion here. When your remotes aren’t able to make a connection, you should see a “help” option on your screen where you can manually enter the core’s IP, this is where I want you to enter the multicast address rather than the core’s IP and let me know if that works.

Hi Nuwriy, please be more specific. I am a user. Not an it-specialist. I don’t see a ‘help’ option. Which screen should I look ? at the tablet? or at the windows pc ? I can’t see a help option on both screens.
Please tell me exactly where to look and what to do.
Kind regards, Hans