Loss of connection

Ever since I started using a new MacMini with bootcamp a few months ago I have had problems with Roon losing the connection on my iPhone and iPad.

My setup: Roon server running on MacMini with Windows 7, cable connected to LAN > cable connected Raspberry > stereo.

Asus-Merlin router running latest software. Roon version 1.5.

This is what typically happens:
I start using Roon on my iPhone. No problem. After a few minutes I want to change to a different track, so I call up Roon on the iPhone again. It now refuses to connect. At that point I switch to iPad. It connects fine, I change track. A few minutes later I want to change track again, using the iPad, it now cannot connect. If I am lucky the iPhone can now connect, but quite often it cannot.

I discovered I can “solve” the connection problems by switching off WiFi on either device and switching it on again. Then it connects immediately to Roon, only starting to give me problems again when I try to connect a second time within a short period using the same device.

Any suggestions would be much appreciated.

Thanks for reaching out, @Luke23!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Do you have any active firewall or antivirus software on the Core machine? If so, does temporarily disabling them yield any different results?

Is the phone in sleep mode when you’re starting to use it again? Does it ever disconnect when it’s actively being used?

Do you have any other Mac or Windows device on the network? If you use remote on one of those devices does the same behavior occur?


1 Like

I did describe the network typology.

The firewall is off. Sophos Enterprise is running but I have now disabled the web part of it, so I’ll see if that makes a difference.

The phone are iPhones, so I am not sure what you mean by sleep mode. I guess they are always in lower power mode when they haven’t been used for a few minutes.

No they never disconnect when I actually have a connection.

As to other Macs/Windows machines, I did use Roon on the same machine but running OSX and I never had this problem. I also ran it on a previous MacMini with Windows 7 and did not have this problem either.

I tried it with the virus scanner turned off and it makes no difference. Disabling the WiFi and then enabling it again solves the problem (but this does not mean that on the device the WiFi no longer works for other apps when this happens, it does and I have tested that again and again).

Thanks, @Luke23.

Can you describe the network hardware that’s in use? What kind of router? Any switches or other networking hardware?

If you use an app like Fing that scans the network, can you see the Core machine from the remotes when it’s in this state?


1 Like

I use an Asus with Merlin installed (Asus RT-AC86U). We also have a few passive switches (also Asus). I ran Fing when it happened again just now and yes the server can be seen.

Some further info. If (big IF) Roon comes back later on the same device after it could not find the server, it comes back empty, last played item has disappeared, Queue is empty and it says Nothing Playing.

Maybe a problem with a Bootcamp Windows driver?
Have you (or anyone) successfully used Bootcamp in the past?

Yes, I had it running on my previous MacMini. Worked better than OSX.

Hey @Luke23,

If you don’t use Bootcamp but instead install Roon on MacOS do you experience the same behavior?


Hi Dylan,

Sorry for the tardy reply, I was abroad for the last two weeks. To answer your question: no, under OSX (High Sierra) I do not have these problems. Nor did I have them previously in Windows bootcamp.

Hey @Luke23,

Hope you had a great time during your travels!

Since things are working great on OSX but not Windows, it sounds like there is something specific to the Windows configuration that is causing this issue. Since you’ve confirmed there is no antivirus or firewall active, I think the next step would be to look into the Windows drivers.

I did a search and found some reports of bootcamp having issues with network connectivity due to drivers. When the remotes disconnect can you confirm whether or not the Core is connected to the network?


Yes we did (Armenia and Georgia are wonderful), and yes, I can confirm that the connection to the server is NOT lost because I have no such connection problems on my laptop (likewise connected to network via wifi). Note that the connection problems only occur immediately after a successful connection. The first time I use the Roon app on my iPad or iPhone there is no problem, it just refuses to connect when I return to the (open or closed) app after a few minutes.

Thank you for the additional information here, @Luke23!

Can you confirm what versions of iOS your devices are running?

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thank you,

They both ran iOS 11. To reproduce the issue I will have to return to Windows. Will do so tomorrow and let you know when the problems occurred.

1 Like

Hi Dylan,

I waited a few more days because out of the blue the system started functioning properly again. I made no changes except for updating iOS to 12. Of course that led me to suspect this update solved the issues I was having, only to find that Roon on my wife’s iPhone which was still running 11 also worked properly. So I am at a loss to explain what may have changed. Anyway, I am keeping my fingers crossed and hope it stays like this.

1 Like