Loss of control of audio device

Core Machine (Operating system/System info/Roon build number)

Acer Aspire E1-572G

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

ever after I switched from copper wiring to glass fiber wiring in March the core says: roon last control of audio device. Sonos works fine.

Lost control of what audio devices? You’ve only listed Sonos but say it works fine?

It seems to me all audio devices. I play three wireles sonos speakers and two amynalogue Silbersand speakers through my sonos connect zp 90. All of them work as they have over the last couple of years. But whenever I try to start them playing over my roon it says: lost control of the audio devices, though the devices show on the roon screen.

That is normally a network error. Sonos will work as they have their own internal mesh network whereas roon will use your normal wireless etc.

thank you Ged. I am, as you might have thought, not a tech freak. So I am wondering, how this could be a network error if everything works - just not roon.

If you use other services they send compressed files to the device, do less network traffic, and let the device decompress the file. Roon does the decompression in the roon server and sends out full files across the network.
Also Sonos natively uses it’s own internal WiFi network that allows the multroom bit. Roon uses your home network and it can overwhelm it.

Hi @Hans_Nacke,

If you try to stream via Airplay to the Sonos zone, does that work?
Are you able to start playback to your System Output zone?

thank you Ged and Noris for your answers and your time. But I am afraid, you are too much of tech experts for me to communicate with. I don‘t use Airplay, Noris, and I don‘t even know what to do to playback to my system output.

I like to listen to high quality music streamed by qobuz through my sonos system to my Silbersand speakers. And I thought roon would fit in just nicely, which it has for over a year. But with these technical issues now, I am sorry to say, I am going to give up and not continue my roon subscription beyond this period. Roon requires more of a techie to run it than I am and than I want to be.

So, Noris, thanks again and no bad feelings - but you have lost a client.
Best regards

Hello @Hans_Nacke,

Thanks for the feedback here. If you do not wish to troubleshoot this issue, I can’t force you to, although I certainly would have liked to resolve this issue for you.

My question as to if your Sonos Airplay or System Output zone worked as expected would have provide some more information on if just the current Sonos zones are having issues or if all zones are having issues.

Testing the different zones would have just required you to go into Roon Settings -> Audio and enable the zone and then select it from the Zone picker.

I suspect you might be having a firewall issue here, but as I mentioned, if you don’t want to troubleshoot the problem, then the conversation ends here. If you change your mind and want to work with me to look into this problem further and fix it, please do let me know.

Thank you.

Hi Noris,
your message encouraged me to give it another try.
I have tried the sonos Airplay zones and they don‘t work neither. Then I tried the Laptop output zone and that works. So it‘s just the sonos system (speakers and connect) via Airplay and sonos streaming that do not seem to be able to connect to roon anymore.

Hello @Hans_Nacke,

Thank you for being open to more troubleshooting here. Since the laptop zone works and just the Sonos is affected by this issue, this could be related to the way your Sonos is configured networking-wise.

You mentioned that you have a Sonos ZP90, is this through Wireless or connected via Ethernet cable?
Is there any change in behavior if you try to temporarily connect it via Ethernet cable if it’s on WiFi?

Also, if you have not yet rebooted, I would suggest a reboot (power off, wait a few min, power back on) of your Core, Networking Gear and Sonos ZP90 to see if this helps with the issue.

Hi Noris,
the Sonos ZP 90 only works via ethernet cable. So, no changes to be observed there.

But then I followed your advice and rebooted the Sonos, the router and the core laptop. On that occasion I also updated the core software to Microsoft 10, version 1909. That took more than two hours this afternoon. And now guess what? roon has regained control of the audio device and I can start the sonos speakers plus the connect via sonos streaming through roon again!! And also I can make use again of my remote controls on the Iphone and the Ipad. This is great!

I guess you deserve a medal for your staying cool with your „non-techie“ but frustrated customer and communicating in a friendly and understandable way. So, thanks a million for your support. I’ll happily stay a roon customer.


1 Like

Hello @Hans_Nacke,

That’s fantastic news indeed! I’m glad to hear that the issue is now resolved!

I will go ahead and mark this thread as [solved] but if you have any other issues with Roon, just let us know and we can help, no matter if you’re a techie or a non-techie, we’ll try to help how we can :slight_smile: .

Until next time, take care @Hans_Nacke and thanks for working with us here to resolve the issue!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.