Loss of Local Audio options upon loading Desktop client

Core Machine (Operating system/System info/Roon build number)

Nucleus
OS:
Version 1.0 (build 227) stable
Roon Server Software:
Version 1.8 (build 790) stable
Roon Labs Software:
Version 1.8 (build 790) stable.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router:
Google Nest Wifi
Switch:
Linksys 10/100/1000 8port dumb switch
Network Connectivity:
500/500 Fiber connection
Entire house connected via Gig Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PC:
JDS Labs Objective DAC/JDS Labs O2 Amp, via USB A to Mini-B, HD650
Focusrite 2i2 (3rd Gen), USB C (Focusrite) to USB A plugged into USB C/Thunderbolt hub
Stereo:
BlueSound Node2i into Onkyo HT receiver via RCA
House:
Multiple Chromecast devices

Description Of Issue

After installing the drivers and setting up my focusrite 2i2, I no longer have the ability to utilize my laptop as an audio output source using the local Roon software installed. When initial loading of the application, all of my audio devices are present in the settings menu, but then window flashes like it is refreshing, and all of my audio options disappear. I only really use my JDS labs for audio out (it is almost always set as default) and not sure why I would lose all options post install of Focusrite device.

After playing around in the Settings for a while, the “This PC” option actually disappears, instead of just showing empty.

Testing:
I was able to click disable on local audio out upon initial open, It loses all local options, If i close the app and re-open, then all options are available to choose from for enabling. When I enable, it allows me to enable the local default or ODAC audio outputs, but then when I close the app, it starts the whole refresh/loss of options cycle all over again.

Side note: This could have been going on longer, I haven’t used my Roon desktop software in a few weeks so I don’t know when exactly I stopped having audio access.

This is the listing of my normal, all audio outputs on “This PC”

This is the listing after I close and Re-open the application:

When I click on the Refresh button, this shows but never goes away:

Hello @Zefal! Thanks for reaching out about this issue and for providing those screenshots. That helps a lot. I’m sending this over to our tech team now to look into things in a bit more detail. While we’re waiting, it would be helpful if you could pull logs for the team to review.

Please note the exact local time + date when this issue next occurs and upload your Windows (not Nucleus) Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.

Hello @kirsten, Here are the associated timestamps, and will DM the link for Google Drive logs in a second.

Time Stamps

Open First time with all audio Disabled:
May 18, 2021
1648 PST

1649 Enable both Default and ODAC/AMP
1649 Play first Song using Default audio Zone
1650 Pause music, close roon

1651 Open Roon - Audio Zone no longer selected and no longer listed
1651 Settings Audio - shows No local audio devices, and screen refreshes/glitches every 10 seconds
1653 Close Roon

1654 Open Roon
1654 Settings - Audio - Disable Audio Source
1654 Settings - Audio - 30 seconds after disabling, all local audio devices disappear, and screen starts refreshing/glitching every 10 seconds
1655 Close Roon

1656 Open Roon
1656 Settings - Audio - All local audio options are showing with the Enable option presented, and not disappearing
1658 Close Roon

As a follow up, all of the logs from the 15th are also associated with this issue. I was not listening to any music and all of the opens and closes were tied to this issue.

As per logs, I haven’t used the Roon app since 04/25 it appears, and there were no issues back then.

@Zefal Thanks for the detailed information! We’re taking a look and will be back with you asap!

Hello @Zefal ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Looking over the log set you submitted, there is unfortunately not much information contained in them. I noticed that you are using a Realtek driver here, and there have been similar issues in the past with Realtek drivers.

Can you please try to uninstall the Realtek driver via Device Manager, let Windows re-install the default Realtek driver and verify if that helps? Please let us know, thanks!

Hello, Sorry for the long delay, its been a busy couple of weeks.

  1. Uninstalled the Realtek Driver as requested, and let windows re-install. Still having issues.

  2. Tested a theory, which proved correct, and I have zero explanation as to why (maybe too many possible devices under default?

Theory and test:
Theory: There is something off with my default audio device, like its going through too many options (not sure how default audio option works)

Testing:

  1. Disable all audio settings, close/open roon app, all audio devices show up and stay
  2. Enable only Default audio, close app, reopen app, and audio device options disappear like above.
  3. Disable all audio settings, close/open roon app, all audio devices show up and stay
  4. Enable only my DAC/AMP (WASAPI), Close app, reopen app, zero issuses with my audio devices, and will always work every time app is closed/opened.

Note: My DAC AMP (WASAPI) is set as my default audio device within windows.

and… I have zero ideas why one works, and they other way doesn’t.

Thanks for the descriptive report, @Zefal — That helps a lot!

I’m hoping you can do something to help us collect some more data here.

First, can you share specifically what settings you’re disabling/enabling with screenshots?

Then, please do the following:

  • Reboot your device
  • Reproduce using Roon in the working description you described above, sharing the time you start playback and the name of the track you play
  • Reproduce using Roon in a non-working configuration described above. Also share the time you try to start playback and the name of the track you try to play.
  • After you’ve done this, use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).

We’ll then take a look at the working and non-working logs and will investigate further. Thanks!

This topic was automatically closed after 6 days. New replies are no longer allowed.