Loss Of Output with iMac and Mojo

I have also had this happen repeatedly on my iMac using a Chord Mojo over USB. Just now I was listening to all Roon tracks (nothing from Tidal). While I was listening I was choosing other tracks to play next ranging over my catalog. When this happens, Roon shows the “sound wave” animation next to the next track but it does not play. I also find that it has last the connection with the Mojo. Restarting Roon does nothing. No sound will play from any files and Roon can only find my “System Output” and my “Living Room Apple TV”. The Mojo is connected and on. I can turn off the Mojo and on again, nothing. I tried unplugging the USB for 30 seconds and nothing. After all this tried restarting Roon again - no help. I can’t remember if just logging back in or actually having to restart works. I’m going to try that now - be right back…

I had to do a restart to fix things. Immediately the Mojo was recognized and songs would play through it. Also all of my other outputs were found correctly. When this happens I usually loose all audio outputs except for System Output not just the Mojo. Any ideas?

Hi @John_Dempsey ----- Thank you for the report and my apologies for the wait here.

I wanted to touch base with you and see how things have been holding up since you shared this latest observation with us (i.e things working after a restart). If further assistance is required I will be glad to help.


I can’t really tell you too much more than in the original report. It seems to happen out of nowhere although I have been trying to really pay attention to see if there seem to be any triggers that I can identify. Next time it happens, I’ll let you know here. Thanks.

1 Like

Hi. Still having problems with this. I have a Hugo 2 now with the same problem. I’m investigating if it seems to have anything to do with switching from Tidal music to local. This can happen several times a day. If I restart Roon, it doesn’t always help. If fact Roon seems to “time-out” of something and then I can listen again. I’m going to do more tests.

HI @John_Dempsey ----- Thank you for the update and providing this latest observation. I am sorry to hear that issue has persisted now with the HUGO 2 as well.

Are you still able to readily reproduce the issue? If you are, would you mind replicating the problem a few times, keeping note of the time of day when they occurred, and when I have the requested time frames I can enable diagnostics on your account so we can try to get a sense of what is causing the issue.

Furthermore, you had mentioned in latest post that you were going to conduct some additional test. Just curious if anything note worthy was observed :microscope:


I’ll try this tonight. Unfortunately I can’t predict when this will happen. I might have two problems or one that is exhibiting in a couple of ways. Sometimes I just seem to lose track of the music. The “bars” animation runs next to the selection, the name of the piece appears at the bottom but the progress indicator stays at 0:00. Stopping and starting Roon does not seem to fix this. I think it may just be “fixing” itself over time; like I said before it seems to be “timing out” of something. In this case I still have contact with my DAC. I will see if I can make this happen and then run over to Tidal and make sure that I still have machine contact with the DAC.

I also still have the problem of losing sound sources in Roon. In this case, it seems that maybe Roon could still be poling the choices available (?) but I can wait a long while and my DAC will not appear (and sometimes some of the other outputs don’t appear either).

I would really like to find a trigger here. I’ll see what I can find. Thanks.

Ok. Just had this happen but had trouble duplicating it.

I had a song paused in Roon. Watched a video in YouTube on Safari. Roon correctly released the Hugo from exclusive mode.

Returned to Roon. Progress bar was set to 0:00. I could not play any songs. All of the sources were available and Hugo2 was still selected. When I tried to play a song the song’s title displayed at the bottom on the window, the “bars” animation started, the progress bar was set to 0:00. Nothing happened. Everything reset to no song selected after 15 seconds. I could play no song. Also Roon had not released Hugo 2 in exclusive mode. I could not assign it to any other audio stream through the Mac.

I quit Roon. Immediately it released the Hugo 2 from exclusive mode. Restarted Roon. Tried to replicate the above scenario and it would NOT duplicate.

The time that I noticed the problem was at 8:59:52 PM EST.

I’ll keep working on this and see if I missed anything.


I appreciate the follow up @John_Dempsey! I have went ahead and enabled diagnostics on your account (as mentioned) so we can take a look at the time frame when error occurred in the logs attached to the diagnostics report.


Hi Eric. Had it happen again just now. I was playing an album from Tidal this time (I don’t think the source matters). Paused it for a minute or so. Came back and could not continue play. Same scenario as above. I came back to the Mac between 5:18 and 5:19 PM.

There was an app that was hanging up in the background before I paused but the sound from Roon was continuing just fine. When I returned that app had caught up and was fine.
Doubt if it has anything to do with anything but…

Just restarted Roon and can now play music.

Thanks for the attention.

1 Like

Hi @John_Dempsey ----- Thank you for your continued feedback and more importantly, thank you for your patience. I am sorry for the slow response.

Moving forward, I first wanted to check and see if you have made any progress or new observations in regard to the Hugo2. I also wanted to ask, since reporting this issue have you tested with another USB cable between the computer and the DAC?

Furthermore, I am still waiting on some feedback from the tech team as I can see that your ticket is still in their queue. However, I would like to propose testing with a new “RAATServer” folder in place to see if we can trigger a change in behavior with the Hugo2. Please see below for instructions.

  • Before anything, please make a backup of your current Roon database.
  • Once the backup has been created, please close all active instances of the application.
  • On the core machine open Finder and click “Go” in the top bar.
  • Hold down the “Alt” key to unhide the “Library” folder.
  • Click the “Library” folder and locate your “RAATServer” folder.
  • Once located, please rename the “RAATServer” folder to “RAATServer_Old”.
  • After you’ve renamed the “RAATServer” folder, please launch the application and let me know how things behave.


Eric. Tried your suggestion. Things seemed solid for a while. I was listening to an album. It finished. I got up to do something. When I got back, I couldn’t play anything. No music would play. 15 second timeout as before. Connections were just fine. Hugo and other endpoints were available. Other things were working on the Mac so that could have something to do with it. Previously I thought that this might be connected to somehow confusing Roon with bopping around to and fro but this time I wasn’t even at the computer. Now 20 minutes later, still can’t. When I close and restart Roon. I should be able to play my music again. Yep. That’s just what happened. Is there any way that Roon can be losing the music? I went to the file info for one of the music files and it correctly found it and when I clicked “Open File Location”, it correctly found the file in Finder.

Thanks for getting back to me @John_Dempsey and sharing the observations you made with a new RAATServer folder in place. The update is very appreciated!

Moving forward, I had a chance to discuss this issue you’ve been experiencing with the Hugo2 yesterday with our tech team and as per the conversation I would like to kindly suggest the following moving forward:

  • Please make sure that the batteries are charged in the Hugo2.

  • I checked back through my notes and if you are having to repeat yourself, my apologies :innocent:, but since noticing this behavior with the Mojo and now the Hugo2 have you tried moving the device to a different USB port on the computer?

  • Please provide screenshots of your audio plugins on the iMac hosting your Roon core.


I will check on that tomorrow. The Hugo 2 is continuously plugged in so no battery problems. It occurs to me that I should trying playing through my Audioquest DAC and see if I have the same problem. I would also like to add that I have the problem of “losing” the music more often than I have of dropping my end-points. These seem to be two separate problems so I am not sure that they both (or either one for that matter) has anything to do with the Hugo 2.