Lost “albums by import date” data

Core Machine (Operating system/System info/Roon build number)
Roon 1.7 build 710 running on QNAP TX473 with firmware 4.5.1 build 20210107

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
TPLink switch, Archer VR2800 router and Virgin media super hub modem.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Meridian 210 connected by Ethernet.
Cyrus Signature DAC/preamp connected to streamer via Coax.

Description Of Issue
After updating the firmware today on my QNAP NAS I’ve lost all the recently imported album data when sorting by date added. However, when I go to a particular album I’ve recently imported it gives me the correct imported date - but this isn’t reflected under “sort by import date”.

Under history, everything appears as expected with all the albums and tracks played in the correct order with corresponding dates. On many of these if I then go and search an album it presents it as not having been played before.

This phenomenon first occurred when I changed my SSD in the NAS that contained the ROON core. I restored it from the back up and had lost 3 years worth of data regarding album imported date even though the history was retained correctly.

Any suggestions how to resolve as part of the pleasure of Roon is playing recent discoveries which I can’t now do easily.

Hi @David_Allen,

Can you share a screenshot of Settings > Library > Import Settings > Track Import Dates?

Hi @dylan, when I saw these settings I changed the import date default to “file creation” and it seems to have solved the problem.

It still raises the question of why the problem arose following the firmware update on the NAS. Why would the ROON time stamp not have picked up the correct import date anyway because on each album it states the correct import date.

Was it set to Roon Import Timestamp previously?

For one of the tracks that wasn’t showing properly can you share a screenshot of View File Info?

Yes it was.


Is there any other file info you need?

Thanks @David_Allen. Can you try doing something here?

  • Switch back to Roon Import Timestamp
  • Make a note of the time you make this switch
  • Open up this album — Does the Added date change? Can you share a screenshot?
  • Switch back to File Creation time
  • Also make a note of this time that you change it
  • Open up the album one last time

Once you’ve done this respond with the times and the screenshot. We’ll enable diagnostics and take a look!

Hi Dylan : response as follows.

Switched back to ROON import stamp at 11.15am Thursday 14th January
Import date still shows 5th Sept:

Add images

Also provide screenshot showing relative import date for the album in my collection- you can see it’s a relatively old import ![image|666x500](upload://uIi5OpSTCd3ZXn3GUi2G3o7ttR0.jpeg)

Switched back to file creation time at 11.51am 14 Jan.
Screenshot shows the import date stays the same:

Also provided screenshot of where the album import date now sits in the collection - it vert recent, about page 3.

Hope this helps
Cheers
Dave

Resent the collection screenshot after setting to ROON time stamp


For some reason it hadn’t uploaded

Thanks, @David_Allen! I’m going to check with the team on this and I’ll follow up with you as soon as I can.