Lost Bluesound Audio Zones

i have completely lost my audio zones. Connection has been a bit hit and miss for some months but it has now gone completely. all other aspects of Roon work ok (i can see my music library etc) but no sound! i have a blue sound vault 2 which connects to my main stereo speakers and blue sound pulse flex speaker. the blue sound os works fine and recognises all speakers. my core is a mac (2016) running high sierra os. please help.

Hi @rory_hussey — Thank you for the PM and sharing your feedback with us. Sorry to hear of the troubles. Typically, we try to handle any support related questions on the “support” thread of the community site so other user have access to any information or troubleshooting tips being shared, should they provide useful. Would you mind if I made this a public topic?

In the meantime, would you kindly please expand on the description of your current setup using this link as a guide and please verify for me if you have any active firewalls or antivirus applications running anywhere in your setup. If you do indeed have active firewalls and/or antivirus applications running, would you kindly disable these functions (temporarily) and confirm if this action triggers a change in behavior.


Thanks Eric. no problem with this being a public topic. i had some difficulty in understanding how to contact support through community site.
as requested here is description of setup.

  • no active firewall or anti virus application
  • Roon 1.3 (build 276) stable 64 bit
  • core i mac 3.5 ghz intel core i5. memory 8 gb.
  • osx high sierra
  • music is stored on blue sound vault 2. approximately 16000 tracks
  • system output though Vault 2 connected to my stereo speakers and wifi to bluesound pulse flex speaker.
  • router is netgear nighthawk (firmware up to date). vault 2 is connected by ethernet cable via a Netgear internet extension (difficult to hard wire to router given logistics of house). i suspect this is the weak link. however blue sound works with this configuration and all other aspects of roon work (access to vault 2) except audio zones. roon has worked with this setup for the last year although it has occasionally lost audio zone temporarily.
    best wishes

Hi @rory_hussey ----- Thank you for the follow up, I have went ahead and made this a public topic :thumbsup:

Moving forward, I want to be certain I am understand the issue correctly based on the information from your most recent post. As it stands Roon is unable to identify the Bluesound Vault 2 and Flex speaker as “networked” audio zones within the application, correct? Furthermore, are there any issues playing directly out of the the iMac’s internal speakers via “system output”?

Lastly, while Roon is unable to locate the mentioned zones the bluesound application has no trouble, is that right? If this is indeed the case, while this may sound a touch elementary, since noticing this behavior with the Vault2 and Flex speaker have you tried rebooting not only the core computer but also your router and any other networking based devices that are active in your setup?


thanks eric, you are correct on all accounts a) Roon cannot identify Vault 2 and Pulse Flex speaker as networked b) no issue with internal speakers via system output (it did go blank once in last 2 days but only for a few minutes) and c) i have rebooted core, router, vault, speakers numerous times.

thanks for your help

Hi @rory_hussey ----- Thank you very much for the follow up and the clarification, very appreciated!

Moving forward, I would like to have you run a few tests to see if we can isolate some variables here to help determine where the issue could be stemming from. Please see below.

  • While I understand that the Vault2 can not be tested with a direct connection to your router (“difficult to hard wire to router given logistics of house”), could you please test with the flex speaker mount the directly to Nighthawk router and confirm if the application identifies the unit.

  • Please try testing with the mentioned Netgear extender temporarily disabled and confirm how things respond in regard to the mentioned endpoints. It is important to point out that we have seen issues pop up with these types of devices in the past, which is why we recommend the use of a mesh network configuration by companies like Orbi and Eero. Our CTO Brian goes into further detail about the limitations of these type of products (i.e “extenders”, “repeaters”, etc) here.


my connection has been restored but i think you observations on extenders is correct. that seems to be the week link. i will try and reconfigure my internet connection.
best wishes and thanks for your help.

1 Like

@rory_hussey ---- Thank you for the follow up and sharing your observations after trying the suggestions made in my previous post :clap::thumbsup:

I am going to be closing this thread, but should the behavior return, just drop me a PM and I will gladly re-open to continue troubleshooting.

Happy listening!

1 Like

Eric, this is the problem raised in a thread that you closed on November 29.

We previously identified the extender as the problem. however i now connected the blue sound vault 2 directly to my router and the problem persists. Roon is picking up the music library from the vault 2 but fails to find the blue sound speaker or my main stereo system which is connected to the vault 2. as previously mentioned this is not a problem with blue sound app which works fine only roon. Roon can identify and play through my sky box, my apple tv, my mac (the core) but not blue sound audio. very frustrating.

Hi @rory_hussey ------ Thank you for the PM and I am sorry to hear of the continued troubles.

In regard to this issue with the Vault 2 & flex speaker not being recognized as audio zones. When you are in this state…

  • The Bluesound application is not active at the same time as Roon, correct?

  • When you are unable to see the mentioned audio zones in Roon if you launch the Bluesound application the endpoints can still be identified/used, correct?

  • Does power cycling the Vault2 and Flex ever force Roon to rediscover these devices?

  • Besides the extender being removed/disabled in the chain of communication has there been any other adjustments made to your network topology since we last spoke? I just want to make sure that I have all the “up to date” details of your setup.


Thanks Eric,

Bluesound application is normally active at the same time as Roon. However it doesn’t make any difference if Bluesound is running or not.
I have tried power cycling many times without success
No other changes to the network topology

i can output Roon through all my IOS devices, TV and Mac but not the flex speaker or my stereo which is hardwired to the Vault 2. I have tried to delete and reinstall Roon but nothing seems to work. Frustrating.

Hi @rory_hussey — Thank you for the feedback and more importantly, thank you for your patience. I wanted to let you know that @mike has provided an update on this behavior, which can be found here: