Lost Connection cycles non-stop since build 334 Update

So I updated to new build 334 and Roon has been cycling ever since. it Connects… spins for 6 seconds then disconnects for 6 then tries to re connect. Rinse, repeat forever.

Current Core lives on an Intel NUC mini PC kit NUC7i7BNH Core i7, 64gig SSD, 8gig SODIMM. Remotes are MacBookPro and iPhone 10. Both have been updated to new build. Both have been rebooted multiple times. 3493 albums, 32857 tracks.


@support Same problem here. I got a notice, that there is an update available on my remote device (iPhone) and clicked on “Update all”. Now I am not able to connet to the core (NUC / ROCK) anymore. I just get this screen in all remote devices:

I have re-started the roon server and it is running, but no connection possible. Any idea?

Im my case re-booting the NUC has solved the problem, so I’m good again so far.

Hello @Chris54,

I have just received the report back from our QA team. They have recommended the following solution:

  • Please navigate to \ROCK\Data\Codecs from another computer, you can use the same instructions from our KB towards the end of the page to navigate in ROCK
  • Delete your current ffmpeg file located in that folder
  • Replace the ffmpeg codec
  • Reboot ROCK

Please let me know if replacing that ffmpeg codec yields the necessary result or if you have any issues performing any of the steps listed here. I look forward to your reply!


Will do when I get home - thx Noris

1 Like

Hey Noris.
Quick question. Is this ffmpeg file the same as one you issued on May 17th?

Hey Noris,
Unfortunately, replacing the ffmpeg file did not work. It just continues to cycle. Next steps??

So I found a potential clue. If I turn Background Audio Analysis Speed OFF the Roon STOPS cycling and appears to operate normally (at least for now) BUT why? And what is the long term fix?

Hey @Chris54 – that’s good news, tells us a lot more about the problem. @noris and @support should be able to pin this down now, since it’s probably related to a file in your library.

Did you add any new media recently? New files, cover art, anything like that? If so, feel free to move is outside your watched folder, and see if things are more stable with analysis turned back on.

If you didn’t add anything lately, Noris will be able to look at your logs and point you in the right direction. Thanks for letting us know!

Hey Mike. Thx for the update. Almost all of the most current content added has been Tidal albums with the exception of a few FLAC albums. And since I have 2 Roon systems and the other has the same music library I am guessing that may not be the cause of the problem. The analysis on the problem system was not even getting past 1 or 2 files before cycling if that provides any additional insight.

Hi @Chris54 ---- Thank you for the continued feedback! Having the additional insight is very appreciated!

Continuing forward, I tried to enable diagnostics on your account so we can have a look at your logs and the report seems to not be making it to us. In the interest of expediting this process and getting your logs into the right hands may I very kindly ask you to please use the instructions found here and send us over a set of your “Roon logs” from the NUC hosting ROCK in a PM addressed to me for review.

Many thanks!

Hey Eric,
Thx for getting back to me. I may not be able to get to this to tomorrow but will as soon as ai can.

@Chris54 ---- Thanks for the follow up, very appreciated!

Good news! I re-enabled diagnostics on your account this afternoon just to see if the request could be fulfilled after having another go. Just checked our servers upon seeing your follow up and can confirm that diagnostics report containing your Roon logs has indeed made it to us. I am going to be passing over to our tech team for review momentarily.

Once the team has completed their analysis and your ticket has been updated, we’ll be sure to share their thoughts/findings with you ASAP.


Thx Eric. I am standing by for their update.

1 Like

I have this same problem.

Hey Thomas. Believe it or not after analyzing thousands of files it turns out I had a couple of rogue songs that crapped out my entire Roon system. Eric and the team did an amazing job analyzing all of my files and identifying the bad files which I removed and have been in heaven ever since. They will work you through it,
Good luck

1 Like

Did you try to resolve this problem by rebooting the Roon core? That helped in my case.