Lost connection to my NAS


I recently moved from Sky Broadband to BT. Since doing so I am unable to see my music from either my iPhone app or Mac Mini. The core being on my Nucleus. I can however access my NAS via my Mac Mini and play files on the mac’s internal music player!

In Roon setup, I’ve tried the various options to try and connect to my NAS with no success.

My web page shortcut/bookmark to the DSM login no longer works. When I put the Synology Diskstation disk into my CD room and activate Synology Assistant, the server name ‘MusicNas’ is found. The IP address is listed ‘192…’, but when it tries to connect I get a ‘Connection failed’!

Any ideas what I need to do? I read in another post that a new modem can issue a new IP address to the NAS! I haven’t a clue where to go from here.

Many thanks

Hi @Keith_Gilliard,

First, I definitely recommend checking out this article about adding a NAS in Roon.

Besides the new router, were there any other changes to your networking setup (switches, access points, etc.)?

Can you confirm exactly what you’re entering into Roon? Are you adding the correct Username and Password?

Hi Dylan

The only thing that changed was the modem/router (Sky to BT). The seperate switch stayed them same and all other connections.

The file path used was \MusicNas\music and this had worked previously with the sky modem connected!

My safari bookmark for the Synology DSM web interface no longer works. It seems the IP address has changed. I moved my NAS earlier and connected it to my Mac directly. I managed to get the IP address for the NAS from doing this and it is different to the one for the DSM webpage and also the Synology assistant which starts '192… The new IP address starts ‘169…’. My nucleus IP address starts ‘192…’. Does this have any bearing on the matter?


Your new router is probably giving out a different dhcp address range. Reboot everything attached so it can obtain a new address. Any static addresses, including bookmarks, will also need to be updated to the new range. When you can see the DSM page in Safari again, you’re moving in the right direction.

Thanks Mike.

Okay, so everything has been rebooted and I’m in the same situation.

Looking at the network via system preferences on my Mac mini, the Mac has been given an IP address 192***. The router is also 192*** and my nucleus is 192***.

When I open the Synology assistant it tries to connect but fails. The IP address listed starts with 192. However, when I connect my NAS direct to my Mac and look at the network, it has a 169 address. So am I right in saying the new router has issued new IP addresses to all connected items to the network, but the NAS is being stubborn and not changed? How do I get it to accept the assigned address? Keep rebooting until it accepts.

Many thanks

Default NAS IP setting is “get IP from DHCP server”. If there is no DHCP server available it gets an IP within the range of 169.254.x.x


1 Like


I found the tiny reset button at the rear of the DiskStation (which I was unaware of).

Thanks for prompting Mike and I hope this discussion can help someone else in the future.

All the best

Excellent :+1:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.