Lost connection with my Nucleus + after years of no problems

Roon Core Machine

Nucleus + (rev B)

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Lost connection with my Nucleus + after years of no problems

It would be really helpful if you could complete the template to include details of your setup and network.

Furthermore, please explain the issue. What have you tried, and does the Nucleus appear to be powered on?

The ethernet green light is on, but nucleus will not power on. Set up, nucleus + in a wired internet connection. Running remote on a MacBook running Monterey 12.4. Nucleus into a wyred for sound digital to analog converter and into a stereo system.

Thank you.

1 Like

Please reboot everything including your ISP router.

If this doesn’t change anything, please check the web interface at http://nucleusplus.local or the local IP address, and hook up a monitor / TV on the HDMI interface.

What do you see?

1 Like

Rebooted everything. No change.



Manufacturer: Roon Labs
Model: Nucleus+
OS: Roon OS 1.0 (build 227) stable
Hostname: NucleusPlus

Searching for network address…

If this persists, please check your network connection.

The HDMI display indicates that there is something wrong with the network connection. This could be indicative of a fault in the ethernet hardware in the Nucleus, or it could be something simple such as a bad cable or connection. Have you got another ethernet cable that you can use to connect the Nucleus to your router or switch as a test?

And have you tried rebooting the router as well?

I did reboot the router, it did not help.

I have tried several cables. In addition, the cables I tried worked with other devices.

OK, then let’s see what the Support team suggest after the weekend…

Is your Nucleus plugged into a switch? If so, power cycle the switch.

Thanks for all of your help. The Nucleus is plugged into a switch, I have not power cycled it, will do and I will let you know. Thanks again,


1 Like

I tried cycling the switch, it did not help.

HI @Mark_Tucker ,

Do you by any chance have a USB → Ethernet adapter that you can try to connect the Nucleus and the Ethernet cable to?

Can you temporarily bypass the switch and plug the Nucleus directly into your router as a test?

I can temporarily bypass the switch, I’ll try that.

With the USB to Ethernet adapter, I’ll have to check. So, if I do, plug the USB into the nucleus and connect the ethernet to the internet?? Or ethernet connection to nucleus and USB to something else??

I bypassed the switch and went directly to the router, no help. I am looking to see if I have a USB to ethernet connecter, I don’t think so, if not I can get one from amazon if it would be of help.

I don’t have USB to ethernet, ordered one, will take a couple of days to get here. Anything to try in the meantime?

I can do ethernet from the nucleus plus to my MacBook is that would be diagnostic?

What did the support team suggest?

That was the reply from Noris earlier this week:

Gotcha, I’ll have the USB to ethernet in a couple of days.

1 Like