Lost in Settings Audio for PC

My setup:

After I placed an optical output in my PC (and it works perfectly now) I miss the audio settings of my PC for Roon.
Every 12 seconds it appears for 1 second:

My PC does see the Core and HQPlayer:
ip address roon core

but devices linked to my PC sees it once every 12 seconds. Via my PC I can listen to Qobuz via my Loxjie DAC. That connection works. The Loxjie can also be seen in the Windows sound program and is set as default. You can also see the new optical output there:

So I can listen to Roon on my PC via HQPlayer, I can adjust settings, I can add albums via Explorer. So there is a connection via the network, only the devices linked to my PC have disappeared in audio settings.
Who understands what’s going on?
I’ve also looked at this problem in the forum but didn’t see a solution anywhere.
Thanks in advance for reading and for the help.

Realtek drivers can be an issue in roon. Make sure you have drivers from the device manufacture not just windows update versions.

Unfortunately, updating by Realtek’s drivers didn’t fix anything. No drivers would be needed and installed for the Digital Output:

Very strange: The device manager window of my PC disappears every time one second after 12 seconds and that only if I have activated Roon. That must have something to do with each other. I just don’t know what. Someone who knows?

Hi @Bert_Dijkstra,

A few suggestions before the team pulls diagnostics to review more deeply:

  1. In your setup, do you have multiple subnets set up for each of these network switches? If Roon is losing visibility for the system output of the Core, it’s possible that some networking factor is interfering with the discovery cycle for Zones.

  2. Do you have any VPNs or firewalls on the Core machine? Have you set up the proper exceptions to the Windows firewall? (Here’s an article).

  3. Do you encounter this missing Zone on all of your Roon Remotes (iPad Pro as well as desktop and any additional phones)?

The next step is to connect the Core directly to the router via ethernet and see if you can stabilize the Zone visibility. Disable any VPNs or network security if you’re testing using a Remote.

The tech support team will keep an eye out for your response. We’ll pull more thorough diagnostics and proceed with additional troubleshooting steps if these questions don’t illuminate a solution for you. Thank you!

Hello Connor,
The first thing I will do is remove the optical output from my PC because after installing it the trouble did start. If this isn’t the solution I will follow your suggestions. Only some parts of it I don’t understand like: multiple subnets set up for network switches, what’s the difference between Roon and the Core, networking factor is interfering with the discovery cycle for Zones.
Further on I don’t use VPNs or Firewalls on the Core Machine (SonicTransporter 7i from Small Green Computer) as far as I know.
The Windows Firewall was never a problem in the 4 years I’m using Roon in my setup. I didn’t change anything in the setup of the Firewall.
The PC Zone I’m missing is the Zone with the Loxjie DAC (the default didn’t work anyway) Wasapi and Asio (2 grey bars).
I think these Zones where never visible on my iPad/Phone, but never tried to find out.
The Loxjie doesn’t have problems with the PC while it functions with Qobuz and all other programs with audio on my PC.
After removing the Optical Output on my PC I will report the new situation.
Thanks for your help and suggestions.

Yesterday I did remove the Optical Output on my PC but unfortunately the problem remains. I also connected my laptop to my network and started Roon on it. It turned out to be visible on my PC and iPad in Roon> Settings> Audio. There were 3 switches in between and still visible everywhere. I assume that I only have 1 network. You have to create subnets yourself and I have never done that. My network setup is very simple.
My PC audio devices are nowhere to be seen in Roon. Not on the laptop, not even on the PC itself and not on my iPhone/Pad. But in Roon> Settings> About the PC can be seen:

I have now also connected the PC directly to the router, but that doesn’t matter, the devices connected to my PC remain invisible in Roon> Settings> Audio.
I find it striking that Device Manager in Windows disappears every 12 seconds (search/scan?) and only does that as soon as Roon is started and Roon also shows the same behavior but in reverse: every 12 seconds the connected devices appear for 1 second .
Tomorrow I will have contact with my PC help, who will view it remotely. I wonder if he understands what’s going on. I also wonder if I shouldn’t buy a good sound card for my PC to prevent these kinds of problems. I think everything is handled by Realtek now. Maybe someone has a good solution for that.

My PC help helped me a lot. He suspected that there was a problem with the drivers of my Loxjie D30 DAC. Roon was apparently always looking for that, but was not allowed access, hence the on/off situation both in Roon and in the device manager of my PC. I don’t understand how and why the old drivers stopped working because I hadn’t done anything about it (installed a year earlier) and it concerns the same drivers from 2020. In any case, removing and reinstalling these drivers was the solution. Roon again showed my PC with the connected devices in Settings> Audio. However, a number of settings in the sound program of my PC had to be adjusted before sound came out of the speakers. This first succeeded with Qobuz, although the speaker icon in the taskbar was muted, but there was sound. Also in Roon > Settings > Audio I had to set something like the volume control. Unfortunately still no sound although it was playing. In the Thesycon XMOS USB Driver Control Panel, the check mark had to be checked for Loxjie Audio.

Yes and then sound also came via Roon > PC > Loxjie ASIO. Qobuz> PC> Loxjie Wasapi already did it and the speaker icon is no longer muted. I used to be able to play them right away, but that is no longer possible and that is of course not necessary.
As it looks now, this problem has been solved! Hopefully this will help other users.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.