Lost NAS connection

Roon Core Machine

SonicTransporter i5 v2.7

Networking Gear & Setup Details

Synology NAS DS 218+

Connected Audio Devices

PC (USB to Chord Qutest/SPL Phonitor X, 2X KEF LSX (via access points), LUMIN T2 via access point

Library Size

~30K tracks

Description of Issue

This has been a rock-solid system for me. I recently upgraded my LUMIN D2 to a LUMIN T2 and with it, I upgraded my ethernet cables to Wireworld Chormas/Starlight. My first step was to replace the cables and then connect the T2. I believe, something I did caused the IP address to update and now I can not add the NAS location. I can access the location via Windows explorer and both the LUMIN App and JRiver can access and play the files as they always could. Just not Roon. I’ve tried EVERYTHING I can think of, including going back to the old cables. I’ve tried Rebooting, reinstalling, I’ve followed suggestions from support at SonicTransporter all to no avail. Any thoughts?


I am not an IT guy and I had a similar issue. It took me hours to figure it out, but it had to do with folder permissions, they were set to Guest deny. My stuff wasn’t allowed to talk to each other until I fixed it. Good luck.

Thanks for weighing in Stephen. What kind of NAS do you have? I’ve been poking around guest permissions, and it appears that I’ve allowed them, but only on a folder level. I have a general setting, to disable guest (Ev_Media is the folder with my music files).

But here you can see I’ve allowed in on the folder level

Again, I appreciate you taking a peak. I’m beyond frustrated. I have this new awesome piece of gear and I’m unable to really use it as I’d like. I’m forced to use the LUMIN app, which is NOT Roon.

Make sure your NAS allows SMB 2 connections, SMB 3 (and above) only won’t work AFAIK.

Thank for replying, I appreciate it. Like this, correct? If so, it was already selected.

That looks good, so one possible reason eliminated. :smiley:

Troubleshooting tips can be found here:

Thanks again. I’ve checked those out as well. When I finally figure this out, it’s likely going to be something simple and it’s really going to make me mad. The weird thing is, this set up has been working flawlessly for 1.5 years. I made no setting changes of any kind. I merely hot-swapped the ethernet cables. I think that caused an IP refresh. But I’ve carefully typed in the new IP to no avail. I even tried going back to the old cables. But windows can access the NAS, all my mapping is fine and even the KEF and LUMIN apps can find the NAS directory…same as they always have. Just not Roon. Weird and frustrating.

I have a QNAP NAS. I could never get anything connected using the IP addresses, I had to use the device and file locations. Here is how I had to tell everything where my music is. I absolutely feel your pain!

This is for the Bluesound Node 2i

This is for Roon

First, I’m soooo sorry for the repeat post, but I was advised to contact Roon support directly and they have not responded at all in almost a week and this situation is EXTREMELY FRUSTRATING. Even Andrew Gillis from ST has responded and he’s technically “out of the office” right now - thank you Andrew.

Additionally, this community has been incredibly helpful to me and I appreciate all of your goodwill and efforts to assist over the years.

My system worked fine for 1.5 years and now I can not add my music share on my NAS.

In upgrading my D2 for a T2, as well as a cable upgrade, my NAS IP address changed. I have since made it a static IP address but I CAN NOT get Roon to add music share folder. I’ve tried every nomenclature available. I’ve made no other changes to the settings.

I can see the drive and share everywhere else. I’ve changed nothing. I can access the file with Windows and JRiver continues to find the files. All network backups work. The only thing broken is Roon.

Since I was unable to get a resolution, I’ve since created a workaround with a back up copy to a WD MyCloud Ultra. This is not an ideal solution, but I’m getting by temporarily.

Any Synology NAS experts out there that can weigh in?

Roon support issues aside, I’ve found Roon to be a fantastic tool and thus my frustration. I’m also seeing the Synololgy issues with DSM 7 and maybe it’s time to jump ship and get a better NAS anyway. As such, I’m considering upgrading to a QNAP NAS. Any QNAP recs? I LOVE the SonicTransporter and will continue using it for my Roon core.

Thanks in advance. I do really appreciate the shared love of music and assistance found in this forum. Roon is lucky to have such a knowledgeable, devout and helpful user base.

Best, Thomas

Hey @Thomas_Eviston, thanks for your patience – I’m sorry we couldn’t get back to you sooner! In one of your screenshots, I noticed you added the network share like this: \\Ev_Media.local\All_Music

Can you try with \\Ev_Media\All_Music?

Another thing I noticed:

As a troubleshooting step, can you enable this setting and try again? After that, try adding the admin credentials in Roon instead of leaving them blank.

Thanks for reach out Kevin. I’ve tried all: