Lost network links with core

Core Machine (Operating system/System info/Roon build number)

NUC6CAYS (core operating on 500 GB SSD)
Windows 10 OS
Roon 1.7, build 555, 64bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core connected by ethernet to wifi network (SPARK SMART fibre modem/router)
PCs (HP Pavilio23 and Surface Pro 10 both using Windows 10) and Android smart phones connected to core via wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Expert 400
Cocktail x40
Bluesound Mini
Bluesound Flex

Description Of Issue

Returned home after a weekend away to find that PC’s and phone could no longer pick up Roon core. The core is still functional and can be used to play music out of Bluesound devices and through the Cocktail X40. However, the core can no longer recognise/link directly to the Devialet (except via the Cocktail x40). But this is not that helpful as I no longer can control devices via phone or PCs. I have tried re-booting the core, turning NUC on and off, turning wifi on and off, uninstalling and reinstalling Roon on remote PC devices, and followed advice on support pages and from other reported problems (eg ensured core will accept connections from remotes, typed in IP address when scanning for core and tried Nothing seems to work. Any suggestions would be greatly appreciated.

Dave Grimmond

Hi @Dave_Grimmond,

Welcome to the forum! Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

I have sometimes seen automatic Windows updates revert firewall settings, so please let’s verify this aspect before going into deeper troubleshooting. Do let me know how it goes!


Thanks very much, that was just the type of help that I needed. The problem was not the firewall but the public/private network issue. We must have had an internet interruption while we were away and when I was searching for the source of the problem I had not noticed that the network connection for the PC with my core had somehow reverted to public. Anyway in the end a very simple fix. I was quite stumped, so thanks very much.


1 Like

Hi @Dave_Grimmond,

Happy to help! Do let us know if you have any further issues and we can certainly take a look!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.