Lost Network Path

I have a ROCK with the latest OS.

I moved my Synology NAS, which had connected to my network through Ethernet, to a different part of the room, again connecting it by Ethernet. I believe everything then worked, though I could be wrong. Then, we had a power outage. I turned the Synology back on and turned the NUC with ROCK back on. Now, Roon can no longer find my NAS with the same network path. How may I reconnect? (With MacOS, I had to do a new network connection before the Mac would recognize the Synology.)

Hello @Andrew_Stein, can you see the NAS over the network from the Mac itself?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Almost every time I reboot the router (Orbi) or we have a blackout, Roon can’t connect to my Synology NAS, and I have to reenter the pathname in Roon through smb:// and the network pathname. It’s strange since MacOS can navigate to the NAS and see it when Roon can’t. This time, after I reconnected, Roon is importing tracks all over again (28,245 out of over 200,000 files scanned and growing).

I don’t think I should have to go through that process every time my router reboots or we have a blackout. I would appreciate any help. Thanks.

  • Details on your Core machine (OS, Hardware specs, Roon build)

ROCK version 10.0.0.19

  • Details on your Remote(s) (OS, Hardware specs, Roon build)

Various, including iPhone 11 Pro Max and MacBook Pro 16"

  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)

Bluesound Node 2 streaming to various devices through Ethernet and to some devices (e.g., iPhone, MacBook Pro 16") by WiFi.

  • Audio devices in use

Streaming wired to four destinations in house (to Parasound Hint 6 directly from Bluesound Node 2 and to three other wired Bluesound devices (one turned off)) plus to iPhone and MacBook Pro wirelessly. Various Ethernet switches throughout house, plus Orbi router and Circle parental-control device)

  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)

Stored on Synology 415play, connected to network by Ethernet.

Why need to reboot router ?:grinning:

Can you confirm NAS is on, and you only reboot router?

Anyway, can you log into your router DHCP and assign fixed IP addresses ?
And remove any fixed IP settings you may have on your NAS ?

It’s strange you need to enter the path every time to NAS. Can you send a picture of this setting before and after reboot router ? (It doesn’t make sense it should be different).

Maybe something here can point you in right direction as well:

1 Like

Hello @Andrew_Stein, and thanks for your patience while I discuss this thread with the team. They asked that I submit a report for them on this issue and get some information from you. Could you please reboot your Orbi to reproduce the issue and provide a timestamp (your local time) when you do?

Also, could you please send me a screenshot of “Settings>Storage” so I can show the team? Thanks!

Hi. I just rebooted my Orbi. The reboot started at 2:09 p.m. PST and finished around two minutes later.

I will send you a screenshot of Settings/Storage privately, but I can see that it did connect to the NAS and has started scanning from and importing from it. Does it have to rescan and reimport upon every router reboot? Thanks for your help.

Hello @Andrew_Stein, thanks for the details! By the way, I tried enabling diagnostics for your account but it looks like the core hasn’t been active in some time. Could you please enable it and use Roon so they report will upload? Thanks!

Also, the team asked that we connect the NAS to the core directly via Ethernet to see if the issue is still reproducable. Please let me know!

Hi. Roon reports that I am signed in on the core (ROCK). Not sure why it is showing as inactive. I am playing something now. I can’t connect the NAS directly to the ROCK. They are too physically distant, and I would have to unplug lots of cables and reconnect them. I just don’t have time to do so much troubleshooting.

Hello @Andrew_Stein,

Could you please:

  1. Reboot ROCK from the WebUI (like in the screenshot below)
  2. Then try to connect the NAS one more time
  3. Reply here with a timestamp (your local time) when you did this
  4. And finally, use the directions found here (option 1) and send us over a set of logs using this link.

Please make sure the ROCK logs are included. Thanks!

Hi. I rebooted around 4:15 p.m.-ish PST on 8/1/20. It took a couple of attempts, but it finally worked. The Mac Roon app showed it connect to storage (the NAS) right away, but it is scanning tracks (57,000 out of 114,755 as of 4:22 p.m.). Is it supposed to rescan every time it reboots? (At least it did find the NAS without intervention.)

I just uploaded the support package.

Thanks for your help.

Hello @Andrew_Stein, I passed this additional information over to our team. Thanks again for uploading the file!