Loud 'pop' noise beginning new track DSD Native [ALSA fix in 4.10 kernel, DietPi Patch]

Experiencing loud ‘pop’ noise at the beginning of the first track in an album or playlist when using DSD Native. DoP is fine.

  1. Upsampling from PCM 44.1/16 to DSD128 using Roon 1.3 DSP Engine
  2. DAC is a PS Audio NuWave DSD connected via USB from a
  3. RPi3 DietPi 143 Roon Bridge v1.0 build 64
  4. Roon Core 1.3 (200) Windows 10.

Only happens at the beginning of a new album or playlist. No detectable ‘pop’, ‘click’ between tracks or at the end of album or playlist.

Not a deal breaker, DoP works flawlessly… Reporting in the event there is a bigger, underlying issue or if there is a know fix.

I get it too sending native DSD through a microRendu. I have to mute the preamp before restarting play. I have become a master of adding next or adding to Queue instead of bothering to do that !

The issue is in ALSA, the Linux sound package, and the way it sends (or doesn’t send) initial “silence” over USB.

A patch to fix it seems to have been recently developed.

Let’s drop flags for @dan_knight (your DietPi) and @Jesus_Rodriguez (my mR) and see if they can tell us if this is a fix and if it can be implemented.


Thank you @andybob! I like your queue manipulation workaround :grin:

1 Like

Whoa, that’s exciting this might be fixed at the ALSA level, thanks for the good news. It’s clear it can be addressed at a variety of levels such as JRiver’s “Play silence at startup for hardware synchronization”. I’ve often seen the blame placed on DAC designs that don’t mute the first 50ms of native output. Keep hoping iFi will address it in a firmware update. According to that link the patch was accepted so I’ll be watching keenly for alsa 1.1.4 to come downstream. Until then I’ll stick to DoP.

I seem to recall something like this when skipping manually to other parts of a track or to the next track but continuous play seems to be no issue. I forget if this was on the RPi or if it was also happening on my Win10 core connected DSD ready DAC’s … might go and retry that and report back

This indeed a good news, I’ve an Auralic Aries Mini and tried on the Holo Spring, I got loud pop at the start of DSD256 track. It only happens at DSD256 native mode, and not DSD64/128. The later ones are transported via DoP. I’ve contacted Auralic and Jeff Zhu sometimes ago and they are looking into it.

I don’t know if this patch should be applied at the source or the DAC end or both, but this indeed in a right step direction!

This nasty loud pop only happens in Linux OS and must be transported via native mode, not DoP. Windows+Roon with Holo Spring driver don’t experience any nasty loud pop at all. I’ve tried all the way to DSD256 native mode.

Be mindful these nasty loud pop can potentially damage your amps and speakers if the volume is set too high!


Excellent find.

I’ve applied this to our RPi kernel, once complied i’ll let you know when its ready for testing :slight_smile:



New kernel is ready with DSD USB noise fix/patch, to install it:

/DietPi/dietpi/func/dietpi-set_hardware kernel dietpi_rpi

Let us know if this resolves the issue.


@Dan_Knight you are the man! Applied the fix/patch and tried replicating the issue with the same method I used for initial troubleshooting. Issue appears to be resolved.

Thank you!


No worries,

Full credit to @andybob for providing the patch :slight_smile:

1 Like

Patched the Arch-4.9.8-1 kernel this morning and that’s another longstanding issue for me with linux audio fixed, thanks for the leads @andybob and @Dan_Knight.

I’m convinced native sounds better on my system: slightly more open / more air. At any rate it’s one less step for the music on it’s way to my ears, and I won’t look down my nose at a good placebo :joy:


@Dan_Knight did this patch make it into the DietPi v144 kernel? Or will I need to reapply if I update?


EDIT: Upgraded to v144 and the original issue did not resurface so answered my own question.

1 Like

@Dan_Knight … Is this patch also able to be applied to the Odroid C2 kernel? Thanks…

Hi @Wakajazz and @lorin,

Would you mind providing details of the endpoints and DACs you are using where the pop issue was resolved by this patch ?

Brian is going to try to reproduce it in the Roon Labs. I believe white coats will be worn.

1 Like

Sure thing. I’m using an iFi iDAC2, and applied the patch to the 4.9 kernel on Arch Linux, running roonserver. Simple one box setup, although I’m now experimenting with a home-brewed NAA, fun stuff :smile:

Before this, any native non-DoP DSD playback would commence with that startlingly loud pop sound. Depending on the playlist behaviour of a given player, sometimes it would be just the one pop. JRiver’s leading silence was an effective kludge, and HQPlayer standalone is less prone I think because it takes control of the audio system and never lets go.

I noticed the 4.10 kernel was released today and it has these changes merged. For stability’s sake I’ve since switched my roonserver PC to Debian Stretch, which is on 4.9. The pop is back, but now I know how to fix it. I think they mean to include 4.10 in the Stretch release but coming from Arch I’m not sure I can wait more than a day or two. I’ll report back after I figure out the correct procedures for patching here.

1 Like

Endpoint: Raspberry Pi 3 B, DietPi v144, iFi iPower ‘wall wart’, AudioQuest Carbon USB cable, Roon Bridge RAAT v1.0 build 66 (no HifiBerry, IQaudiO etc hats)
DAC: PS Audio NuWave DSD
Device Setup (deviation from defaults): Fixed Volume, Max Device Volume at Playback Start/Yes, DSD Playback Strategy Native

Pre patch (DietPi v143) a loud ‘pop’ best described as the equivalent to dropping the stylus onto an LP at the beginning of play with volume set moderately high.Only occurs when starting Roon playback from a new playlist/album/track. If the playback queue is kept populated and playback never actually stops or is paused then the noise is not heard.

I recently tried an Odroid C2 as a drop in replacement for the Raspberry Pi 3 now that Roon Bridge is included in the DietPi build for this SBC. The ‘pop’ noise returned, I assume due to the fact that the ARM kernel is way behind that of the RPi release and the ALSA patch was not applied by @Dan_Knight for v144.

1 Like

I don´t think the patch is already included in the dietPi v144 release. I experienced the same pop noises at the beginning of a new DSD album or when using the track skip function on my McIntosh C2600 preamp with attached Raspi via USB. This happened in native DSD and also in DSD over PCM mode.

After applying the patch to the v144 release the pop noises have gone in both DSD modes.

Oh, long story short (again, not my forte!) my typical roon playback chain is simply iPad remote > Linux core passing audio to HQPlayer, upsampling to DSD256 with no DoP.

Unfortunately, not at the moment. Odroid kernels are maintained by Meveric (http://forum.odroid.com/memberlist.php?mode=viewprofile&u=157) and provided through his apt repo.

cat /etc/apt/sources.list.d/* | grep meveric
apt-cache search ODROID | grep linux