Low Volume on RP4 with HifiBerry OS and Digi +

Core Machine (Operating system/System info/Roon build number)

Roon Rock on Intel NUC i7. OS V1 build 227; Roon Server V1.7 build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology D-218+ over ethernet; Modem Netgear Nighthawk X10 R9000

RP4/HiFiBerry Digi+ Pro running HiFiBerryOS. —> Via Optical or Coax --> Schiit Bifrost II Multibit DAC or Schiit Modi Multibit --> DIY Headphone Amp/ Pre-Amp Noir or DIY WHAMMY Pre/HA --> either Audeze LCD-1 or DIY AMP CAMP AMP --> DIY Vifa Speakers or Zu Audio Omen DWs.

Description Of Issue

The volume of the system is low. At 100% on the volume control it plays slightly below normal listening levels. My Roon system is working perfectly on a similar system differing only be being an RP3 running DietPi. I can take the same equipment and cables to the RP3 system and all the components and cables tested one-by-one play insanely loudly on the earphones or the speakers. I am confident this is not a network problem, a Rock problem or a problem with any of my audio chain except possibly the RP4 HiFiBerry HAT and OS.

I have tried Fixed and Device Controlled Volume control. I have looked at every configuration control on the Roon set-up. I can’t figure out if a volume limit is being set somewhere. DSP is off, Volume leveling is off. Under Device Volume the Set Limits are Min 0, Max 0, and Comfort 0. I do not see an option for DSP volume on this system as I do with the RP3 system. A this point I am totally confused. I feel like this is a software problem but I haven’t managed to find the right place in the software to fix it. I also feel like I am over-looking something simple and obvious. I don’t think this is a Roon software problem–all other nodes are working beautifully–I think it’s a user problem or a RP4/HiFiBerry problem but can’t figure out the next step even after reading the user forums.

Post a screenshot of the signal path when you think the volume is abnormal.

HifiberryOS is a Full Software suite that allows to enable and disable many streaming protocols, even B&O room correction etc. It also has a volume control. I experienced the same problem until I found out that the volume was set very low on that internal SW and had nothing to do with Roon. When you enter in a browser the IP address of your RPi you will get to the webinterface of that Hifiberry Software and you can start to disable all these whistles and bells. And set the output to fix volume and not variable. Then all should be fine again.

Edit; I briefly checked. There is a tab in the Software called ‚sound‘. Click to that tab and you will find a volume slider. Probably this slider is not at 0dB and therefore you have this low output volume.

1 Like


Thanks! That was the piece I knew was obvious that I was forgetting. The hidden volume control is just as you said–it’s in the HiFiBerry Software, I had never used the web interface, This set-up has been running continuously since just about when the RP4 came out, Worked perfectly so no reason to fiddle. Then one day the volume changed, Don’t know why. When I opened up the webpage at it’s IP address there was a volume slider at the bottom of the page! It was set at 50%. I haven’t checked it yet but I am certain that you have solved the problem. Will update the software and try to remember that I can control the software via the web. Actually, the Software Update tab said the new version has a local interface for RP3/RP4. I’m going to update and see what that offers. Thanks again.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.