LS50 Wireless - New firmware - Disconnects from Roon

Core Machine (Operating system/System info/Roon build number)

Core i3 NUC, 16gb ram, windows 10, Roon 1.7(latest)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus RT-AC88U Roon server connected via Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

LS50 wireless over Wifi (2.4ghz)

Description Of Issue

After updating the LS50w to the latest firmware offered on the KEF support page, and upgrading to Roon 1.7, I am getting “Roon lost control of audio device” errors. This is the exact same behavior I saw when I first set up roon, and was resolved with one of the Roon 1.6 maintenance updates.

The error can happen at random, and when it does, the system becomes completely unstable.

@support Help

Hi @KungFuNat,

What firmware version did you upgrade your KEFs to, can you let me know the exact firmware build?

Is there any change in behavior if you plug in your LS50s over Ethernet instead of WiFi?

How often are you seeing this issue? Once a day? More frequent?
Does it only occur when playing certain types of content (such as high-resolution)?
Have you tried rebooting your networking gear, endpoints and core yet?



Wi-Fi v3.0.0
MCU v4.1.0
DSP v0.54

You can find it here:

I cannot plug my ls50 via ethernet, its too far.

I am seeing the issue multiple times a day, sometimes it will recover with a simple power cycle of the speakers. Sometimes the system becomes completely unresponsive and requires power cycle from the wall outlet. The system will not go for more than an hour or two without this issue. The speakers are always able to control via the KEF app, even when Roon cannot play music through them.

I have rebooted my Core, and router, but the problem persists.

Hi @KungFuNat,

Can you please reproduce this behavior once more and note the exact local time + date when it occurs and send me logs by using these instructions?

Have you tried factory-resetting your LS50s yet? I have heard for some customers that this helps.

Yes I have factory Reset my LS50s, the behavior persists.

Sending you a link to the logs now

Hi @KungFuNat.

I can confirm logs have been received, I’m seeing a few strange traces so I have requested additional feedback from the technical team regarding them. I’ll be sure to let you know once I hear back, thanks in advance for your patience.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.