LS50W no longer visible as Roonendpoint on Synology DS918+

Core Machine (Operating system/System info/Roon build number)

Synology DS918+ NAS with 8 GB ram
6.2.2-24922
Connected via ethernet to Meraki switch
Roon 1.7 (Build 537)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Huwei Home Gateway HG659
Meraki MS220-8P switch
Meraki wireless AP

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LS50W - Wifi 5Ghz (also tried ethernet)

Description Of Issue

OK - it’s happened again.

My LS50W no longer available as an endpoint in ROON.

I have done everything - , restarting DS918+, router, switch, wireless AP, LS50w, using direct connection with switch via ethernet, even reinstalling the DS918+ and reinstalling ROON - I promise I have dedicated HOURS of troubleshooting to get this working and to be quite frank I am getting desperate now!

I have an iMac on the same network infrastructure - installing ROON core on this, I can see the LS50W as endpoint.

The interesting thing is - I know if open vswitch is enabled on the Synology DS918+ it will break network for ROON, I can confirm open vswitch is not enabled, and can see all my Chromecast devices… just not my beloved LS50W.

I’d really appreciate some help here, any tips or hints appreciated. If you need logs, can post them just let me know what you want.

Thanks!

Graeme

Hi @Graeme_Stables,

Thanks for reaching out. I have a few questions:

  1. Can you please share a screenshot of your Roon Settings -> Audio tab?

  2. Do you have Plex or other media server apps running on the Synology? Is there any change in behavior if you temporarily turn the other apps off?

  3. What is the IP address of the Synology and what is the IP of the KEFs?

  4. If you temporarily try connecting the KEFs via USB to the Synology, do they work as expected?

Thanks for the reply!

  1. see attached
  2. yes I have plex - I disabled plex on the DS918 and the KEF LS50W does not display
  3. Synology DS918+ IP is 192.168.1.200, KEF LS50W 192.168.1.29 (both on ethernet)
  4. I can’t do this - the synology is in another room.

Hi @Graeme_Stables,

Thanks for the additional info!

How was the iMac connected vs the Synology? Were you using a hardwire connection to the same switch? Or was the iMac connecting via WiFi instead? Ideally the iMac should be connected using the same cable/port as the Synology was for this test.

The iMac is connected via wifi and wired ethernet access port 7 on the meraki switch. It’s getting two IPs, one .4 and .24
The synology is connected via wired ethernet on the meraki switch port 4&5 (load balanced) .200
The Meraki wireless AP is connect via access port 2 on the meraki switch.

I’m sure that something on the synology is not right, or somehow the network is not sending broadcast packets to the ls50w.

The only change I made was installing Docker on the Synology a month or two ago.
I have since done a reinstall of the Synology DSM OS, which should’ve hosed any network configs.
I have checked and open vswitch is not enabled.
I’m also wondering if the synology is blocking ports, or if there’s a setting on the meraki I need to change.
I haven’t made any network changes.

Hi @Graeme_Stables,

Is Roon currently running on in a Docker container on the Synology? If so, can you try installing it natively? Roononnas.org provides instructions on how to install it as a native app.

Do you have an unamanaged switch around the house? If so, could you try connecting the LS50s and Synology to the unmanaged switch instead of the Merakai? That should help clarify if the switch is at fault.

Hi there,

No, Roon is running as a native app.

I think I may’ve worked it out - the interesting thing with this issue is I can see all of my Chromecast devices, just not my KEF LS50W, only from the Synology - so I thought there may be a port blocked on the synology. If it was a network related issue, then why could my iMac on the same network see the LS50w? It didn’t make sense. Could my synology have a blocked port?

I then noticed Audio Station (a synology app) used Port 1900 UDP so I installed this application thinking it may also install the network configuration and open that port - when I opened Audio Station I could see the KEF LS50W was available as an endpoint - so the Synology was seeing the KEF, but still no joy from Roon.

I then tried connecting to an unmanaged switch. The KEF LS50W then became available in Roon (I installed Roon from scratch again)

It streamed music fine. I then thought I’d try moving back to the Meraki Switch. Once I did this - the music continued for a while but then was dropped again and the KEF LS50W disappeared.

I checked out the Meraki settings and
I enabled IGMP Snooping and Flood Unknown Multicast Traffic on the switch. I plugged the NAS and KEFLS50W back into the Meraki switch and this appears to have fixed the issue - something was up with how the Meraki was sending mutlicast. It’s funny though - I’ve never had to turn this on before and it has worked fine.

Thanks for your assistance - I was almost going to purchase a NUC and run Roon ROCK but I want to avoid that as I find running it my from NAS works fine (when it works!)

1 Like

Hi @Graeme_Stables,

Glad to hear you pinpointed the issue to the Merakai switch and resolved it with the change in the switch settings! If you have any further issues, just let us know and we can take a look, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.