Lumin D2 Cutting out

I have had the Lumin D2 on my system for about a year now. It is hardwired, and has worked quite well.

Today, however, it is unable to stream for more than a minute and a half at a time before cutting out, as in, just the green circle on the display, and nothing on the Roon devices list.

It comes back online again within a couple of minutes, and upon being selected to play, does so for another minute and a half or so, and the same cycle ensues?

I have switched the Lumin on and off, reset the router, and prioritized the Lumin in my router settings. No dice. Just to check things, I connected a different streamer onto the same ethernet cable, connected it to a different DAC, and it has been playing seamlessly.

What gives? Any advise on how to get the Lumin to work? It ain’t exactly small change to use it as a doorstopper.

Do you happen to be using an aftermarket LPS for the D2? In that case, please reconnect the original SMPS.

Not at all. Just what was in the box.

Please put a few music files on a USB thumb drive in FAT32 or NTFS format. Plug it into the D2.

Use Lumin app (not Roon), select the library as Lumin D2 USB Music server, and select the Lumin D2 as player, add those files to playlist and repeat play for a few hours.

To what effect, please? I need it to work with Roon, as advertised.

I’d be grateful for some rationale please. Will doing as you say fix the problem somehow and enable it to work with Roon properly again?

To verify the hardware.

1 Like

I see. I’ll try that and revert.

No probs with USB. Streaming has the same issues.

An update. Looks like my firmware was not the latest version. I brought it up to date, and am keeping my fingers crossed.

RAAT SDK is updated as part of Lumin firmware update.

One other thing if it’s still dropping off is to try a ping to the IP address from a command prompt in windows/Mac and see it it is dropping responses after some time.

This would verify if it’s a network issue where it might stop responding to pings.

1 Like

Thank you. Thankfully, it worked out with a Firmware update.

Lesson for others: If you are using the Lumin primarily from within the Roon interface, it might pay to periodically head over to the Lumin app and update the firmware. The same is true for other services, such as Bluesound, of course.

I just forgot the basics and bothered the community needlessly. Sorry about that.

1 Like

Glad the fix was easy. Love my D2 and 2 D1’s and they are just rock solid units despite their age for the D1’s Still very capable and current for my needs. Props to Lumin to for keeping the features (mostly) across the whole range even for things like MQA and RAAT that have come along since initial designs.