Lumin Firmware Changes and RAAT

I just tested that it works for me.

Please verify that the “Check for Firmware Updates” option in Lumin app is set to Yes. Then double tap iPad home button, swipe away Lumin app to kill it.

Power cycle both the Lumin units.

After they are booted up, launch Lumin app again.

If that still does not work, please try Safari on iPad and check whether it can show

“Check for Firmware Updates” was set to “Yes” in both my U1 and U1 Mini and again note I’ve had no problem automatically getting upgrades prior to this. I’ve had tried killing the app and restarting before I posted here and that didn’t fix it. Additionally, my U1 is normally powered off so I only tried to see if it would find the upgrade after powering on and that didn’t work (and that was also done prior to my posting). When you posted, I was away from my house until today so couldn’t try another complete cycle of restarting the app and re-powering the devices but before I could do that the app provided the expected option to upgrade both devices to v12. Have no idea what fixed it but the issue is resolved.

1 Like