Lumin Remote can only adjust volume. Pause/Start/Skip don't work

Hi guys,

Anyone else experiencing this issue with the Lumin Remote, not being able to do anything else than adjusting volume, when playing from Roon?
Nuc8i7Beh > Router
Router > Lumin D2
Lumin > Power amp via xlr

Roon Core and all remotes are latest version (1.8, 790 stable).
I have tried rebooting router, core and Lumin, but no matter if I reboot individually or simentaniously, it doesn’t seem to fix it

Any ideas?

You mean the Lumin physical remote right?

Please try pause / play / standby / repeat / shuffle / mute buttons, and next/previous track (only if you have multiple tracks in the play queue).

Please also try Lumin app instead of Roon.

Hi Peter,

Yes, the physical remote.
Only Volume Up/Down and Mute works in Roon.

All buttons works fine in the Lumin App via TIDAL. Actually it’s super, super quick in here - Music pauses almost instantly upon pressing the button.

1 Like

That’s odd. All those buttons were tested in Roon months ago with the current Lumin firmware. I’ll update the Roon Core in office and retest it later this week.


Sometimes, when I just reboot the core, all buttons works for a couple of minutes. But then it goes back to just being the volume that works.
I use volume 99% of the time, and rarely the other buttons - If that is relevant for troubleshooting…

All buttons working as expected on mine.

For me also all buttons are working under Roon (much better than the Harmony plugin).
Do you’ve network problems or using something like DLAN?

Preliminary solution:
I turned the D2 off, unplugged the USB from the infrared receiver, and put into the other USB slot (the downmost), waiting a couple of minutes and turned it back on.
Apparently fixed the issue…?

That’s a good try.

I did initially have a problem with the remote in that it work when first installed but then stopped working with some of the functions. I was at the point of repacking it to return to the dealer when I decided to a complete reinstall ie reboot the X1, plug the remote sensor in and start again and all came good and has been working fine ever since with Roon. I do get an issue when I try to shut down the X1 using the remote it will go into standby mode and then restart. I subsequently discovered that if there was any music in the Lumin app queue it would bring that up on the X1 but not play. By removing anything in Lumin app queue the shutdown process works as expected. The remote is a lovely piece of kit but I do wish there was more functionality with the range of “future use” buttons which at the moment don’t do anything at all.

I love the solution too. I tried a few integrated amps, when my local dealer suggested just running xlr’s directly to a power amp and getting the remote. And the sound was just… Wow! Compared to a traditional setup. Leedh really paved the way here.
But a the price point of the remote, I am a bit disappointed. The functionality of standby/wake-up has never worked for me. I have disabled Lumin streaming, and I am only running Roon, and my girlfriend uses Spotify connect… But still doesn’t work.

And now the problem is back yet again… Gets pretty annoying, if you have to unplug twice a week, just to be able to pause the music :frowning:

We need to reconfirm whether this is a hardware issue or a firmware bug.

The next time this happens again (i.e. remote pause button does not work in Roon), please launch Lumin app and Spotify app (create a free Spotify account if necessary) and see if the remote pause button works or not.

If this is a hardware issue, all apps should exhibit the same problem.

I launched the Lumin App, where i normally only have Roon and Spotify (so my girlfriend also can enjoy the system) enabled. I disabled Roon and Spotify, and enabled Lumin streaming, where I’ve got my Tidal account connected to. I played a random track, and the physical Lumin remote suddenly worked again. I paused the music via the physical remote, disabled Lumin streaming in the app, enabled Roon and Spotify again, launched Roon, started the music via my phone, and the pause button on the physical remote then worked, together with all the other buttons.

I hope it lasts this time, and I don’t have to go through these steps every time it lets up it’s connection to Roon - Cause it seems to be working flawlessly in the Lumin App with Tidal in there.

It actually just stopped working again, and the previous fix is not working anymore.
But it’s still possible to pause music streaming in the Lumin App, using Tidal. Just not on Roon…

Please confirm that after it stopped working in Roon, it continues to work in Lumin app, and after you verified it in Lumin app, going back to Roon it still does not work.

And previous fixed now don’t work anymore.
Works in Lumin App everytime using TIDAL, but when going back to Roon, it stops working.

Core running 1.8 795 stable, and Lumin D2 is set to check for firmware updates.

I’ll need to setup a test environment for this. Since it’s not occurring 100% of the time, this will take a longer time to investigate.

Furthermore, I am able to play from Tidal in the Lumin App, even with the “Lumin Streaming” set to Off.
Don’t know if it’s related… But still kind of weird.

Turning off AirPlay “Lumin Streaming” does not prevent you from playing Tidal / Qobuz from Lumin app.

Turning it off would prevent AirPlay from playing via Tidal / Qobuz official apps (instead of Lumin app), along with Amazon Music, Apple Music, YouTube, etc.

When/if we have Tidal Connect for some models in the future, then Tidal app can be used without AirPlay.

1 Like