Lumin T2 not playing MQA in Roon after recent Lumin update

Core Machine (Operating system/System info/Roon build number)
Innuous Zeneith MK3

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Since last update for Lumin T2, Roon is not working well. No MQA and cutouts.

1 Like

Please use Lumin app to factory reset the T2, under About of Lumin T2.
Disable Spotify Connect, Lumin Streaming and Custom Resampling.

Reboot Innuous. Make sure you choose the Lumin Roon Ready zone, not AirPlay.

Then change Roon MQA capabilities to Renderer Only.

I have done all of the above and it still was not working. I took the Roon core off of my innuous Zenith MK3 and put it back on my iMac Computer and it appears to be working. I don’t think the issue is in the T2 but not sure as it works fine in the Lumin app and now works fine with the Roon core on the iMac, but does not work with Roon core on the Innuos. It appears to be the Roon Core on the Innous that is causing the issues or the innuos itself. . I have a ticket in to innuos to see what they say. This only happened after the recent update but that may have been a coincidence. I have only had issues with this setup when something in the loop updates and i seems to take awhile for the others to catch up. If you have any other thoughts, please let me know. Tom

Peter, something weird has happened again in either Roon or T2. the core is still on my iMac computer. It said and sounded like it was playing MQA this morning on the front of the T2 and in the signal path, but now it has switched to ORFS 44.1 KZ on the T2 and in the signal path on a normal Flac 44.1kHz 16 Bit , MQA 44.1kHz file. I can’t seem to get the MQA back so maybe it is in Roon or the T2.

This is the correct display if you use T2 as Renderer Only, for MQA playback. This is MQA playback.

1 Like

Except that I was using decoder and renderer when that changed. I am trying to eliminate any roon setting in DSP like sample rate conversion and volume leveling to simplify the path. So far it is working on the computer fine with MQA studio on the higher res files. I am not sure upsampling to DSD in Roon helps the sound quality in basic flac. . I keep forgetting which dominates the Lumin app settings or Roon to allow upsampling in Roon. I am thinking the Innuous doesn’t like the upsampling but We will see when I hook it back up. The Lumin is a very transparent and detailed streamer so I am not sure the upsampling is that important as long as it is a good file. I have also switched ethernet cables. For some reason, the T2 doesn’t like the Wireworld Cat 8 cables I had on it previously. Why, I don’t know. There is some glitch that has developed in this networking and hopefully the server is ok and I can find it. As I said earlier, I don’t think it is the Lumin causing the issue but I am not 100% sure. On another note. I can’t group the Dragonfly colbalt with my other Roon endpoints unless it is set on Decoder and Renderer which stops it from playing MQA at least as far as the color of the light shows. Its preferred setting is Renderer only for the full unfolding but in Renderer only setting on the Dragonfly, it cannot be grouped with the Lumin T2 as Roon loses control. This is another weird one.

Peter, I don’t think Roon, the T2, and innuous server get along real well. So what I have done is eliminate all sample rate conversion and any other DSP which I didn’t’ use anyway. I got rid of volume leveling and pretty much got down to basics for settings in Roon including the T2. I set it on decoder and Renderer so I could group endpoints without Roon losing control.( see above) The only question I have is should the MQA Core Decoder be enabled or not. So far everything seems to be stable. Time will tell. I actually prefer not having a bunch of filters and upsampling in my music anyway. . Unless you listen to bad files, which I try not to do, even Cd quality sounds fantastic on the Lumin. I like MQA but there are some files that the basic Hi Res in Qobuz sounds even better. I have tried some DSP filters but to my ear, they make it sound worse most of the time. . I’ll let you know, Thanks Tom

Set T2 to decode and render, and shut off MQA in Roon. I don’t use any DSP whatsoever and T2 sounds amazing.

If you get OrFS display with Decoder and Renderer, you must be doing DSP, volume leveling, or grouped zones.

You should always disable Custom Resampling in Lumin app, as stated in my first reply.

This needs CPU power.

You should connect the T2 to a different port on the switch with a different cable. One possibility is a network infrastructure problem.

Please describe your whole network, including brand and model of all router, switches, access points, endpoints and how everything are connected together.

You need to use Renderer Only for Dragonfly, otherwise it is not fully decoding MQA.

This is not supposed to happen. You don’t have a third endpoint such as Bluesound, do you?

That’s the correct way to do it.

It should always be enabled.

Please don’t.

Peter, I will describe my network tomorrow. Yes ,to the volume leveling and I disconnected it. I tried new ethernet wires and that seemed to help to. I do have a bluesound endpoint set to decoder and renderer, a dragonfly endpoint on my computer , a wireless Elac speaker that is also an endpoint and the t2 so four endpoints. Will see if it still runs tomorrow morning. Thanks.

Sorry of course my bad - trying to do too many things at once!

Network connections.


Everything has been working fine in my network until the other day. This morning, Roon was again having issues seeing the T2. I could get it up playing on the Dragonfly but it was stalled on the T2 so I rebooted everything and it now seems to be working again. This is really weird. It definitely seems to be a Network communication issue between the Roon Core on the Innuos and the Lumin. I have had this Network connected several ways but when this issue seemed to start was when I could not combine endpoints without losing control of Roon, an update or two back. I solved it by just dumping MQA on the Dragonfly and setting it to decoder and renderer when it was in the group. It was at that point that the issues started especially with the T2. I am not sure it is resolved although it is playing a the moment.

The network starts with a high speed connection with a Verizon Dual Band 802.11ac XB3 Modem which includes landline.

It is wired with Supra Cat 8 into an Orbi Mesh network router RBR50 with three Satellites.

The Audio connection is hardwired into Router and is wired with a Supra Cat 8 for 50ft to my audio area.

The Audio area has a dedicated AC circuit connected to a Furman Power Conditioner.

At the Audio center, the Cat 8 goes into the Innuous in the Lan.

It comes of the innuous from the streamer Port into an Etherregen switch on the A side of the switch.

Also wired into the A side is a Cat 8 cable from an NAD M12 with the Bluesound Module. The NAD M12 basically drives numerous remote speakers connected via a speaker selector and driven by an NAD M22 V2

Out of the B-side of the Etherregen switch is a Cat 8 to the T2 to an Anthem STR amp which is bewired into the external crossover of a set of Bryston Model T Signature Speakers. I also have Two subs wired into the RCA jacks of the Lumin as the speakers are out of the XRL ports.

The Roon Core is on the Innuos Zenith MK3 Server.

Connected wirelessly to the Network is an IMAC with a Audioquest Dragon Fly Cobalt on the audio with external speakers.

Also Connected wirelessly is an ELAC Roon ready endpoint wireless speaker…

So I have 4 Roon endpoints.

As I said, this has been working flawlessly until recently.

I had a TL-SG105 switch connected for awhile but the Etherregen sounds better between the Innuos and T2. I had the network wired differently at first about 3 months ago and if the etherregen was placed before the innuos and the Inuous wired out of the A side and the T2 out of the B-side, in theory this should work, but it confused Roon and everything else and they definitely were not talking to each other.

The current connections have been working great since I got the Ertherregen about 3 or 4 months ago.

Other things connect to the Network wirelessly, IMAC, epson printer, two iPhones, a Samsung TV, 3 iPads. There is a 2.4 and 5 GhZ channels on the Modem. There are also a couple sonos wireless speakers which we don’t use much.

The main reason I put the Core on the Innuos was because it sounded better and I wanted to get it off the iMac where multiple processes were quite commonly running at the same time and the iMac was much noisier even though it had much better processing speed.

I have no idea what is causing this Network Conflict with Roon. I don’t understand how it works fine and then doesn’t. I have tried taking the Etherregen and other switch and the Blusound out of the Network and just wire directly from Router to Innuous and from the innuous to the T2 and it doesn’t seem to make much difference as eventually, Roon won’t connect well.

Any question or suggestions, please let me know. Is it possible the Roon Core has gotten corrupted some how?


Please power off all your network devices including smartphones. Power cycle the router, access points (if any), and switches like EtherRegen. Wait for a few minutes, then power up the Roon Core. Wait for a few more minutes, then power up everything else.

After every network infrastructure change you have to reboot the whole network, especially Roon Core and all Roon endpoints.

Actually it’s working again at the moment. Ok so I have this correct. Turn off anything that is powered up that is connected with the network,any computer, iPad, iPhone,anything that shows in network traffic.How about the modem? So after everything is powered off, WHAT EXACTLY DO YOU MEAN BY POWER CYCLE? So router first, then switches, then innuous with roon core on it.? After those are booted up, boot up everything else that connects to the network starting with roon endpoints and controllers.

I didn’t know this. So anytime I change any physical connections in the network, I should do this to reestablish the network pathways? Does that include cables? Thank you, I’ll do this tommorrow and let you know.

Power it off (not standby), wait for a few seconds, then power it on.

Unless your modem contains router functionality or you’re having internet issues, there is no need to power cycle the modem.

Anytime you change the network infrastructure, you need to reboot the Roon Core and all Roon endpoints.


Thank you so much.

Peter, so far rebooting the network has worked perfectly. Thank you. So two things, if there is a conflict between Linux and Roon, what is your recommendation going forward for me as far as where my Roon Core should be located…On Inuos server or iMac? Second, I still haven’t resolved the conflict grouping my Dragonfly cobalt with the rest of the Roon Endpoints. I have to set it on Decoder and Renderer or It won’t play in the group and that cuts out MQA. I have four endpoints, T2, Nad M12 with Bluesound module, iMac computer with Dragonfly, elac wireless speakers. Any suggestions for this?

As you have just solved an issue, don’t change it for now.

Does grouping all zones excluding Bluesound works in Renderer Only for all devices for MQA playback?

Does playing to a single zone Bluesound works in Renderer Only for MQA playback?

Thomas Bacon 10:16 PM (6 minutes ago)

to Peter

ok, somehow my elac won’t connect wirelessly now for some reason, Roon is driving me to drink, HA! Will fix that later. Any way, t2, dragonfly and Elac will work with renderer only separately and in a group. Bluesound will not work with renderer only separately or in a group. it will work with decoder only separately but not in a group. all will work together in a group with Decoder and Renderer but then there is no MQA on dragonfly set to decoder and renderer… .