Lumin V14 Firmware

I received an e-mail from Lumin today saying that V14 firmware is available now for my U1 Mini. I’ve tried the Lumin app on both my Android phone and my iPad, and neither one detects a new firmware. The app is set to check for new firmware on both phone and iPad. Is there any way to manually initiate the firmware upgrade?

Same here with my T2 - still on 13.4 and no indication to upgrade when loading the app. Maybe @wklie can shed some light on this?

The Lumin app on my droid phone updated today to 4.1.0 but that’s all.

My D2 just upgraded to 14

I’ve updated the app on my phone, and closed and restarted it probably a dozen times. It just doesn’t pick up the update!

1 Like

Can’t get my T2 to update, tried power off, totally unplugged etc but not having any of it.
Am I missing a way to force an update or?

Don’t think there is a way to force an update. The app auto senses there is one available and asks you if you want to install it. Only… it isn’t :man_shrugging:.

1 Like

Lol, exactly…:joy::joy:

1 Like

I even uninstalled and reinstalled the app. Still no joy.

It’s OK, @wklie is banging away on code to sort this out as we speak :laughing:.

Edit: Firmware update service is just resumed.

Works here, thank you.

Update successfull! Thanks Peter.

Only just woke up but will try it, thank you @wklie

Edit…all good!
Thank you!

I had an issue yesterday but it loaded the update this morning. I test drove a few MQA files and they did sound marginally better but perhaps that was expectation bias.

2 Likes

Worked fine last night on my D1…

Shame they cannot support tidal connect - but we have roon or still direct in the app :+1:

Cheers

Matt

Worked just fine this morning :+1:.

1 Like

@wklie Peter, I’ve updated today. Out of sudden now I have sudden stop during the playback – both local library and Tidal. Never had those before with my T2.

Any ideas?

I assume you mean Roon playback of local files and Roon playback of Tidal, right?

What do you see on the front panel when it happens?

Please turn off Lumin Streaming, Spotify Connect in Lumin app. If you have an Android device, please off Tidal Connect in Lumin Android app.

Please describe your network, and how everything are connected.

@wklie Peter,

  1. Yes, that is correct. Sorry for the confusion.
  2. T2 sits quite far away from my desk, I’ll report it next time. In Roon it just stops.
  3. Wireless router → Network switch-> T2 and Mac mini i7 as Core - everyting is connected via Ethernet. I know Switches, expecially manageable have been reported numerous times as the issue causer, but I haven’t had any issues so far and before update I’ve been using T2 for the last 7 months - with different routers and switches.
  4. No Android. Did turn it off as you said. Seems to be working fine now. Will report soon any updates.