M.2 SSD in NUC8 keeps dying

Hi @Ken_Talbot, thanks for the links. Jay seems to have had a problem with power outage which caused is disks to crash right? Unfortunately, I have not had the same problem.
Which disk did you end up using after the Transcend crash? Still using an NVMe disk?

XPG SX8200 Pro M2 2280 PCle Gen 3X4

Thanks @Ken_Talbot, seems like a decent disk. Thanks for sharing!

I agree it’s a good brand, but that does not mean every product must be perfect. Same with Intel - I knew someone who was hit by the Intel Atom C2000 defect, but that’s another story. Try google “bait and switch” prefixed by your brand.

I’d like to reiterate my recommendation of only buying a SSD from a manufacturer who manufactures its own NAND chips.

I re-installed the ROCK OS on my NUC a few days ago (no hardware change) and it’s been somewhat more reliable. It crashed again shortly after the install, but then worked find for several days before crashing once more yesterday. It’s been working since.

I agree that it sounds like a hardware problem. I ordered the Intel SSDPEKNW512G8X1 which was the least expensive drive ($65 from NewEgg) that was Intel Validated on their compatibility list for the NUC8i7BEH - expected in about a week.

@wklie, thanks for elaborating, now I understand what you mean, and your recommendation to buy from original manufacturers make a lot of sense! To be honest, I have not realized the difference until now.

Hi @Jay_Torborg, thanks for answering this thread och updating us on the current situation. Good luck with the new disk.

I use Samsung. Never had an issue. If you are looking for a brand to try.

I think it’s been 4 months now. Please confirm that using a different brand of SSD solved the issue you reported.

Hi Peter, I can confirm, that the NUC works without problems since I installed the WD SSD.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.