Mac connected devices never enable


(Graeme Dixon) #1

@support

Haven’t used Roon in a while – fired the client up on my iMac and was told it needed updating (I run the server on my QNAP NAS which was up to date). Updated the Mac client, but the devices I want to use – specifically my locally (Mac) connected DAC (Chord Hugo TT) – never enable – they sit in “Enabling…” – I can disable, but on reenabling they never become active.

Running 1.5 (build 363) on Mac and on NAS. Mac on 10.14.2. QNAP 4.3.6.0805

I also tried deleting everything Roon-related in ~/Library to force a reinitialization – are there other Roon “droppings” I need to remove to force, or even better a fix for this. Very frustrating…

Thanks.


(Noris) #2

Hello @Graeme_Dixon,

Thanks for contacting us regarding this issue. Can you please make sure that your Hugo TT is powered on, connected to the Core via a USB and has the correct USB input selected before trying to enable it? I would also check your OSX firewall using these instructions as I have sometimes seen this be a cause for failing to enable. Let me know if that helps.

Thanks,
Noris


(Graeme Dixon) #4

Thanks @support – the Hugo is powered on and works fine (have been using it with Tidal app – not at same time as trying to use Roon however).

The firewall on the machine is disabled. I enabled just to see if that made a difference – after allowing the Roon and RAATServer connections, it made no difference.

The iMac and QNAP are on the same switch in my office and I can play content (audio and video) fine from the NAS on the iMac.

Don’t know if this is in any way related, but seeing repeated messages of the following flavor in the system logs:

27366555: RECEIVED OUT-OF-SEQUENCE NOTIFICATION: 293 vs 516, 512, <private>

nw_path_close_fd Failed to close guarded necp fd 22 [9: Bad file descriptor]

Thanks.


(Noris) #5

Hi @Graeme_Dixon,

Can I please ask you to share a screenshot of your Roon Settings -> Audio Tab? It should look something like this:

Also, I just want to confirm here, the same issue occurs regardless of which output you try enabling? As in this behavior is the same for HugoTT, System Output and any other zones you may have?

Thanks,
Noris


(Graeme Dixon) #6


(Graeme Dixon) #7

I have some networked Chromecast and Airplay devices that Roon discovers – they aren’t currently enabled, but I can enable them without any issues.

If I try to enable the Mac’s “System Output” is also behaves like the “Built-in Output” and the “HugoTT” in that it never completes “Enabling…”


(Noris) #8

Thanks for sharing that screenshot @Graeme_Dixon.
I believe something may have gone wrong with RAATServer and I would like to generate a fresh RAATServer instance to see if it helps here. Can you please use the following instructions to do so?

  • Exit out of Roon on your Remote
  • Navigate to your Roon’s Database Location: https://kb.roonlabs.com/Database_Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder
  • Let me know if this resolves the issue

Thanks,
Noris


(Graeme Dixon) #9

Noris,
I tried a bunch of times including reboots in between. No change in behavior – if I try to enable any of the devices connected to my Mac they hang in “Enabling…”.

I looked at the logs in the ~/Library/RAATServer directory and see the following being repeated over and over:

1/11 14:55:17 Trace: [RAAT::HugoTT] [server] [192.168.1.196:42484] accepted connection
01/11 14:55:17 Trace: [RAAT::HugoTT] [session] [192.168.1.196:42484] created: 0x7f8dc07f2120 (0x7f8dc23cbc28)
01/11 14:55:17 Trace: [RAAT::HugoTT] [server] new script with name=raat.dat:base.lua module=base
01/11 14:55:17 Trace: [RAAT::HugoTT] [session] [192.168.1.196:42484] pre-loading lua module base
01/11 14:55:17 Trace: [RAAT::HugoTT] [server] [192.168.1.196:42484] SENT[LL] [1] {“status”: “Success”}
01/11 14:55:21 Trace: [RAAT::HugoTT] [server] [192.168.1.196:42484] read: eof
01/11 14:55:21 Trace: [RAAT::HugoTT] [server] [192.168.1.196:42484] destroying client
01/11 14:55:21 Trace: [RAAT::HugoTT] [session] [192.168.1.196:42484] destroying session


(Noris) #10

Hello @Graeme_Dixon,

Thanks for confirming that for me. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your OSX is active, a set of logs will automatically be generated and uploaded to our servers for analysis. I kindly ask for you to leave Roon open on that machine and connected to the internet so that our servers can receive the diagnostics report.

Thanks,
Noris


(John) #11

Hello @Graeme_Dixon,

Could you try temporarily running the Roon client on your Mac as a “Roon Core”? This will give us some more information to work with regarding where in your playback chain we should be focusing our efforts.

To get started, disconnect from your QNAP Core in Settings > General, and then click “Use this Mac”. Roon will ask you to log in, and then prompt you to de-authorize your QNAP as your Roon Core. Set up the Roon Core as a minimal installation, logging in with your Tidal account is likely all you need. Once you have completed the on-boarding process, head over to Settings > Audio and see if you can enable the HugoTT or System Output zones.

-John


(Graeme Dixon) #12

Did what you suggested (running the “Roon Core” on my iMac with content on a local disk to avoid the NAS) and the Hugo was enabled instantly (as in Hugo TT appeared and was added immediately) and is working flawlessly…


(Noris) #15

Hello @Graeme_Dixon,

Apologies for the delay in getting back to you here, can you please confirm the model of the QNAP you’re using?
Does using the QNAP as a Core and streaming to System Output work as expected? I have started a case for you with our QA team who will take a closer look at diagnostics but knowing if System Output works as expected and the model of the QNAP would be good data points to have.

Thanks,
Noris