Mac Core freezing and crashing when using iOS remote

Roon Core Machine

Mac 10.14.6
Mac mini 2012 2,5 GHz Intel Core i5
Exactly the same as I had in February:

Networking Gear & Setup Details

Internal network

Connected Audio Devices

USB only

Number of Tracks in Library

32838

Description of Issue

I have tried all troubleshooting and resetting and reinstalling tricks.
Still the Core (running on Mac OS) freezes or crashes hard when I try to use the iOS remote on either my iPad 6gen or iPhone 8plus. Same result.
The iOS remote app also crashes or freezes sometimes.
It seems to be when the iOS app initialises connection to the Core.
This is still the same big problem as I had 8 months ago.

I am still really disappointed, feeling like a beta-tester.

Hi @Anti_Wendel,

Sorry to hear you’re still having trouble here! It looks like @noris reached out over a PM so we could take a look at logs, but that message might not have reached you. Apologies! So we can better understand what’s happening, I definitely think we’ll want to take a look at logs after the problem occurs next.

Please note the exact local time + date when this issue next occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. You can upload the logs here:

https://workdrive.zohoexternal.com/collection/3ancn627336cfd60346fe8b3d4b18a82d1c75/external

Ok.
Roon Core Mac just hard crashed again.
It happens when the iOS remote app (new clean install) attempts to initialise Roon.
Nothing playing at the time.
Time was 15.13 local time on Oct 18.
I have sent you “Anti Wendel Roon Logs.zip”


The only cure is to restart computer and not use iOS remote app at all (same on iPhone & iPad).
Without iOS remote app the Core works fine.
I have had more than 50 crashes and restarts so far and have tried everything suggested on forum.

I also sent you the system crash log “Crash log Oct 18 15.13 Roon Core Anti Wendel”

Thanks, @Anti_Wendel. I took a look and I think we might need some additional logging from macOS to better understand what’s happening:

Open Console.app (this is part of mac os x. You can command-spacebar and then type “console” to find it).

Then go into the “User Reports” section, and see if you can find any Roon crashes in there.

For any crashes, paste the contents into a text doc and then send that file over to us so we can take a look.

image

Hi.
Yes I did that already.
Now I also sent you all my Roon Crash logs.
“All Crash logs Roon Core Anti Wendel.zip”

Hi again
Anything else you need from me ?

Hello @Anti_Wendel ,

Thank you for sending those logs over and for your patience here. This looks like a mono-related crash, but it is not clear where this is stemming from.

Can you please confirm if a fresh Roon database also reproduces the same behavior? You can use the following instructions to set up a fresh database for this test:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Please let us know when possible, thank you!

Ok
Did all the steps.
But…
Roon crashed hard on first startup (w new database).
Sent you the log:
“Roon crashing at first startup with new clean database Anti Wendel”

After computer restart Roon started ok.
Tried connecting with a freshly installed Roon Remote on my iPad and got a core freeze (like many times before).
I had to force quit Roon (Oct 27, 21.51 local time)
This makes me sooooooo tired…

Sending you the latest Roon log
“Roon_log Anti Wendel”

Hello @Anti_Wendel ,

Thank you for sending these logs over. I have created a ticket regarding your case and have escalated it to our QA team for review. Once I have their analysis of the new logs, we will reach out again, thanks in advance for your patience here while this makes its way through the queue!