Mac Mini Power Schedule = Manage Audio Devices

When running the headless mac mini with Roon Server and a power schedule (off at 12AM on at 8AM) the Roon app on my iMAC/iPADdoes not see any audio devices.

It’s only when I log in to the Mac Mini (and do nothing else) that the Roon app suddenly sees audio devices.

When the Mac Mini runs 24hrs with no power down I do not have this issue. Thoughts?

Have you tried setting the mini to use auto login? I assume you have the check box for run at startup checked in the roon server icon.

1 Like

Yes, Roon is in the login items. Not sure what else to try and I don’t want to run the Mini 24X7

You say it’s only when you login that Roon suddenly sees audio devices.

So… you need the Mac to auto login.

Have you looked in ‘System Preferences’ - ‘Security & Privacy’

‘Disable automatic login’ should not be checked.

Hi Dan - It’s never been checked. So not sure what’s next. Thanks -

Thats not what I mean…I mean the Launch at Startup in the Roon Server app on the menu bar… sorry wrong words before


Wiz, on the PC side you have to actually log in for the application to run since it is not a service. Is this different on the MAC side?

You still have to login I think (auto) I do that on my Windows Core… ive never seen missing audio devices on my Windows or Mac cores when they are running

Yes. That’s also been checked. Same issue this morning. Can’t just launch Roon without logging in to Mac Mini. I don’t need to do anything when I login to the Mac Mini. For some reason, just doing that allows me to see my audio devices on the iMAC or iPAD.

I recall something on older MacMini running headless that you might need a Monitor faking plug. Not sure if this might help with the audio.

Hi - I do have HDMI on the Mac Mini. Does that make a difference?

how are the audio devices attached to the mini? HDMi / USB or Optical/3.5mm audio?

I have a Dragon Fly on my iMAC. The iPad and Yamaha receivers use Airplay.

Chris, I’m not sure from your responses, but, do you have your mac set to auto login to your account? This is separate from having Roon auto-start.

I mentioned this before too but lets paint a 1000 words or more… mine is set to OFF in this picture of the System prefs Users & Groups Login options


Changing to YES asks for the user name and password to login at startup.


Thanks - I’ll just live with issue. Too busy to keep screwing around with Roon. Just need it to work when I’d like to use it.