Mac Mini, Roon crashing

macOS Sierra, ver 10.12.4
Mac mini (Late 2014)
Processor Intel Core i7, dual (2) cores, 3 Ghz Intel
16 GB 1600 Mhz DDR3 (L2 cache is 256KB per core, L3 cache is 4 MB)
Startup Disk Macintosh HD, 500 GB Flash
External HD, 3 TB SATA LaCie d2 TBT2

  • all music folders are on LaCie 3 TB drive
    Graphics Intel IRIS 1536 MB
  • at time of crash Audio Zone not set, even though I’ve been using a Moon 230HAD dac, using TOSLINK optical cable.
  • this system setup has worked fine in recent past but is now crashing consistently.
  • sorry, at this time I’m not able to capture Roon audio setup screens.
  • aprox 1,150 albums loaded, all on the external LaCie HD, connected via Thunderbolt interface.

Roon fails to start, CPU spikes, here is START OF dump (more available upon request), “Roon quit unexpectedly” :

Process:               Roon [2845]
Path:                  /Applications/
Identifier:            com.roon.Roon
Version:               1.0
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Roon [2845]
User ID:               501

Date/Time:             2017-04-08 20:53:49.133 -0600
OS Version:            Mac OS X 10.12.4 (16E195)
Report Version:        12
Anonymous UUID:        68B564B3-3F59-93FB-51C3-373F74CF3DC5

Time Awake Since Boot: 140000 seconds

System Integrity Protection: enabled

Crashed Thread:        16

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00007fe444125bd2
Exception Note:        EXC_CORPSE_NOTIFY


Model: Macmini7,1, BootROM MM71.0220.B14, 2 processors, Intel Core i7, 3 GHz, 16 GB, SMC 2.24f32
Graphics: Intel Iris, Intel Iris, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x483943434E4E4E434C544D4C41522D4E5444
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x483943434E4E4E434C544D4C41522D4E5444
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x13B), Broadcom BCM43xx 1.0 (
Bluetooth: Version 5.0.4f18, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
PCI Card: pci1b21,612, AHCI Controller, Thunderbolt@193,0,0
Serial ATA Device: APPLE SSD SM0512G, 500.28 GB
Serial ATA Device: ST3000DM001-1ER166, 3 TB
USB Device: USB 3.0 Bus
USB Device: Apple USB SuperDrive
USB Device: IR Receiver
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Magic Trackpad 2
Thunderbolt Bus: Mac mini, Apple Inc., 26.1
Thunderbolt Device: d2 TBT2 USB3, LaCie, 3, 24.3

[end, Sat, April 8 @ 9:06 pm Central Time]
1 Like

clarification : Roon is crashing continually, not OSX itself … .

Hi @Anthony_Mack ------ Thank you for the feedback and my apologies for the troubles here. I would like to grab a set of your logs so we can try and determine what is causing this behavior to occur. I will be contacting you momentarily via PM.


hi Eric,

at worst the initial Roon screen struggles to come up and eventually crashes.

some times the initial screen is fully rendered but the “wheel” cursor spins, like it does when new music has been loaded, but wheel keeps spinning until Roon crashes.

and not too often the spinning wheel goes away but I’m not able to select an album to play because it seizes up, then crashes.

~ Anthony

hi Eric,

LOG of latest crash now uploaded as filename …

crash occurred today, April 10, 2017 @ time 19:26 (7:26 pm).

as usual, Roon crash upon startup, before I could even select anything.


~ Anthony

update : crash problems are on-going. I will provide more details shortly. (Anthony)

Hi @Anthony_Mack ---- Thank you for touching base with me! By chance did you happen to see my last PM to you?



yes, I did remove the first offending file from the directory but the next time Roon crashed the logs highlighted another song file.

now the first song file might indeed be suspect because it was downloaded off the Internet from an “un-official” source, but the 2nd file is “legit” in that it was purchased from a legitimate music download service,, and is in my mind more likely to be free of file corruption. I have many download purchases from Tidal and they have been working fine.

Please stand-by while I find some time to do more troubleshooting. thanks for your help, patience ! 8)

1 Like

Hi @Anthony_Mack ---- Thank you for the update. I will be on the look out for your feedback!


my mistake, I misread one of the later LOG files …

the song file I was thinking of, LOGs did not mention anything about … " failed to extract audio format ".

after that realization … I am now looking for mention of that “failed …” and will remove files, and any other files noted in LOGs as “corrupt”, there are quite a few of those, then will try Roon again.

Please stand by for an update after this try. thanks. 8)

1 Like

? Can you possibly tell what “CorruptFile” and “Failed to extract audio format” mean in the Roon log files (ex Roon_log.02.txt) ?

I am not a programmer but would consider myself very technical. I am preparing to remove all files that are flagged with either of those issues in the Log files, in an effort to resolve a variety of issues including Roon crashes, and more recently Roon tracks skipping within the tracks.

I realize that either of these problems could be caused by a variety of things, but what I want to see first is to see my Roon installation running as “cleanly” as possible, that is without anything flagged as problematic or unusual.

If you have any advice regarding this line of troubleshooting I’m totally open to suggestions or help 8)

thanks !

~ Anthony

Hi @Anthony_Mack ---- Thank you for touching base with me and providing the observations you have made during your troubleshooting. The insight is appreciated!

Being as it has been about a month since we last spoke about any issues you were/are having, I want to just pause for a moment before you delete/remove a bunch content and just reiterate on exactly what the problem is. You’ve mentioned that Roon is crashing and “Roon tracks skipping within the tracks”.

Can you please provide some further insight into this behavior:

“and more recently Roon tracks skipping within the tracks.”

Furthermore, during your troubleshooting have you tried (temporarily of course), hosting your Roon core on another device? If so, what was the experience like?