Mac Roon Client frequently crashes at launch when trying to connect to QNAP Roon Core

Roon Core Machine

QNAP TVS-672N running QTS, Core i7-8700T, 64GB RAM, 6x 10TB WD Red HDDs (RAID 5 - Roon library files), 2x 256GB M.2 SSDs (RAID 0 - Roon Server and Roon database), 2x 2TB M.2 SSDs (RAID 1 - SSD cache)

Networking Gear & Setup Details

One Asus GT-AX11000 configured as AIMesh router plus two Asus GT-AX11000s configured as AIMesh nodes. My QNAP NAS and the Mac Roon client that’s crashing are both connected via ethernet (at 5Gbps and 10Gbps, respectively) to a QNAP QSW-2104-2T 10G switch. That switch is connected via 2.5Gbps ethernet to one of the AIMesh nodes. In essence, the Roon Core and the Roon client are connected to one another via an ethernet switch.

Connected Audio Devices

I have no issues with any connected audio devices other than the Mac with the Roon client that’s crashing.

Number of Tracks in Library

11,945 tracks

Description of Issue

Approximately 75% of the time the Roon client that’s on my Mac Studio crashes when launched. The crashes appear to occur as the client is trying to negotiate a connection with the Roon Core. I can see this because if I disconnect from the Roon Core before quitting the Roon client on my Mac, quit the client, then attempt to relaunch it, the status of the Core always shows as red/“Connecting…” when I first relaunch the client. From that point either the status will turn green/“Ready” eventually or the client will crash or hang. The nature of the crashes vary - sometimes the Roon client will just exit without a message, sometimes the client will generate a macOS error report upon exit, and sometimes the client will hang and I’ll have to force-quit it.

I’ve tried connecting the Mac to my network via wifi as well as taking the QNAP 10G switch out of the loop and connecting the Mac and the NAS to my AIMesh node directly via ethernet. Neither of these effort eliminated the crashes. What’s strange is that all my other Roon clients (iOS, macOS, Roon Ready, etc) seem to be able to connect to the Roon Core without issue - even if at the same time I’m getting continuous crashes when launching this Mac client. When my Mac’s Roon client does manage to connect to the Roon Core without crashing, I don’t experience any further issues unless I quit the Roon client and try to relaunch it…then it’s a crap-shoot whether it will connect or not.

I’ve tried completely uninstalling and reinstalling both the Roon client software on my Mac and the Roon Server software on the NAS with no improvement. I’ve also restored Roon from a previous backup without improvement.

I do not appear to have any other issues with my Mac’s or my NAS’s network connectivity - no drops, lost packets, or anything like that. It’s simply that I can only intermittently launch the Roon Client on this one computer without it crashing.

Thanks in advance for any help!

Great to see you again @Gregory_Schwabacher!

Thank you for reaching out to us with your question. My apologies for the delayed response and for your wait. We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual.

I’m sorry to hear that you were having issues with your Mac Studio crashing. Since some time has passed I wanted to touch base to get your current status. Are you still experiencing this problem after updating to the newest Roon build 952?

We’ll be watching for your reply and get back in touch as quickly as we can. Thanks!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.