Macbook Air copied from MacMini won't show up as an Endpoint

Core Machine

2014 MacMini with Big Sur
2020 MacBook Air with Big Sur


I have been using Roon on my MacMini (running Core) with many Endpoints without any issue. I recently purchased a MacBook Air, on which I used the MacMini backup to initialize. My goal is to continue to use the MacMini as Core and the MacBook Air as another Endpoint. But when I go into the MacBook Air’s Roon instance, after logging into MacMini’s Core, it doesn’t show the MacBook Air as an Endpoint. As a matter of fact the Settings → Audio page looks exactly like the Audio page from the MacMini, with “This Mac” referring to the MacMini.

I’ve tried reinstalling Roon after deleting the Roon and RAATServer libraries but that doesn’t seem to help.

I’ve noticed a few people have posted about this in the Support forum, but the solution doesn’t seem to be posted. Would you be able to help me with this?


In to the Mac clones the same users should not be logged.

I had the same problem a few days ago. Reinstalling roon and reinstalling macos didn’t help. The solution that worked was formatting the drive, reinstalling macos, and then installing roon (from a roon backup).

1 Like

Interesting. Does that mean I can just change the name of the User on one of the machines or do I need to delete the user and create a new user on the machine?

Wow. That’s pretty drastic. Then I would I have to reinstall everything and copy everything over manually on the MacBook Air.

Thank you. I’ll try this if I can’t figure out an easier way soon.

Good luck; hopefully you’ll find a less drastic solution, but the fallback I suggested certainly works.

Neil, Thanks again. I finally tried your suggestion and it worked perfectly.

I just hope they find a better solution for this. It took me all morning to rebuild my computer.