macOS 11 Beta not allowing me to open the Roon App

I use my Mac to store my music collection. I’ve used successfully for 9 months or so and recently updated my software to the Beta version of Mac OS 11. I’m sure that the problem I’m having a Beta related issue. My questions:

  1. Have any of you experienced my situation?
  2. If so, do you think that this is an issue for Roon or Apple.



Doubt you get support from either since your using a beta software. it’s in the apple agreement and Roon’s not responsible. i will say however i’m using Big Sur beta too. Working nicely on Mac Mini. Tidal login issue continues.

Thanks Rudy,

Strange, my Tidal works normally. I’m sure it will get worked out eventually. Good luck!


I’m been on the beta since Day One and have had no problems with Roon.

My connection to my NAS stopped working a couple of weeks ago with Big Sur. Roon has an “unexpected error” when trying to connect. Completely removed Roon and reinstalled… same issue. Tried every trick posted on here about connecting a NAS, and none of them work. I minored in networking (20 years ago) in college… so I know my way around a bit. I think it’s a Big Sur compatibility issue with Roon. One of the 2 needs to address it.

/usr/bin/kmutil load -p /System/Library/Extensions/smbfs.kext


Run sudo kextload /System/Library/Extensions/smbfs.kext

it worked for me.

1 Like

i had same issue with recent beta. I added my NAS as a volume against Roon suggestion but it worked. Also received this solution from jhwalker. Yes, for some reason Beta 6 messed up network file shares / SMB.

To fix, run this command in Terminal:

sudo kextload /System/Library/Extensions/smbfs.kext

I’m sure it will be fixed in Beta 7, as it got a lot of noise in the forums.

Worked like a charm. thanks!

1 Like