macOS Catalina interface laggy randomly while running Roon (High GPU usage randomly, Roon idle 20% GPU, sometimes up to 99% usage) [Resolved in Roon 1.8]

@noris sorry to reply back again, if you need a beta tester for this issue I can do the job if works for you guys.

1 Like

Thanks for the offer @mavmcl, appreciate it!
I will let QA know.

1 Like

Hi @noris have had any word from QA yet?
Thanks!

Hi @mavmcl,

No news from QA at this time. We’re still testing a new build internally, hopefully we will have more to report soon.

1 Like

Thanks @noris fingers crossed :slightly_smiling_face:

Hi @noris please pass this feedback through the members of your team.

Nowadays given the global situation we spend more and more hours working in our computers, more and more hours using Roon.

Today has been particularly frustrating we really need to get this issue fixed as the software usability is highly compromised, it is highly disappointing for me to have to eventually switch to Audirvana (which I don’t like) as if I don’t (almost) count my clicks in Roon my GPU hits 100% which is NOT healthy for my machine that ironically I bought to run Roon’s beautify interface in full screen…

I will not complain about metadata or trivial stuff you get so many requests about, this is something real about software design and functionality that could even compromise the hardware (potentially), as well I am not willing to pay extra on my energy bill as the 100% GPU usage will come at 300W hour, against the normal 40W… it makes me wonder if there is a real leak or something… sometimes these computers from all of us the affected ones behave like if someone was mining on us (CPU and GPU)…

Is there a way you can escalate this to have higher priority (most of software companies will react to a situation as this) I don’t know the company hierarchy honestly, I know @danny is high in the hierarchy so he may be willing to help, please release even a beta, any beta will behave better than this current Roon version for Mac users.

Not to mention the high CPU issues/reports you constantly get as well, which seems to have no resolution since 1.7 came out (nov 2019)… once again real software functionality issue, not metadata or display or trivial thing… I would say this has even higher priority than any streaming integration issue.

Please Assistance, can’t even conceive the fact of been having this issue for more months. I strongly believe in your product and consider Roon is the best option in the market without any discussion, but need help to address this bad issue.
Thanks.

1 Like

Hi @noris do we have an update on this? would be great to have some clear expectations.
Thanks.

Hi @support look the workaround I had to come up with to contain the OpenGL GPU issues in macOS:

GUI in a minimal windows 10 install running on parallels headless VM with coherence, not a workaround at all but I will have freedom to use the interface without entering/triggering the looping 100% GPU usage, although the interface is not as fluent as the real one I can run it in full screen and click around.

Please help can’t go like this too long, highly affected user experience for a lifetime member, never thought I would have to operate Roon like this.
Thanks.

ezgif.com-video-to-gif

Hi @mavmcl,

First, I want to let you know that your patience has been much appreciated as we’ve investigated this issue further internally. I met with the QA team today to discuss how the testing of the new build was going.

While the changes contained in the new build are helpful in many ways, unfortunately this specific GPU issue is not resolved by the changes that were made. We are, of course, continuing to investigate this issue further and we hope to have more changes to make in the future to address this, but unfortunately these changes will not be a part of our upcoming release.

I know this isn’t the news we were hoping for, but the team remains confident that they’ll be able to resolve this issue with some further investigation. I’ll continue to keep you in the loop as I receive more updates from the team, and once again, you have my thanks for your patience here.

1 Like

Hi @noris thanks for following up on the latest updates from QA team.
Thanks for honest feedback. For sure not what I and other users with this issue wanted to hear.

Is there any expected ETA for them to address this? it is quite painful having limited GUI functionality and/or keep monitoring the GPU resource usage, it is very very concerning thinking about having to deal with this issue for 2 or 3 more months or even years!
Thanks.

Hi @mavmcl,

First, I’d like to say that we appreciate your patience as we’ve continued to investigate this issue. After gathering data from a number of reports, as well as our own testing, we’ve traced this issue to a specific GPU series that appears to not be handling Roon how we’d expect.

While we don’t have this resolved just yet, our QA team is in the process of acquiring this specific hardware for further internal testing in our labs. With this specific hardware in house, we believe we will be able to see first-hand why certain devices are not reacting to Roon the way we’d expect and can then get a report to our development team to resolve the issue.

Hardware-specific issues like this can require some in-depth testing to fully understand, so we can’t offer any specific timelines just yet. With that in mind, we want to assure you that this is a top priority for us. We want to make sure that we get this right, and we know it’s already taken longer than anyone would have liked.

The team remains confident that bringing this hardware in-house will be a big step toward getting this resolved, and we will be sure to keep everyone in the loop as soon as we have further information on this. Thanks again for the patience you’ve shown as we work to resolve this, along with the great details you’ve all provided to us to aid in our investigation.

Roon Technical Support

1 Like

Thanks @dylan and @noris appreciate the transparency, at any moment feel free to ping me to have access to my hardware to do any testing you may need as that iMac 2019 is dedicated to Roon.
Thanks.

1 Like

Hi @support guys, just FYI no changes at all after 571 deployment as expected:

All Mac clients updated to 571 as well.
Thanks.

Hi @dylan ,

While it’s great to hear that you guys are working on this, the news that you are pursuing a hardware specific cause is a bit disheartening, for me at least, as I am experiencing a very similar issue on a quite different machine with different internals (2013 Mac Pro, details are below)

Shall I chase for a resolution on that ticket separately or will it benefit from your specific testing efforts for @mavmcl 's issue?

Thanks,

that is interesting in a disencourage way :upside_down_face: so happening in old HW as well.
haven’t pay attention to those HW details when shared the link with you @Yargi_Erel

Hi @Dylan @noris is there any progress on this issue? any QA news you can share with us?
Thanks.

@Dylan @noris another report from @gary_v the situation did not improved after 528 as we all know, this user reported this back on December 8 months ago, need higher priority.

1 Like

Hi @mavmcl,

There are no updates from QA at this time, but they are aware and working on this issue. Once we have further news to report, we will be sure to do so here, thanks!

1 Like

Hi @noris I just noticed something new. Since version 571 I just stopped attempting to use Roon interface in full screen, now using it as a window in my main desktop, so I had a lot of windows open so reduced the Roon window size from lets say 2/3rds of the screen to the smaller size Roon allowed me, I did noticed the GPU usage went down from around 30% to 6-10%, hope that can help QA.
Thanks.

2 Likes

Thanks for the additional info @mavmcl, I’ve noted this in the ticket.

1 Like