MacOSX Local Audio Output Disappears

I have the following setup:

Windows Xeon E5-2630 v4 CPU w/64GB ECC RAM
96TB SAN - All connected via Avago/LSI 9280-16i4e
Gig Ethernet LACP to Switch x4 = 1x4Gig Interface at switch

DCS Rossini connected via Ethernet to switch

I also have a few iPads I use as remotes for my system when listening to music over my Rossini.

Everything else is Windows based other than my Mac OSX 10.13.3 High Sierra running the most recent roon (1.4 build 310 stable 64bit as of 3/28/2018).

I occasionally listen to music played back on my Mac. However, I’ve noticed that whenever I connect to my network via wifi, the local output (both the System Output and the Core Audio output) disappear and are no longer an option. I have the blue button at the bottom that says, “Select an Audio Zone”.

I uninstalled and reinstalled and the outputs reappeared, but then disappeared soon thereafter. What’s going on and why are my local outputs disappearing?



@Bryan_Allen Maybe your wifi is connecting to a guest network? A guest network will not normally allow for connectivity to other local endpoints.

What is the service order when you have your Mac operating on wifi and LAN together? Maybe you could indicate what MAC is this - MacBook? or iMac?

Is this happening when its only connected to wifi or when its connected to both wifi and LAN?

If your service order is not configured to prefer LAN over wifi it might be something to do with your network settings for the wifi.

I can control the rest of my network devices (my Rossini and a couple of Sonos devices that are connected via ethernet
– sorry forgot to mention the Sonos devices) when I’m on my Wifi (and I don’t connect to my neighbors), so I’m connected to my network. I’m also a Network Engineer/Programmer so I’m technical, no simple answer like that is likely :slight_smile: haha.

It’s a Macbook Pro, 2.8 GH Intel Core i7, 16GB DDR3, Intel Iris Pro graphics. I have two of them and the same thing happens on the other device.

@support Time to get the higher powers that are Roon support in on this. I use my MBP as an output mostly on wifi and haven’t noticed this but I am traveling currently and updates have happened in the last week that might have some impact that I haven’t seen yet.

Was this happening before the B310 update the other day? I see you are lifer and long time user so if this is a new issue maybe it due to the update.

I too have a network engineering background. :smiley:

The local outputs appear in response to the Server’s query of the local computer. So when you are connected via ethernet, your mac is responding and the RoonServer is creating those endpoints. When you are connected via wireless, the server is not receiving the response to its queries so the endpoints are not being created.

The most likely answer is that you have some extra firewall/security on the Wifi that is not on the Ethernet side which is blocking the Server’s query.

Hello @Bryan_Allen,

I think @Rugby is on to something here, can you check your Macbook Pro for any installed security or firewall software?


Yup, sorry. Forgot to mention CISCO ASA sits in-between VLANS and Wifi is on its own VLAN. I’ll need to put it in debug mode to see what’s going on.

Very helpful info @Rugby – I had no idea the server sends outbound request to clients. I’ll try that and get back to everyone. Thanks again.

I haven’t played with VLAN’s in Cisco but other brands typically use different IP ranges for each VLAN and even with routing between them I dont think Roon is going work over them.

So you’re saying it has to be in the local broadcast segment then? What about enabling proxy-arp? That typically allows MAC addresses to traverse VLAN’s or routed segments. Because I have that enabled and I can see the MAC get sent back to Roon server from the ASA.

If Roon Server is sending out a multicast 224 or broadcast for the device it should get to it as I’m routing into the VLAN.

It is a different IP range you’re correct and it’s routed through the ASA.

Appreciate everyone’s help. I was also playing with accessing Roon via my VPN and have the exact same issue (VPN remote client gets and IP yet another VLAN, but it’s on the same security level as the Roon Server.

So interesting thing, I remoted onto my Roon Database/Server and kept the Macbook pro Roon Client running, restarted the Server and it showed the local output. It worked for a day and no longer works again.

OK, so here’s what I’ve figured out. I had some ACL’s not allowing traffic between the two VLAN’s. That’s resolved any issues from Wifi to Wired.

On the VPN side, I had to add an external NAT rule to allow clients to connect to the Internet through the network when they VPN in. I also had to change it to L2VPN client setting and then the local playback devices started showing up.

I do have one problem and that’s with the VPN clients. They will start playback and then a few seconds into the song I will get a message saying there is a playback problem saying, “media is loading slowly…this may indicate a performance or hardware problem.” I watched the data usage and I was very quickly consuming a ton of data, actually streaming the entire size of the file over the VPN.

So here’s my question: Does Roon have an option to transcode (or scale down) a connection down or down sample audio to smaller sizes (bitrate conversion) at the server so that the full amount of data isn’t sent over the network and VPN (like JRiver does actually – it will let you select the quality of the stream to your client by changing the “Transcode Audio Quality” – which in turn does all that server side. I’m likely going to run into this issue trying to remote into my network from other places as well. I have FTTH Gigabit Internet so there’s no bottleneck in my home – it’s everywhere else. A good amount of my collection is 24Bit and DSD audio – at least the stuff I like the most unfortunately. Any thoughts on this issue?

Using Custom in the sample rate conversion under dsp will allow you to set everything to CD quality, which is as low as Roon allows you to go now. I would imagine that when they roll out Roon Mobile it might be an option.

But does it send the full data amount to the endpoint and the conversation happens there, or does it do the sample rate change at the server/database side?

In Roon, all processing is done at the server.