Macs, iPad no longer showing as audio devices?

Core: Nucleus (2020), Roon version 1.8 (build 1021), RoonOS 1.0 (build 227)

Hello all,
This issue has cropped up a few times on old, closed threads, and I’ve been unable to find a solution. In the past, my various Mac desktops and iPad Pro have shown up as audio devices (capable of listening to audio on them), but at some recent point, they have all disappeared.

I live in a small apartment, and primarily listen in my listening room (KEF LS50 II) which is hard-wired into my network switch, along with the Nucleus core. The iPad / iPhone / MacBooks are all on wifi. Every device interfaces as a remote just fine, but as of late, I can no longer select a Mac (or the iPad) as an audio source to listen to music through. Important: this was possible in the past. It has always been possible when I first purchased the Nucleus and my lifetime Roon subscription (maybe 3 years ago).

I’ve checked the KEF audio settings and there is no “private mode” setting enabled. When clicking the icon of the KEFs in the lower right corner of any of my remotes, there are no other audio devices showing.

Ideas? Thank you.

If you haven’t already, turn on your iDevices and start Roon on each of them. Then go to Roon - Settings - Audio and see if they show up there as Roon Ready devices and have been set up properly.

Hi, thanks for the reply. Sadly no. Here’s a screenshot from the iPad Pro. Again this seems to be a recent development; I say recent because it’s been months since wanting to listen on an iDevice, but however long ago that was, it was possible and said device(s) did show up on my audio list.

Have you tried deleting the Roon app from the iDevices and reinstalling?

Just re-installed Roon. Nothing has changed on the Audio settings menu, no iDevices or macs are showing.

Try switching from 2.4 to 5 or from 5 to 2.4 WIFI frequency.

What do you know! Switching to our 2.4 network worked (iPad)! How bizarre.

This is great but obviously I’d rather be operating on the 5Ghz network; the 2.4 is only there for our home devices (outlets, robot vacuum etc).

2 Likes

As my apartment is rather small (1k sf) and the speed difference is negligible (211-78 vs 206-90), I suppose we could just keep the devices on 2.4 (unless a local transfer etc is needed when I can switch over to the 5)… but still, I don’t understand.

As all your troublesome devices are on wifi and switching frequencies fixes the problem, I suspect your router (what type/model is it?) may have something to do with the issues you are experiencing. When was the last time it was rebooted?

2 Likes