Major problems with Roon (new user) [Resolved - Build 222]

Hey Fernando and Tony,

Thanks for the info. I’ll make sure to consider that when I decide wether or not to keep the account.

However, My remaining issue (timeout rendering specific albums) is not a power issue. The NAS is relatively idle (in all aspects - CPU, Memory, IO and general load).

@support may be able to help but they will need to know the albums, format, resolution etc

Thanks Tony,

@support, The album that it happens the most is Sigiswald Kuijken/La Petite Bande playing Matthaus Passion by Bach (see attached screenshot). The format is flac 192/24. I’m not sure what do you mean by resolution.

Hi @Haim_Ashkenazi
How did you check that it is not under heavy load? Did you try to open the “Resource Monitor” in the QTS and watch the CPU graph in the “system resource” tab? Check if there are any spikes when trying to play that high-res album.

Regarding your SSD: I am not sure if I understood you correctly here. Is your library (=audio files?) stored on it or the Roon database?
Where did you store your music files?

Hi @crieke,

I was looking at the resource monitor many times in the past few days. As I’m writing this response I’m trying to access several albums including the two problematic ones. The big(ish) spike in the middle (reaching about 60% CPU) happened when I was trying to access one of them and it didn’t succeed (it stayed at Loading Album… a long time after the spike was over. Also trying to go to other albums didn’t succeed. After a minute or so I was able to browse more or less freely but when I tried to access the second problematic album it got stuck again (this time no spike at all). During this time I was able to play and stop the music without a problem. BTW, it’s been several minutes since and I still can’t browse (although as I said I stop and start the music at will).

Here’s the screenshot:

The database is located on the SSD (as the documentation instructed). The flac files are on the regular 7200 RPM disks.

Thanks :slight_smile:


Is it possible to connect an USB audio device directly to your QNAP? (best would be if it is capable of 192khz/24bit).
I would like to rule out any network issues and in this scenario everything will happen locally on your qnap.

Hi @crieke,

I’m not sure I follow. The problem happens regardless where I play or even if I play. This morning I played directly via the Qnap HDMI and it still occasionally timed out the album. There’s something in these two albums :frowning:.

BTW, only one of them is 192/24. The second one is 44.1/16.

Thanks :slight_smile:

ok, understood. :slight_smile:
Just for confirmation: Other HighRes files play fine without issues?
Do these 2 said albums have anything in common?

Hi @crieke,

I think there’s some misunderstanding. The playing on my mac issue was solved a couple of days ago by configuring exclusive mode on my BuildIn audio device. Playing is always good via Qnap’s HDMI.

The timeout I’m experiencing is not with playing :smile:. It’s just with displaying the page for these two albums. Nothing really in common. I only added about a dozen albums, most of the albums in my library are from Tidal (these two are not). It’s really strange. I actually have to sometimes restart roon client in order to be able to browse again after it happens.

Are both albums “large”, Eg many tracks or multi disc? The Bach is of course, but is the other?

Hi Nathan,

Bach is 3 CD’s and the second one (Britten’s Albert Herring) is 2 CD’s. I have other 2 cd albums that load without a problem.

Thanks :slight_smile:

Sorry for my bad grasp today! :smiley: I think the timeout confused me (and I mistakenly connected it to audio playback).
If you move both albums out of your watched folder hierarchy, then everything is fine?

I think I never experienced this kind of timeout here.

Where did you put your flac files? Are they on a separate share on the QNAP?

Hi Haim,

I am in a similar situation, that occasional multi-disc albums load but others do not (either blank screen or error loading saved page).



My flac files are in a Roon under the Multimedia share. I don’t have to take them out of the directory, I can just not view them and everything is ok. It’s just when I want to view them that it happens (not all of the time, it comes and goes).

That’s disturbing :frowning:, how often does it happen? Do you happen to know if there’s a difference between Tidal albums and regular (from file) album? I still have almost 1000 albums to copy and I’m afraid that many of them will behave like that.


I just scrolled through my Tidal albums and many 2 - 3 disk albums timed out. I’m afraid it doesn’t look good. No matter how nice the experience is when it works, I don’t want to struggle with it so much.


@support, do you have any idea that will save the day?

1 Like

Hi @Haim_Ashkenazi ---- Thank you for the feedback and my apologies for the troubles. I wanted to touch base with you to let you know that we are aware of this issue and steps are being taken by our tech staff to address it accordingly.

From @Mike:



Great to here. I would really hate to give up on this :smile:.

Build 222 was just released and it seems to solve this problem. :smile:.

Thanks @support.