Make Roon available to play local content during an Internet fade

Core Machine (Operating system/System info/Roon build number)
Roon Core runs under FreeNAS 11.2 BHYVE jail containing Ubuntu 18.04 and Roon Core

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Provider: Hampton Roads VA COX
Network hardware: Ubiquity UniFi USG, switches and access points up to date
Core is on wired Ethernet. Most Roon Bridges are wired also. Most roon controllers are WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Important audio devices are SPDIF. Desktop Schiit Modi 3 is USB
Away from my desk, Roon Bridge runs on a Raspberry Pi. 2 have hats, a third is hatless, a fourth is Shairport only (no roon bridge).

Description Of Issue
Roon is unavailable while Internet is down. The following sequence of events occurred.

  1. Power cut over night
  2. ISP fade coincident with power cut
  3. Dominion restored power. Cox Internet and cable still down
  4. Recovered internal network with the exception of off-site link to COX
  5. Restarted FreeNAS server and all services including Roon Core. Library is on FreeNAS server
  6. Tried to start a roon controller.
  7. Roon controller sat there looking for core
  8. Cox restored service
  9. Core checked in to verify license and connect to TIDAL and Qobuz
  10. Roon Controllers connected with core and I could finally, 3 hours later, play local music.

It would be really nice to play the 600+ albums in the local library while my ISP was down.

Assumption: Roon is verifying licenses with home before proceeding further.

Proposed behavior:

Offer local content based on most recent license verification and a time to live following verification. Kind of like Kerberos works. If instance holds a live service token, come up and provide available local services until Internet connection is restored. When Internet service becomes available, authenticate the account and core instance, check in with subscribed services, and begin offering off-machine content (both artist and title articles and music).

Hi @David_Hamby,

Roon periodically checks for licences but a temporary ISP outage should not affect your Core in this way, especially since you were stuck on the “looking for Core” page. I would imagine being presented with Roon asking for your login but the Core should not disappear when there’s no active ISP connection. I have a few follow-up questions:

  1. When this issue occurred, did your Core still have a valid IP address?
  2. Was the behavior the same from multiple WiFi Controllers?
  3. What about Ethernet controllers, did those allow connection?
  4. Do you recall the approximate time/date when this ISP outage occurred and when you were able to log in?

Problem presented in the context of a neighborhood scale loss of mains power stopping core and all endpoints and ISP local battery backup boxes.

When power was restored, internal network recovered but ISP was still sorting outage related problems in their plant for a couple of hours. ISP restored service at noon, 2 hours earlier than promised. Power was back by 1000.

Core had a valid RFC1918 address. Core and FreeNAS host have independent network addresses. Everything is sorted now. Core was indisposed for just the 2 hours with power but no ISP. iPad and MacOS controllers were affected. Without a working controller, endpoints had nothing to do.

UniFi networking is extremely robust but we have only the COX cable modem path to the outside. No standby redundant Internet link.

The recovery was not very orderly as power was restored while I was away.

  1. Power was restored
  2. Switches restored POE
  3. UniFi controller restarted (UniFi Cloud Key device is POE).
  4. UniFi USG router restarted and began DHCP service
  5. Audio rack power restored manually (power amp is hard starting load)
  6. FreeNAS server and Roon Core restarted by hand. This machine set for manual power restore start
  7. Checked in on Roon Core from iPad. Controller would not connect
  8. May have checked in from MacOS, don’t recall

ISP restored service around noon as indicated by iPad alert delivery
Roon sorted itself and has been well behaved since.

It takes a while for FreeNAS to start, start the Roon VM, and start Roon. I could have jumped the gun but recollection is that problem persisted after a reasonable wait. I checked FreeNAS to confirm that Roon VM had started and had an address. I tried Roon on MacOS and it stalled waiting for core also.

After ISP restored service Roon quickly became its usual agreeable self.

Hi @David_Hamby,

Thanks for sharing those additional details. I spoke to the technical team today regarding your report and they have confirmed that the expected behavior when there’s no internet connection is to be presented with the login screen, not with the “Searching for Core” screen.

We’re not sure what exactly happened in your case, but the FreeNAS hosting the Core might be related to the issue. If this is a common occurrence in your area, I would check to see what the behavior is like when it next occurs if the Roon Core is hosted on a regular PC without a VM.

Possibly. How BHYVE shares the Ethernet connection could be the issue. UBUNTU is seeing a virtual NIC of type Intel e82545 as em0.

Behavior of the virtual NIC is not specified in much detail. FreeBSD Driver is libvirt. Ethernet is implemented with “bridge” semantics so Ubuntu should be seeing an Ethernet port. Intel e1000 device is emulated.

I don’t know that it is worth chasing as power without ISP service is less common than loss of power which is 1 to 2 times a year here.

HI @Davd_Hamby,

Thanks for sharing those additional details. I do believe that using the VM may have been part of the issue, so if this behavior occurs again I would verify if it impacts a properly spec’d Roon Core outside the NAS VM Environment, otherwise it’s very possible that this was a setup/environmental cause.

I’m going to go ahead and mark this thread as [Solved] since this issue occurred only once and doesn’t seem to occur regularly enough to troubleshoot, but if you experience further issues, please feel free to reach out to us again and provide a link to this thread. Thanks!

Be glad to if you’ll port core to FreeBSD. I really like having Core and the library on the FreeNAS machine. The music dataset is mounted as a VM device so music access is very simple and robust. I’ve had Core on a 2009 Mac Mini running Ubuntu. It was always a little flaky regarding CIFS access to the music library. And we were having occasional stalls. Moving all to FreeNAS VM and it just cruises. Most likely would put Roon in a Jail in that case.

Big fan of FreeNAS with Roon. My server is set up RAIDZ2 with replication to an 8TB internal disk and a second off site backup to Backblaze B2. Nothing out there comes close to Roon. Bit Radio fan and TIDAL Qobuz integration fan.

This topic was automatically closed 13 hours after the last reply. New replies are no longer allowed.