Make sure modem is in BRIDGE mode!

this might be obvious to 99% of you, but for me, it was not.

I have a comcast modem, and an Eero wifi network.

Couldn’t get ARC to connect.

One of the community members suggested i was double NATted, and the comcast router needed to be in bridge mode. So I logged into the comcast router ( and changed it to bridge mode.

That solved the issues.

ARC connected no problem after that.

I opened my Eero app and found the core on the network, opened 55000 for roon, and i was good to go.

Thanks for the tip. Is bridge mode mandatory / required? My setup is all via Ethernet. Comcast Router to a Switch then out to devices. Roon (Nucleus) Settings and Arc App are all connected and I can see my library and Roon Radio Selections on the Arc App (iPhone)….just keep getting the ‘Poor Connection’ Message.

I found that setting Ip passthrough on my AT&T modem worked for me in a similar situation with an Orbi router on the network side of it.

Dont switch to Bridge mode unless you know what you are doing. If not done on the correct device in your chain you will cause other problems and often will need to manualky log in via ethernet to get out of bridge mode.

1 Like