Many images missing after unplugging system

Roon Core Device

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I unplugged my system to change a wall outlet. After rebooting, many of the images of albums, live radio stations, and even microRendu image in the play bar are missing.
Why is this happening; how do I fix it?

Many album, live radio and other images have disappeared. Even the image on the play bar of my microRendu is gone.

What’s causing this and how can I fix it?

Moved to support area. Have you made any troubleshooting steps like rebooting everything?

Thanks, Ged.
I’ve turned transporter off manually, rebooted it from the web controller, closed Roon and reopened with VPN and firewall off, deleted/reinstalled Roon, cleared image caches in settings, etc. Nothing works. More images are gone with each of those steps.
With gratitude,

I would have hoped for some of that to work !

Can you describe your setup David as per the following:

  • Details on your Core machine (OS, Hardware specs, Roon build)
  • Details on your Remote(s) (OS, Hardware specs, Roon build)
  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
  • Audio devices in use
  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)

Thanks, Andrew,
First, no problem with the mobile app.
Small Green Computer sonicTransporter i5

Verizon GS3100>
tp-link ethernet over powerline from router>
2nd tp-link eop to Trendnet switch>
sonicTransporer and microRendu>
Chord Qutest>
Qobuz sub
Library is on SSD in sonicTransporter
191 albums in library

I hope this helps.
I had similar problem a few months back but reboot of transporter fixed it.


Now profile image is gone. Also, category images in Live Radio are missing.

How did you shut down the system before you unplugged?

Maybe your Roon library is corrupt.

Do you have multiple Backups from before you did the shut down. If you do, try taking another Backup. If there is corruption that should fail with an appropriate message.

I just unplugged everything w/o backup or shutdown. Could that be the problem? Uh, I’m a neophyte, I’ve never done backup.
Do you mean I should have received a ‘fail’ alert upon corruption?


No, if the library is corrupted, you will be notified when you next try to run a Backup. This happens so that a corrupted library will not be backed up and thereby potentially overlay a good Backup.

Since you have never taken a Backup, you have nothing to lose by trying a Backup now to see if you get a message about a corrupted library.

Also, see this article.

Thanks xxx!
So, do I need to delete Roon from my laptop before backup, so that a reinstallation will create the new folder?

With gratitude,

No, lets see what an attempted Backup results in.

Use Settings==>Backups==>Backup now, of course.

If it’s successful then a corrupted library isn’t your problem.

Sorry for obtuseness, but does above appear in My Stuff? I don’t recall ever seeing that. Aren’t I supposed to exit Roon first? You lost me.

From Roon on your laptop -


Your Core is on the sonic transporter, not your laptop. So, as long as your laptop is up to date, don"t worry about it.

You’re using your laptop to control the Core, so issue the commands I talked about from there.

Got it! Thanks, again. The complexity of Roon is a bit daunting at times.

1 Like

I was using JRiver, but Roon is superior in many ways. I hope I’m not offending anyone.

Alas, the backup did nothing to fix the problem. I found some backups and hit restore on the oldest from 14 Feb. That didn’t help either.
But now I know why Dropbox is in Roon

So, any suggestions?

Ok, you misunderstood why I asked you to do a Backup. You said you didn‘t have any Backups.

I asked you to do a Backup because that was the quickest way to determine if your library was corrupted. I didn’t expect anything to be fixed by that.

So, you did a Backup and it went successfully and you didn’t get any messages about corruption?

Yeah sorry, I clicked Backup before looking in Find backups because I didn’t think their would be any to find any since I hadn’t set up auto backups. I didn’t know they were being saved automatically.

Right, no corruption messages.

Ok, I am tagging @support to see what they have to offer.

On the subject of Backups, Roon doesn’t automatically set up Backups. You must have done that at one time. Doesn’t matter.

When this gets all straightened out make sure your Backup situation is as it should be, so if in the future you have problems that can be solved by a Restore, you have the Backups to do that.

Good luck.