Many missing albums[Solved]

I have been using Roon fro a week now. I like it a lot, except for the fact that I have to use the Tidal service instead of Deezer as I was used to.
However, i have a problem with albums not showing up.

The Roon server is on a Mac Mini (2011 server edition with an SSD and a HDD drive), connected with cable to my router. The software is on the SSD. I have my iTunes files on the HDD, including the FLAC subfolder.

Further I have a laptop I used for listening with a head set and the remote software on my phone.

On the screenshot I have the Synology server showing only 6164 tracks - I have more than 24k files in the music folder - some will be album covers of course. This server has all my music - both the files from the SSD and old low quality digital files I don’t listen to anyway.

The folder called “FLAC” in the iTunes media folder has 5298 files. These are my main music files, newer purchased highres files and my CD collection in 44kHz/16bit quality. But Roon only shows 307 files imported.

A good example is the two albums from B&W’s Society of Sound for October. I downloaded the album with Kjartan Sveinsson in 24 bit and the Sibelius Symphonies in 16 bit. After forcing rescan, Kjartan Sveinsson’s album showed up, but the Sibelius Symphonies have still not showed up. I even copied this album directly into Roon - I am not ware if that put it into the SDD, but there should be 3 copies of that album in the system now.

Probably some old defect files somewhere are stopping download, but how would I find them?
I have searched for .wma files and deleted all those I found.

Best regards Kim Jensen

@Kim_Jensen - since your FLAC folder is a sub-folder of your iTunes Media folder, you don’t need to explicitly add this to your list of storage folders. I wonder whether this is confusing Roon? What happens if you remove the FLAC entry from your list of storage folders?

The other thing that might be causing an issue (apart from corrupt files) is blacklisted folders. See here.

If neither of these issues is at play here, then, as the FAQ suggests, please provide a copy of a problem file to the folks in Support.

Thanks Geoff
I have removed the subfolder FLAC.

I have soome CD images with cue sheets. I can see that some are missing in the library and some appear as one file only. I am in the process of extracting some of the to see if it helps - but would it block the software from looking further, when it comes to one of these.

I also have some 8-10 years old ape files.

Nope APE or single-file image+CUE, I’m afraid – though it is quite easy to convert to individual FLAC files that work with Roon.

Also: in your screenshot, the spinner (first icon of the top-right three) is active, meaning Roon is still busy processing. Can you click on it and post the popup that appears?

Here is the popup. It has been around the 184 files for days

Hi @Kim_Jensen ----- Thank you for the report and my apologies for the troubles. I’d like to grab some logs from you and will be contacting you via PM shortly with instructions.


I am missing album that were there before but dont show up mow. there are still clearly on my nas. I downloaded the support file. What email can I send it to.

Samir F. Jain

Hi Samir and welcome to the Roon Community,

I’ve edited your post to remove your email so spam robots don’t find it and ruin it for you. Usually Support is carried out publicly because a lot of very helpful users on this board help solve problems. If you would like to send a private message to someone then clicking on their avatar and selecting “Send Private Message” is the way to do it. I’ve upgraded you to Basic user so you can use PM.

None of that solves your problem though, so let’s drop a flag for @Eric (that syntax will create an alert for Eric) and he will drop into this thread again and gather details from you. If he should ever need your email address he can look it up from your registration.

Edit: what file format are the missing albums ?

1 Like

Hi @Samir_Jain ------ Thank you for the report and my apologies for the troubles here. May I kindly ask you to please provide some details about your setup as seen here.

Furthermore, as @andybob has mentioned, can you please verify what format the files in question are?


Hi Eric. Thx
Running ROON version 1.2; Build 161; stable 64 bit
OSX 10.12 (but my computer is out of the chain); Ipad mini 4 w/ ROON app
Music is on a Synology NAS; WD Green or Red? Hard Drive
ROON Server on Sonictransporter (not i5) --> Microrendu USB --> Devialet --> Raidho D1
Nothing else in the chain.
Tracks are 11000 in ROON, but number of files in folder reads 18000…
Mostly all FLAC; some DSD
Verizon Gigabit router; Wired to MicroRendu
HiFi Tidal USA

I think many others missing but I noticed the lack of them when I saw 2 Morning Phase Beck albums are missing, one a vinyl rip at 192 one a HD tracks version at 96; Also noticed then the HD tracks version of The Information Beck album and a 192 versions of Mutations by them is missing. So 2 of 6 Beck Albums show up.

I got rid of about 10 *.ape files I found, didn’t help after force rescan. Do I need to get rid of all *.cue files?

@Samir_Jain I was having similar issues with albums missing… Please try this. Create a folder for “Beck” then copy/move all the Beck albums in to the Beck folder… after that do a Force Rescan and see if the showup… They did for me…

1 Like

Hi @Samir_Jain ----- Thanks for the follow up and the feedback, both are appreciated! The proposed test that @Jorge_Valdes is sound and I would like to suggest the same to see if we can trigger a change in behavior here.

To reiterate on Jorge’s comment:

" Create a folder for “Beck” then copy/move all the Beck albums in to the Beck folder… after that do a Force Rescan and see if the show up…"


I did that last night. Getting this (see below) for 24 hrs… No change in Beck album avail…

Hi @Samir_Jain ----- Thank you for trying the proposed test and sharing your observations with me.

Moving forward, I’d like to try and test with one of the albums your are experiencing this issue with in house to see if we can reproduce on our end. Would you be able to PM me a dropbox link to download? Let me know.


Thanks @Samir_Jain – I grabbed some of the media and we’re going to take a look. We’ll be in touch.

1 Like

Hi @Samir_Jain ----- I wanted to touch base with you as I have had a chance to test the media you provided to us (thank you again). I can confirm that I was able to successfully import the content from local and network storage.

Moving forward, could you please provide the exact path(s) of the Beck album(s) in question.


Eric Thx. Actually Id say a 3rd or more or my albums aren’t showing up. Its very hard to get synology folders to get added to the library. I had to use the smb path as seen in the 5th image in my first post

the path to the folder its:

afp://SFJ-SynologyNAS._afpovertcp._tcp.local/music/Digital Music - Auralic Aries Mini/Beck/Beck - Morning Phase 96/24 FLAC


1 Like

Isn’t the / in 96/24 likely to cause some issues since / is ususllay used in indicate a new folder.

1 Like

Yup philr !!
That was it. I just changed the / to a . on the Beck Morning phase album force rescanned and there it is…in my library. Ill have to do this for all my folders as a good numb of them are defined this way. Eric Thx. Ill let you know you if any further problems.

Thx much philr

Samir Jain

1 Like

Great, a bit of a guess on my part but glad this solved your problem.