Mark Levinson No519 not Visible

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus+ 1.7 build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Apple Airport Extreme as router and switch. Wired connection to Nucleus+ and to No519, wireless only to iPad

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mark Levinson No 519 analog outputs

Description Of Issue

Previously using a BluSound Node2i/Bryston DAC without issue, unplugged the Node 2i’s ethernet cable, plugged it into the ML No 519 and it never populated. I have rebooted the Nucleus+ and the ML No519. No change. The ML No 519 is on the network and same subnet. Using ML app, it streams Tidal etc.

One additional data point. The firmware on the ML No 519 is the latest and has been verified as up to date.

Hi @Deniz_Daldal,

Can you please share a screenshot of your Roon Settings -> Audio tab?

Is there any change in behavior if you reboot your router? What kind of switch are you using, what is the model/manufacturer? Is it a managed switch or an un-managed switch?

I rebooted the router just now. No change. I then rebooted the Nucleus+ and 519. Still no change. I am using the router’s built in 3 port unmanaged switch for the ML No 519 and Nucleus+, the third port goes to a managed Cisco SG200 switch where the NAS and other network equipment are landed.

I am still unable to enjoy Roon with this source… what is the next step?

I’ve used the ML 519 with Roon in the past without any issues, it was rock solid in my system.

Router built in switches can be very hit or miss. If you can I would suggest picking up or borrowing an independent unmanaged switch and connecting that to your router. Then feed one supply from the switch directly to the ML519, you can also remove the managed switch from the router and supply that from the same switch.

I use Netgear GS… switches throughout the house using this method and everything is rock steady. It’s worth a try and may solve other problems down the line.

Hope this is of some help and best of luck.

Thanks for the encouragement! Glad to hear it is possible.

I just tried unplugging my switch and keeping everything on the small 3 port unmanaged switch of the AirPort Extreme… that didn’t help.

I talked with a buddy who is an IT professional, he doesn’t think it is a network issue since I can see everything on Fing and it is all on the same subnet. That said, if stores in my area were open, I’d pop out and buy a Netgear GS switch that is working for you, but right now that isn’t an option. Which series GS switch are you using?

I still think it’s worth a try as strange things happen on networks. The ones I use are all ProSAFE GS108v5 and GS105v5 and they work perfectly and fairly cheap to buy.

Let me know how you get on if you do decide to give it a go.

Hello @Deniz_Daldal,

The fact that your Bluesound Node 2i is discovered when connected to the same network switch makes me believe that this is not a networking issue. There are some possible network interactions that could explain the behavior you are seeing, but I would focus my troubleshooting on the No519 itself before tackling the network.

I would try going through the input options on the Leviton No519 and making sure that any inputs marked “Network” or “Roon Ready” are active on the device. A factory reset on the device could also potentially clear out whatever gremlin is causing the device to not be discovered by Roon.

I also suggest reaching out to the Levinson support team, they’re in the best position to provide device specific support and diagnostics.


In view of what John has said can I assume that you’ve been through the settings menu, see below which is taken from the manual. It should be set to Automatic or Wired only and not Wireless Only:-

o Configure: use this setting to connect to wired or

wireless networks.

 Connecting to a Wireless network:

• Ensure that Connection Type is set to

Automatic or Wireless Only (and not

Wired Only).

• To connect via network name (SSID),

either click Scan available networks or

input the network name manually. If

input manually, set the Encryption type

as well (None/WEP/WPA-PSK). Enter

the network key (password) if applicable,

scroll down and click Connect.

• To connect via WPS, first press the

WPS button on your router, and then

the WPS button on the rear of the №

  1. Alternatively, you can also use

the Start WPS setting instead of the

physical button, found under Configure


 Setting up a Wired network:

• Ensure that Connection Type is set

to Automatic or Wired Only (and not

Wireless Only).

Connect a network cable.

• If Wired connection does not

automatically connect, navigate to

Connect under Configure > Wired.

• If needed, you may disable DHCP and

set a static IP under Configure > Wired.

Thank you both. I couldn’t find any “Roon” or “Roon Ready” settings in the Mark Levinson setup menu. Scott, did I miss something there? I do have it set to wired network, and it is on the network and the ML app works… I also called ML and discussed this with them before reaching out here. The ML tech said he thought it was a Roon issue.

I’ll try the factory reset and let you know if that works.

A factory reset made no difference, rechecked the network settings and they are very straight forward. I unplugged the Ethernet cable and plugged it into the Node 2i and the Node 2i immediately populated in Roon.

Quite frustrating!

I feel your pain! There’s nothing worse trying to fault find and getting nowhere.

Stupid question and I hope you don’t mind me asking but can you confirm that the updated firmware is Build 595?

Hopefully you get to the bottom of this as I’m sure you will be very pleased with the results.

Is this where you are seeing the build version? When I click on update firmware, it searches the internet and then comes back saying I am up to date.

Again, thank you so much for your help!

It’s the wrong firmware. The new firmware that includes Roon is Build 595. If you look on the ML website you will see that the new version is there ready to download. You need to download it and update via the USB method. There is instructions for this as it takes quite a long time to update and MUST not be interrupted. See if you can find the instructions before doing the update, if not get back to me.

This is the download page:-

This is the update procedure:-

1 Like

Awesome! I’ll report back.

No problem. Just make sure you follow the update procedure to the letter as you might think it’s done but it may still be updating. Make sure there is nothing else of the USB stick as it wont work, no folders, nothing. Hope you get on okay.