Massive CPU resources all the time - Roon idle

Core Machine (Operating system/System info/Roon build number)

iMac 27" 2019, 10.14.6, 40GB RAM, Roon Build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi, Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

MOTU stack (1248, 16A, 24Ai) - AVB audio

Description Of Issue

I have stopped using Roon (but foolishly let the account renew) because every time I try, the fans ramp up, I see processes showing Roon at 400% or so, CPU utilization in the 25-30% range, and have an overall sense that something is completely misbehaving. These are numbers I associate with Final Cut doing stabilization, not a music player lying idle with nothing selected.

I know there have been a ton of threads on this topic, which is alarming enough, and I jumped on one with a “me too” post that is probably not useful, so here goes with a new topic as suggested by the Facebook page maintainers. What can I do to get this back under control so I can simply use it as a local music player? I am not trying to do anything particularly complex, and we are way past updating album cover art (which seems to be a common triage first-reply).

If it weren’t so inscrutable, I would tell you what it is trying to do… but honestly, it is just sitting there with the fans at full blast. No filckers of the activity icon or any other indication that it is trying to do anything.

I’ve gone back to iTunes in recent months, just to play my own files, and I am constantly reminded by its awful user interface why I was SO happy to kick that to the curb when I got Roon a couple of years ago.

Thank you for any help…

Not sure if you can get any refund on a renewal but its worth flagging @accounts to try. Looks like you joined in Nov '19… if so its not a renewal then?

Anyway I do know there are several suffering this issue and the support guys are working on it so additional diagnosis as always going to help.

Hi @Steven_Roberts,

As @wizardofoz mentioned, we are actively investigating this issue and what we have found so far is that this behavior seems to be related to the network stack.

Other uses have mentioned that turning their Mac WiFi adapter off/on or rebooting their PC temporarily resolves this behavior, can you please check to see if this is the same on your end?

As for the account status, this is best to be discussed in a private setting, I will start a message thread with you and we can discuss how you would like to proceed. Thanks!

UPDATE: This is fixed, thanks to Noris.

Cycling the WiFi on the Mac, even though is not in use, immediately solved the problem.

I really appreciate the helpful suggestion, and it’s great to have my music again! So much better than Alexa… :slight_smile:


1 Like

Hi @Steven_Roberts,

Glad to hear that toggling the WiFi worked on your end! As I mentioned in the private message, this is not meant to be a permanent fix, but something that you can do when Roon gets into this state while we complete our investigation with QA into this issue. Thanks!


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.