Matrix Element X no longer shows up in Roon-ready device list

Anyone else have a problem like this?
My Matrix Element X no longer shows up in Settings/Audio as a Roon-ready device.
It does show up under “other network devices” via Airplay.
This happens even if I choose “LAN” (not WiFi) in the Element X network settings.

I’m using the latest versions of Roon (1.8), Element X firmware, and iOS (15).
I first noticed the problem after upgrading both Roon and iOS software, when I went to test some new features. The software upgrades could be coincidental, though, because I’d been using the Element X for a long time through a USB connection.

My troubleshooting efforts so far have included:

  • power cycling various devices (routers, Element X, music server)
  • switching the network settings back and forth between LAN and WiFi
  • switching router ports
  • deleting and re-discovering the Element X in the MA remote app
  • re-loading the original Element X settings
  • disabling and re-enabling devices in Roon
  • changing the IP address assignment

Hey @Tom_K,

Thanks for sharing with us the issue as well as the steps you’ve tried already :pray: . We’re grateful for your efforts in trying to resolve this.

You’ve already tried so much, but I might have missed this: is there any firmware update for the Matrix Element X? If so, could you please try updating it? :pray:

Thanks. The Element X firmware is up-to-date.

A couple other observations:
When using the Matrix MA Player (an iOS app) to play either from a USB thumb drive attached to the Element X, or from Tidal, songs start playing but then abruptly stop after a few seconds. The same thing happens when playing from Audirvana Studio (over DLNA). But Roon works fine via USB connections. Audio works fine, too, with an optical (Toslink) feed from my TV.

Thanks for confirming, @Tom_K.

We appreciate the additional context - since this is happening with more than just one software, did you get a chance to connect with the manufacturer? Are they aware of this issue?

I contacted Matrix Audio support. Their only suggestion so far has been to make sure the Element X was enabled in Roon. Yes, I’m aware that devices need to be enabled (as well as plugged in and turned on.) Unfortunately, enabling it as a Roon-Ready device is not possible, since it does not show up in the Roon-Ready device list at all.

Another observation:
In the Roon Remote app Settings/Audio options (on my iPhone), the Element X shows up under “Other network devices” as “Matrix1 (Shairport Sync)”. I assigned the “Matrix1” name in the MA app … but I do not know where the “(ShairportSync)” comes from. I wonder if some application might be hogging the Element X, via “ShairportSync”, and not relinquishing control to Roon … or something like that.

Hey @Tom_K,

Thanks for keeping connected and for sparing no effort in figuring our what’s going on, even if that means talking to more than one person or company.

I appreciate all the details. I’m looping in our technical team to see what else is visible on our end and hopefully come up with next steps :nerd_face:

Stay tuned

Still have not fixed it.

This morning I tried attaching (via ethernet) another Roon-Ready device (a Bluesound Node 2i) to the same router that handles the ElementX. Roon quickly recognized the Node 2i as a Roon-Ready device. I already had reset the router, too. So I’m fairly confident we can rule out a network problem.

I’ve tried resetting/rebooting the ElementX several times. Also reached out to Small Green Computer (maker of my sonicTransporter music server). They did not suggest any troubleshooting steps, other than to contact Matrix Audio (which I’ve done).

The ElementX continues to work fine as a USB-attached DAC, as a Roon AirPlay receiver (with its own IP address on the LAN), and for TV audio via Toslink connection. I wonder if these facts suggest it is probably NOT a hardware problem.

After rebooting my music server (sonicTransporter i9) and the Element X,
this line shows up in the Roon Server Diagnostic Information:

09/29 11:43:20 Trace: [devicedb] [autodetect] No Match for DeviceAutodetectData[Type=AirPlay Model=ShairportSync DescriptiveName=Matrix1]

In contrast, here’s what I see for a Bluesound device:
09/29 11:42:36 Info: [devicedb] [autodetect] Match DeviceAutodetectData[Type=RoonReady Vendor=Bluesound Model=PULSE FLEX] => Bluesound PULSE FLEX

Hey @Tom_K,

Thanks for making the effort to keep us updated and give us all the info you have to sort this out.

I’ve reached out to our Roon Ecosystem Expert and he’s taken a close look at your thread. It seems that, if the firewall is disabled, these symptoms are associated with a device issue. Any chance Matrix Audio can take a look at the hardware device?

Matrix is in China. They do not seem to have a North American service/support operation. So I’d like to rule out non-hardware issues before shipping the device off to them.

Hi @Tom_K,

Here are the two most likely scenarios that explain why a device would suddenly not be discoverable in Roon.

A) Something has occurred on your Roon Core or on your network that is preventing Roon from seeing / discovering the zone. Think firewall or something similar.

B) Something has occurred on the device that is causing it to not be discoverable by Roon. Possibly a bug in the device’s firmware preventing the RAAT SDK from running correctly.

The fact that your PULSE FLEX is discovered as a Roon Ready zone suggests that your network is not the issue.

The fact that your Element X is otherwise operating normally and is discoverable using AirPlay makes a hardware issue unlikely.

I suggest reaching out to the Matrix support team as they’ll be best positioned to troubleshoot what’s occurring on device.

As a last ditch troubleshooting exercise you could try temporarily running Roon Core on a different machine to see if it’s able to pick up the Element X. When you attempt to run Roon Core on a different machine it will prompt you to deauthorize your existing Roon Core. This is a safe procedure and can be reversed when you’re finished with your testing.


Thanks, John.

I already had tried running Roon Core on a different machine
Same problem. The Element X still was not recognized as a Roon-Ready device.

Between the last time I used the Element X successfully as a Roon-Ready device, and the time I discovered this problem, the Element X apparently did receive a firmware upgrade. I did not use it in Roon-Ready mode immediately before and immediately after this upgrade; other parts of the ecosystem did change in the interval. Nevertheless it seems to me that the firmware upgrade is a plausible (even likely) culprit.

Which firmware version is your Element X on? B91901 ? Everything works great here

Yes, I’m on B91901 too.
Very strange.
Matrix Audio hasn’t suggested anything more since advising me to power cycle the unit
(which I’ve done several times).

Issue resolved.
The Element X apparently had stopped reporting its serial number correctly over the home network. Matrix Audio sent me an easy-to-use, browser-based software repair. Now Roon recognizes it as a Roon-Ready device.

1 Like