Matthäus-passion BWV244 (La petite Bande Sigiswald Kuijken) correct identified but not correct handled


This version of the Mattäus-Passion is correct identified by Roon. SACD x 3 La Petite bande Sigiswald Kuijken.
However, when I look up all the versions of the BWV 244 (have 3 others) this one is not listed.
It isn’t recognised as BWV 244. How can I correct this?
When playing it lists 68 compositions, I can’t choose multipart composition in the edit album screen.
Because it is identified by Roon, but not correct handled, maybe the solution is with rovi?

Hi @PhiloMelos,

Our metadata providers don’t have a lot of information on this particular album, so we don’t have data about the composition. The best option is to use WORK/PART tags.

The WORK name should be St. Matthew Passion (Matthäuspassion), for soloists, double chorus & double orchestra, BWV 244 (BC D3b).

Let us know if this helps!

No, didn’t help. Tried that allready. And that’s strange, isn’t it? Because Roon should then know it is that particular composition? It drives me crazy!
How do I use the Part tag? When I made a new tag called Part I only get filenames (in Roon!) that are 1 or 2. It recognises the Passion correctly! So I must doing something wrong with the Part Tag.

Hi @PhiloMelos,

From the Edit Album screen, toward the bottom of the list of options, you’ll need to choose Prefer File for composition grouping.

If that doesn’t help can you share a screenshot of your tags?

Did that, but doesn’t make a change.
I deleted the Part Tag in id3tag.

This is how it shows. Note that I’m not able to choose Multipart 68 tracks, 1 performances.

Because for that to work you need Work and Part tags in your files. See also File Tag Best Practice. You can theoretically delete the Title tag, or rename it to Part if your editor allows that, as the track title is no longer needed when multi-part compositions correctly work, but I think it’s best to keep the title should you ever want to use your files with a player that doesn’t support multi-part compositions (Work/Part tags).

Other users also reported that the work and part names should match what AllMusic provides so:

I think I’ve got it. I have to rename all the idtags with Teil I or Teil II (That’s part in German) in front of their original filename.
I think AllMusic is not correct with the number of files. I have four versions, and all 4 have 68 files. But thanks for helping me out.

That didn’t do it. But then I made Part with each trackname, and now it’s showing allright.

But what I don’t get is while Roon is identifying the cd, so it knows it is BWV 244 I have to go to rename all individual id3tag. That’s ridicoulous. Then don’t identify the record! My God, stupid program!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.