Mature Roon Library suddenly cannot be found by any Roon control points

Roon Core Machine

QNAP TS-451+

Server name TS451
Model name TS-451+
CPU Intel(R) Celeron(R) CPU J1900 , up to 1993 MHz (4 cores, 4 threads)
Serial number Q162I07910
BIOS version QW37AR32
Total memory 8 GB (8 GB usable)
Dual channel supported NIC_VIEW_YES
Memory slots 2 (4 GB / 4 GB)
Firmware version Build 20211221
System up time 0 Days 7 Hour 43 Minute(s)
Time zone (GMT+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna
Filename encoding English

Networking Gear & Setup Details

Ethernet connection,

Device name: B525s-23a
IMEI: 861920038042526
IMSI : 262011408993269
My number: +4915117617365
Hardware version: WL1B520FM
Software version:
Web UI version:
LAN MAC address: A0:57:E3:FB:BD:B2
WAN IP address:
WAN IPv6 Address: 2a01:598:b890:d92b:5a02:3ff:fe04:506

TP Link 16-port unmanaged switch

Connected Audio Devices

Raspberry Pi 3 running RoopieeXL- ethernet
Raspberry Pie running RoopieXL - ethernet
Ryzen PC AMD Series 7 32GB RAM running Roon - ethernet
QNAP TS451+ running Roon Core - ethernet
Various streamers from Cambridge Audio - ethernet
Linn Majik DS - ethernet
Motorla G( Pro mobile phone - wifi
Samsung Tab S5e - wifi
Asus Zen 10s Tablet - wifi
Motorola Xplay phone - wifi
Various other Android devices

Number of Tracks in Library

3600 Albums

Description of Issue

Roon was functioning fine one day but when i tried opening Roon on any control point the following day i got a message saying it was taking longer than usual to load… nothing more.
eventually, getting a bit irritated, i clicked on connect to a different Core and it immediately showed my existing core. When i clicked on use this core, it insisted i log in to Roon and when i tried this it then asked for the location of my music files. Alarm bells start ringing - has it lost my library?. checked all the important things i can think of: the SSD where the Roon library is stored - it seems OK. the actual parth it is trying to use: seems OK, access to the NAS itself: seems OK. since i have logged in to Roon again, the control points now insisit i select a new core and don’t look for the ‘original’ any more.

What has happened? - this has occurred before but the last time a QNAP update renamed the SSD and this messed up the libray path etc. Spotted this quite quickly, changed it back and all was good again. This time, however, solution not so simple to find. i can’t do anything and i will be really ■■■■■■ if something has corrupted my library. Any suggestions gratefully received

No response from anyone - Roon Support?

I’m getting desparate here, i’ve not had any contact from anyone - is this posted in the correct place? i posted my original issue 5 days ago and i see posts that are even less than 1 hour old have already had replies. Can anyone help with this issue? i can’t use Roon at all.

Graham you have posted in the right place, but posted on the weekend by the look of it so it might have been missed as support only work Mon-Fri.

Can someone from @support please get in touch with Graham

I assume you have tried the usual magic bullet of restarting Roon in your QNAP and if that didn’t work rebooting it?
Often recommended to reboot your Router and networking gear as well just in case.

Thanks Michael. Yes, i have tried all the usual troubleshooting steps - the control points don’t appear to recognise the existing core - but do see it as a new core (although it’s exactly the same one). it’s possible the QNAP did a firmware update and i have had a similar problem before but this time, i cannot work out what’s happened. i can’t restore a backup because a) I’n not sure i actually have one and b) don’t know where it is if i do.

Well the backup is a problem for another day, but you will want to get to that when support help get you back up and running.

still no contact from @support, this is very strange - previously they have been pretty fast.

Hey @Graham_Knowles,

Our deepest apologies for the delay… :pensive: . We’d really love to help out, so, I was wondering if you could please grab a set of logs for your QNAP and upload them here?

Whenever you get a chance to upload them, would you please let us know?

Hi Beka. Log files are uploaded.

I’m experiencing the same problem. I recently changed my router and since then I cannot find Roon from any of my endpoints (tablet or mobile phone). I have rebooted the router, disconnected and reconnected Roon, disconnected and reconnected the Roon apps on my tablet and phone and nothing helps. I just get a message saying ‘looking for your Roon Core’. Even within Roon on my laptop (where my music files are stored) where I should have a feature in settings to configure my Roon Core I just have a button that says ‘Find Roon OS’ and it doesn’t find it! I have tried scanning for my IP address and that doesn’t work.
I can send music directly from Roon on my laptop to my streamer but I cannot use my tablet as a remote control to access Roon. Fortunately I can still access Tidal Direct on my streamer.

I logged the problem with support last Saturday evening (UK time) and no one has been back to me other than an automated reply.
All other devices in my home can access the new router.

hi @beka . log files are uploaded

Thanks so much, @Graham_Knowles. We got them! :nerd_face:

As soon as our technical team returns to work on Monday they will see them. I’ll follow up as soon as they share their insights.

Please, stay tuned :pray:

@support any joy yet? it’s been 14 days since i first reported the problem and in this time i have not been able to use Roon. i’m a bit disappointed that I’m still waiting for a helpful reply. this is not the quality of support i was expecting and not my experience when reporting previous issues. An update would be appreciated

Hey @Graham_Knowles,

Thanks for the incredible patience you’ve shown. Actually I just heard back from our technical team.

The logs show that there was a change of database location via the RoonServer QNAP interface. Since we don’t have visibility over where it was moved, could you please search via the QNAP interface for a RoonServer folder. Can you find one?

It’s also worth searching for roon_backup_root or roon_backup_ (if you find any of these files, they accompany the Roon backup).

Fingers crossed :crossed_fingers:

Hi @beka . Yes, it is in (as far as i can tell) the same location it always has been on a dedicated USB SSD drive. See attached images.
No roon_backup_ or roon_backup_root files.

Hey @Graham_Knowles,

I noticed that you have two RoonOnNAS folders listed in your second screenshot, one under Roon and one at the bottom:

If your old database by any chance in the bottom RoonOnNAS folder?

Hi @beka perhaps i’m using the wrong language when i describe my problem.
Roon control points can’t find the original core and promt me to select a different one: the only option being the very same core that it just said it can’t find! if i try and connect to this core it asks where my music is stored it makes no attempt to look for an existing library nor allow me to specify the location of an existing library. I’m getting very frustrated now. it’s now 18 days since i reported this issue and we have made no progress.

BTW, i received a reply from you in my email (and responded) in which you ask me to restore from a backup which i have already mentioned that I couldn’t find. Neither of these messages are showing in this thread. Where are they?

Hi @Graham_Knowles ,

The way that QNAP database location is changed is through the RoonServer QNAP interface, example:

Change database location

According to logs, it looks like the current database was created on 01/27, there are no log files older than that present.

Have you checked this folder? Perhaps you had the old RoonServer folder in here and accidentally changed it.

Hi. I thnk i have resolved my issue and it is not impossible that i am partly responsible for the problem. The QNAP NAS did an update and immedately after this Roon failed to start. I have had this problem before (as previously stated) and the cause turned out to be a change of the drive nomenclature so Roon couldn’t find the database. On this occasion, i suspected the same issue and when i looked as the databse path it seemed to be wrong (instead of pointing to the database in the Roon folder, it was looking at the root of the drive instead. As i hadn’t made any changes and Roon hadn’t provided any notifications that a change had taken place, i changed the path back to where it was originally. This produced no change and Roon still couldn’t find the core, resulting in my requst for assistance.

As i have had no Roon for nearly three weeks, yesterday i looked at the file structure again and just as a sanity check, i pointed Roon back to the root of the drive. Hey Presto! This time Roon started, found the core and then said it had been updated and needed to update the database to use it. It did this about three times, taking quite some time and then opened fully and seems to work now. i can’t help feeling that this problem has occurred because Roon has made changes to the file structure without informing the user. I had no idea it had created a new group of files and the old (Roon) folder no longer contained the current library.
i would like to suggest that when changes like this are made, Roon reports it to the user somehow - either as a notifcation or in the settings or it emails it so it is clear where the active database is.

i appreciate the help you provided nevertheless.




Hi @Graham_Knowles ,

Thanks for letting us know that you were able to resolve this behavior!

I am not aware of Roon making such folder changes, but since your install is on QNAP, I’ll flag @crieke to look over these details. In any case, glad to hear the issue is resolved and do let us know if you run into further difficulties.

1 Like