MBP not showing up as an Output/Zone

I have just noticed that the MacBook Pro from which I control most of Roon’s operations on my network is not listed among the output devices in Roon’s Audio menu.

It controls everything well, but I wanted to use it as endpoint to play music today, and I couldn’t find it in the Audio menu to select it. What am I doing wrong?

That is odd. So you went to the audio menu in settings and could not see it?. It’s always the top most device in the audio settings menu. Never heard of it not showing up.

Make sure you have enabled the audio device.

And if you need to understand the difference between system and built-in output read this:

Yes, it is not showing up in the audio menu… There is no reference to “This Mac” at the top of the menu, as you can see in the screenshot below. At the top, I only see “connected to core,” and the core is a dedicated mac mini, not this Mac book Pro :slight_smile:

My understanding is that the only “System Output” and “Built-in Output” showing up in the audio menu are those of the Mac mini on which the Roon core is also located. It is as if Roon is not seeing this Mac Book pro at all.

How strange. Something must be blocking Roon bridge from running. I know this may seem daft but for sanitys sake you have installed Roon on the MacBook? And you haven’t made it a private zone my accident.

Are the screenshots taken from your Mac Mini or the MacBook Pro? Also, have you used the same naming for both, e.g. System Output?

You’ll notice that the MacBook Pro should say “Connected to this Mac”. I suggest you name them after the devices, i.e. MacBook Pro and Mac Mini.

Finally, can you confirm that you installed Roon not Roon Server on the MacBook Pro?

This screenshot is from my Mac Book Pro, and there is no “Connected to this Mac” line or section in the audio menu, as you can see for yourself. References to “this mac” (i.e. my Mac Book Pro) are simply missing from the menu. This shot you see below reflects exactly what I see in Roon on my Mac Book Pro.

I do not remember which version of Roon I installed on this particular Mac, since that happened about 7 months ago, but I would typically install Roon on a machine like this, not any of the other versions. At any rate, is there any way of verifying which version of Roon I currently have on my Mac Book Pro?

I can always Re-install Roon, if that won’t pose any problem.

Thanks for the clarification.

Click on About for version information.

Also, can you confirm if you have a firewall enabled on the MacBook Pro?

The version information I see in “About Roon” is pictured below. My firewall in the MacBook Pro is off.

That looks correct; you’re on the latest version and build. I vaguely recall someone else having a similar problem and @support picked this up as it stumped everyone.

One further thought … do you use Time Machine?

I do not use Time Machine on this particular MacBook Pro. I did on my previous one, which I retired in March 2018.

Hello @sahmen,

Can you please check to see if your firewall is disabled on both the Core and the Remote using these instructions from Apple? Do you by any chance have additional firewalls/antivirus software in place such as “Little Snitch” or “Bullguard”? I would try disabling those as well.

I would also go ahead and try using a fresh version of Roon on your Remote to see if this changes anything. To set up a fresh version, you can use these instructons on your MacBook Pro:

  • Navigate to your Roon’s Database Location: https://kb.roonlabs.com/Database_Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart the Roon App to generate a new Roon folder
  • See if you are able to access the Remote from your Core

This step should look like this in Windows:


Please let me know if any of the above suggestions help.


1 Like

I have firewall disabled on both Core (Mac Mini) and Remote (Mac Book Pro).

However, the following could probably simplify things quite a bit:

This Mac Book Pro was configured for me by the IT department at my place of work, and they installed McAfee Antivirus on it, which they do for all laptops that are usually taken to the work place to be used. I just opened the console in McAfee and found both firewall and firevault enabled on it. If I can disable both without exposing my Mac to any unnecessary extra hazards, and get Roon working properly as an endpoint/output then I shall do that.

It is funny because I have never installed any antivirus on any of the macs that I have configured myself, so this is my first of several macs that an antivirus software installed,… I’m asking before disabling firewall on the McAfee suite as a necessary precaution, only because of the initiative of my work place’s IT department took in installing it on my computer. Do they have a genuine point for taking that precaution?

The other question is that, at present, no firewall is blocking the Remote Roon on my laptop from controlling all Roon’s other activities on the network, including communicating with the Core. If there is some firewall activity going on, then it only seems to involve a selective shut-down of the “output”/endpoint functionality of Roon on my laptop. Is this selective blocking possible?

Should I start by installing a fresh version of Roon on the MBP, as per the instructions you have given, before disabling firewall on McAfee antivirus?

I have just reinstalled/refreshed Roon, as per your instructions, and reconnected to the core successfully, but that landed me exactly where I was before. Roon on my Mac Book Pro works well as a remote, but it does not seem equipped to act as an output/endpoint, or player, and Mac is not identified and assigned a separate zone in the Audio menu for playback functionality.

On the other hand disabling Firewall on McAfee Antivirus seems to solve the problem, but only temporarily. In the picture below, a “This Mac” section is appropriately showing up in the Audio menu of Roon, after the antivirus firewall has been disabled. However, the McAfee Firewall seems to interpret the firewall shut down as a risk, and it turns itself back on after about 2 minutes, at which point the “this Mac” section disappears again. I do not know how to make the McAfee firewall stay disabled : And yes I have to unlock the mac before disabling the firewall, and relock it to prevent any further changes. The firewall automatically turns itself back on independently, in spite of these operations.

Hello @sahmen,

Since the issue here is with McAfee, I would check to see if there is a way to exclude Roon from that firewall. I have found this documentation and this guide that may help. I would make sure that both Roon and RAATServer are added as exceptions to your firewall. Different types of firewalls block different aspects of programs, and in this case McAFee is blocking the discovery of your Remote as an endpoint so I would really look further in this area or ask the IT department who set it up as to properly allow Roon to bypass this firewall.


2 posts were split to a new topic: Missing Audio Outputs [Resolved]