McIntosh d1100 with Roon help

Hello,

I just added a new McIntosh d1100 to my system. Generally speaking, it works great, but there are a few quirky things that I was hoping I could get some help with. I’m not sure if maybe there are some settings I can adjust to fix these things.

My setup: Roon core runs on a dedicated Ubuntu Linux VM. I have Roon endpoint on a few Macbook’s, my iPad and my iPhone. I have a Raspberry Pi 2b with the latest build of dietpi on it, and Roon Bridge installed. I then utilize the USB to connect to the McIntosh d1100. Everything is running the latest builds of Roon. DSD over PCM (DoP) is my DSD strategy. Raspberry Pi and Roon Core is hard wired 1Gbps Ethernet

My issues:

  • Whenever I play an album, there is this weird thing where I miss the first bit of the first track. How much I miss seems to depend on source. For 16/44 CD quality, it is the first fraction of a second. For DSD it could be 2-3 seconds. In Roon, you can see the file playing the first few seconds, but the DAC does not lock and start outputting sound until between about 0.5s to 3s later, depending on source.For example, when playing The Beatles Please Please Me album, starting with “I saw her standing there”, you don’t hear the first part of Paul’s count in. When kicking off “A Hard Day’s Night”, you miss the first part of that epic first chord. This seems to happen regardless of what the source is (PCM, DSD, Various sample rates) and on every album

  • There is an intermittent issue with losing lock between tracks of an album. What happens is that at the end of one track of the album, typically during silence or low output parts during the last 3-5 seconds of the track, the DAC loses lock. Roon will still show the track playing. Then, Roon will move to the next track, the DAC regains lock and away it goes. It’s like a little “blip”. Sometimes, I end up missing just the first split second of the next track. This doesn’t happen between ALL tracks, or even between the same two tracks consistently. The issue seems to happen more frequently with DSD or high resolution PCM.

Sometimes, other than missing the first second or so of the first track, the album plays fine, with the DAC consistently keeping lock track to track. For example, when playing 16/44 ALAC source material. Other times, the DAC continually loses lock when one track ends, and locks back on for the start of the next track. For example, I saw this when playing a 24/192 and 24/96 FLAC albums. Other times, it will lose lock after one track, then lock on for the next track, but I miss the first half second or so of the next track. This happens with DSD and high resolution PCM, but not all the time, and not between every track on an album. Very inconsistent.

I have tried playing with difference resync timer values, anywhere from 0.1s to 1s to 2s to even 5s just to see what would happen, as well as trying 250ms buffer to no avail. I also tried plugging my MacBook Air running Roon endpoint directly into the DAC, and experience the same problems.

Anything I can do or any ideas? It sounds GREAT, but losing the first few seconds of every album and the inconsistent inter-track behavior is really taking away from the album experience.

Thank You

  1. should be a few ms fade in and out as per the firmware fix, not missing seconds.

Try a different end point or direct connected to your computer and see if it behaves itself.

1 Like

Thanks for the reply. After quite a bit more testing, I revised my initial post to be more accurate with regards to what I am experiencing

Hello @joey_corleone,

Could you try switching your Core to run on one of your MacBooks and then plugging your d1100 into it via USB directly? Do you see the same behavior using this setup?

-John

Hi @john

I’d be willing to try that I suppose. I forgot to mention that all the music is stored on a separate NAS box as well. I wouldn’t mind trying your suggestion just for a test, but I’ve put months of work at this point into my roon core, and I don’t want anything to be messed up if I switch to another core for a test, then go back to the one I am using now. What is the best way to do that?

I really don’t think we are going to see any difference. I think what I am hitting is a result of how McIntosh implemented the firmware on their d1100. You can read about it here under the heading “The USB interface”. Look at how he describes the “fade-in problem” - That is exactly what I’m experiencing. https://www.computeraudiophile.com/ca/reviews/mcintosh-d1100-digital-preamplifier-dac-review-part-one-r664/

McIntosh’ solution will likely be “use JRiver”, as they have a setting to add 2 seconds of silence between tracks that seemingly fixes this. I don’t want to use JRiver though…

I love my McIntosh pre and monos, but don’t reward them with my DAC business. Their half assed implementation and fixes just isn’t worth the grief to have matching boxes.

I commend you if you are willing to put up with it. I just moved on.

2 Likes

I am going to give them the chance to address this. If it doesn’t work out, I will promptly return my d1100 for a refund and put that money toward something that works reliably for me, like perhaps a Manhatten II. It would be a crying shame, because the d1100 does sound amazing. However, I’m an album guy. Clipping the first second or so of just about every track is not acceptable to me, especially at this price point.

Joey

To elaborate more on the root cause and observations

  • When you start playing an album, the DAC is muted until it sees a signal with a certain very low amplitude

  • At the end of a track, if the signal flat lines the DAC mutes and loses lock. This in turn causes the problem where the very start of the next track is muted

  • At the end of a track, as long as the input signal and thus the fixed output of the DAC is not completely flat lined, it will keep lock and transition beautifully to the next track with no problems

This explains why some albums exhibit issue #2 and some do not.

So, I think a way to solve this would potentially be a feature in Roon that could pre-emp tracks with x seconds of “silence”. As long as the DAC sees some kind of amplitude, it will hold lock and unmute. I believe that would solve both problems, and I think that is the option JRiver has that makes it work more flawlessly with these McIntosh units.

what say you, Roon @support team? Is this a reasonable theory, and something I can reasonably hope for in a future release?

Joey

This feature has been requested before but for the life of me I can’t find the thread. If memory serves the Roon team didn’t think that would solve the issue and the DAC would still pop or mute in your case.

Maybe near silence is what you need to prevent the issue, not actual silence.

In all honesty if it’s happening between tracks in an album that’s some crappy solution to alleviate popping noises.

Yes, that’s exactly it. You would need a signal that is basically silence but just enough amplitude so that the DAC does not lose lock and mute.

I know this from testing. On some albums, at the end of a track, the d1100 fixed output meters do not go totally flat lined, and in those cases there is no problem. I tediously tested this.

I agree, the firmware implementation is shitty.

@john and @support - In an effort to simplify everything, I tried John’s suggestion as follows:

  • Simple setup of Roon running everything on a single MacBook Air. So, Roon core on the MacBook Air. Files stored directly on the same laptop. USB from the MacBook directly into the McIntosh d1100.

I have the exact same result. So, at least we know

  • It has nothing to do with my NAS
  • It has nothing to do with core <–> NAS latency
  • It has nothing to do with my network
  • It has nothing to do with the roon bridge, raspberry pi, or dietpi software

I am also engaged with McIntosh support on this and will update if and when I learn something.

Good luck, you might want to tell them you are going to do a review, they seem to respond appropriately then.

Following up - McIntosh addressed this issue with d1100 firmware v1.03. It adds an option to toggle USB auto mute on or off. The default in the new release is off, which fixes the issue where you miss the first 1/2 second of the first track and some other tracks

Be aware, it also re-introduces some “popping” issues that they implemented v1.02 to address if you disable USB auto mute.